+ Start a Discussion
Alejandro MorenoAlejandro Moreno 

Partner Accounts External User - Unable to login to Community

I am setting up a community. I have been able to enable it for internal users.

I created a Partner Accpunt, and added a Contact within the account and enabled the Manage External Account option. The contact didn't receive any welcome email (the internal account did). Using the external account email I've attempted to use the "Forgot your password" option, but still don't get an email.

I know Salesforce is sending emails, because I used the "Request Update" option for that contact and it worked.

Can someone help me figure out what I'm missing?
(The community is fgcommtest.force.com/ufc)
William LópezWilliam López
Hello Alejandro,

After you have a contact you need to create a user for that contact, here is an image:

User-added image

Then you will be pronpted to create a user, use the right porfiles for your community access:

User-added image

Finally they should get an email with a URL to set the password.

User-added image

After that all should work ok.

Please let me know how it goes.

Regards.
​Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.   
Alejandro MorenoAlejandro Moreno
Hi WIlliam --

I don't see the 

I see a different option:
User-added image

And if I pick the "Login to Community as a User" I get this:
User-added image
I even tried creating a new one (See below) and this one didn't get an email either.
User-added image

The Partner Account I created is this one:
User-added image

Is there some other reason why the users I create for the community are not receiving welcome emails?

Thanks
Alejandro Moreno
 
William LópezWilliam López
Hi Alejandro,

If your contact already have a user already. And you have that error of "No Avialable community" I will suggest check community setings. I will do the excemple with a support community but with slef service community its similar.

 Go to Setup > Customize > Communities > All Communities, Then click Manage under the community that you need to configure.

User-added image

Next, go to member, its under administration or in the Quick Links.

User-added image

Validate the profile that your customer user its using its enable for that community (Automatically all users will get an email when user its created and profile its assigned to the proper community)

User-added image

Add the proper profile and click Save (I aways forgot to save).

After this just go to your contact

User-added image

And you should be prompted to select a comminity to log in as the user, or directly redirected if there is only one valid community.

User-added image

With this it should work.

Please let me know how it goes.

Regards.
​Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.   
 
Alejandro MorenoAlejandro Moreno
William --

Thanks for your patience... This issue is SOLVED.

After going back and forth, I finally found out the problem... I had to select "All" on ther profiles... (It uses only the Internal by default).

User-added image
It was not showing my external Profile.

Thanks for your help.