+ Start a Discussion
ms-hase-q23eems-hase-q23ee 

force.COM IDE何度やってもログインに失敗する

お世話になっております、掲題のとおり前任者の方から開発環境を引き継ぎ、WEBの画面からログインを確認し、新たにセキュリティトークンを発行しました。

このセキュリティトークンを使用して Eclipse IDE + force.COM からProject propertye  -> Force.com * Username, *Password, *Security Token を設定し、Production /DeveloperEdition を指定して接続しました。

このときは何のメッセージも出ないのですが、しばらくしてclass/*.clsなどを編集しようとすると、以下のメッセージがでてログインできていない旨が表示されてしまいます。

プロジェクトXXXXX Unable to connect to organization with given credentials. ユーザー名、パスワード、セキュリティトークンが無効か、ユーザーがロックされています。

Plrease verify and /or change your credentials in Project Properties > Force.com 


どのように解決すればよいのでしょうか?
宜しくお願いします。

 
Best Answer chosen by ms-hase-q23ee
Ryosuke KobayashiRyosuke Kobayashi
はじめまして。

どうやら、Eclipseのバージョンが最新だと起こる現象のようです。
私も当該現象は確認できていませんが、同じ現象(と思われる)に遭遇している方の
ブログがありましたので、URLと手順を記載しておきます。

以下の手順を行ってみてください。
①ウィンドウ→設定をクリック
②一般→セキュリティ→セキュアストレージをクリック
③コンテンツタブをクリック
④Force Projectsを選択し、削除ボタン押下
⑤Eclipse再起動

参考URL
http://www.everythingandsfdc.net/2015/01/forcecom-ide-not-saving-passwords.html

All Answers

ms-hase-q23eems-hase-q23ee
本件は、なんかかの解決策をお持ちの方はいらっしゃらないでしょうか?
eclipse のforce.com IDEは最初はいいのですが、しばらく使っていると勝手にログイン状態が切れてしまいます。その後、project propertiesからログイン情報を(こちらもパスワードが勝手に消えてしまいます)入力すると、再度ビルドを行ってしまうため、また5~10分ほど時間がかかり、その間にログインセッションは切れます。

使えなくなってしまうのですが・・・
 
Taiki YoshikawaTaiki Yoshikawa
ひとまず以下のメッセージがでているみたいなので、なんらかの原因でログインに失敗している可能性があります。
パスワードやセキュリティトークンに打ち間違えがあったりするかもしれません。

*******************************************************************************************************
プロジェクトXXXXX Unable to connect to organization with given credentials. ユーザー名、パスワード、セキュリティトークンが無効か、ユーザーがロックされています。
*******************************************************************************************************

後は、ログインする環境がDeveloper環境でしたら「Production /DeveloperEdition」で問題ありませんが、Sadbox環境の場合はSandboxを選択する必要があったと思います。


ちょっと思いつくのはそれぐらいでした。。
Ryosuke KobayashiRyosuke Kobayashi
はじめまして。

どうやら、Eclipseのバージョンが最新だと起こる現象のようです。
私も当該現象は確認できていませんが、同じ現象(と思われる)に遭遇している方の
ブログがありましたので、URLと手順を記載しておきます。

以下の手順を行ってみてください。
①ウィンドウ→設定をクリック
②一般→セキュリティ→セキュアストレージをクリック
③コンテンツタブをクリック
④Force Projectsを選択し、削除ボタン押下
⑤Eclipse再起動

参考URL
http://www.everythingandsfdc.net/2015/01/forcecom-ide-not-saving-passwords.html
This was selected as the best answer
ms-hase-q23eems-hase-q23ee
回答ありがとうございます。

> ②一般→セキュリティ→セキュアストレージをクリック
> ③コンテンツタブをクリック

やはりこれでしたか。私も昨日eclipseをいじっている間にこの設定に行き着きました。いきなりちゃんと動くようになったのでびっくりしました。

この現象が起きると、「force.com IDE Log Viewer」で

XXXXX Unable to connect to organization with given credentials.....

のメッセージが何百件も出力されるので、同様の現象になった方は、ご注意ください。