+ Start a Discussion
Ashley LeiferAshley Leifer 

A flow trigger failed to execute the flow with version ID....error when trying to batch update contacts

I created several process builder proceeses around check boxes on the contact object.  I wanted to trigger these to update in mass so I created a hidden checkbox field on the contact object called 'Mass Update', set the value to true for all and trying to do an update. I got the error: The record couldnt be saved because it failed to trigger a flow. <br>A flow trigger failed to execute the flow with version ID 30116000000PPKL. <br/> Contact your administrator for help.

I don't have any active conflicting workflow rules on these fields.  When I tested the active processes they all individually worked. Why am I getting this for all 16K contacts i'm trying to update using Jitterbit? 
PratikPratik (Salesforce Developers) 
Hi Ashley,

Did you get an email containg this error message and the error caused by reason? it consists of error details. If you can share that so we can help you to resolve the issue.


Sample:
I get this error in the page:
"The record couldn’t be saved because it failed to trigger a flow. 
A flow trigger failed to execute the flow with version ID XXXXXX. 
Contact your administrator for help."

Also, as an admin, I get an email that says:  
"Encountered unhandled fault when running process <lightning process name here>/XXXXXXX exception by user/organization: XXXXXXXXv8/{4}
Cannot submit object already in process.
 
caused by element : FlowActionCall.myRule_1_A1 
caused by: Cannot submit object already in process.

Salesforce Error ID: 616817129-17288 (978718756)."


Thanks,
Pratik
Ashley LeiferAshley Leifer
Hi Pratik, 

No I didn't get an email because I was using Jitterbit to do a mass update on all records on the contact object to trigger the flows I'd created. The update returned this error on all the records in the jitterbit error report. That's all it said in Jitterbit : The record couldnt be saved because it failed to trigger a flow. <br>A flow trigger failed to execute the flow with version ID 30116000000PPKL. <br/> Contact your administrator for help.

When I had tested the processes manually on a new record after I created it they were triggering just fine. 

I had ran into this previously and found it was because there was a conflicting workflow rule but that isn't the case this time.  

Not sure how to troubleshoot otherwise to get an email with more details, ideas?

Thanks
Ashley 
Ashley LeiferAshley Leifer
Hi Pratik,

Is this something I can get help with? Should i just revert to making a bunch of workflow rules instad? Seems like process builder is breaking a lot with these errors. I'd appreciate any suggestions or advice out there! 

Thanks
Ashley
 
Sara BierySara Biery
https://success.salesforce.com/issues_view?id=a1p300000008Xn7AAE 

Looks like this is a known issue. 
Smriti Kumari (Shumpy)Smriti Kumari (Shumpy)
It didn't work. Can anyone suggest if you found a solution ? 
 
NJ_RayNJ_Ray
I encountered a similar error but later was able to fix it by hit and trial method, what I understood was since Process builder uses Flow to create the processes, a flow will error out if you are trying to refrence a field that is not on the page layout doesnt matter which profile is being used to perform the update(which in turn calls the process builder process). So just make sure you are only refrencing the fields that are on the page that you are trying to update. In my case, I was trying to update some fields on the case page, based upon a particular record type.But there was one field that was not being displayed on the page layout because of the chosen record type, hence I kept getting the error until I removed it from the process update step.Hope this helps if you are in a similar situation
KbhaskarKbhaskar

I too encountered a similar problem but later I was able to rectify it by the following e-mail , at the bottom of every mail there will be error caused by reason​ 

Error Occurred During Flow "Campaign_history_4": INSERT --- INSERT FAILED --- ERRORS : (STRING_TOO_LONG)..

An error occurred at element myRule_1_A1 (FlowRecordCreate).
INSERT --- INSERT FAILED --- ERRORS : (STRING_TOO_LONG) Campaign Name: data value too large: 70128000000RuVGAA0 (max length=15), 

This report lists the elements that the flow interview executed. The report is a beta feature.
We welcome your feedback on IdeaExchange.

Flow Details
Flow Name: Campaingn_history
Type: Workflow
Version: 1
Status: Active

Flow Interview Details
Interview Label: Campaingn_history-1_Campaign
Current User: Bhaskar Kummara (00528000000UZIc)
Start time: 12/09/2016 09:44
Duration: 0 seconds

How the Interview Started
Bhaskar Kummara (00528000000UZIc) started the flow interview.
Some of this flow's variables were set when the interview started.
myVariable_old = 70128000000RuVGAA0
myVariable_current = 70128000000RuVGAA0
RecursiveCountVariable = 0.00

ASSIGNMENT: myVariable_waitStartTimeAssignment
{!myVariable_waitStartTimeVariable} Equals {!Flow.CurrentDateTime}
Result
{!myVariable_waitStartTimeVariable} = "12/09/2016 09:44"

DECISION: isChangedDecision2_myRule_1_EventName_c

DECISION: isChangedDecision3_myRule_1_Name
Executed this outcome: isChangedRule_3_myRule_1_Name
Outcome conditions: and
1. {!myVariable_old} (70128000000RuVGAA0) Is null false
2. {!myVariable_old.Name} (IT Campaign) Does not equal {!myVariable_current.Name} (ITCampaign)
Logic: All conditions must be true (AND)

DECISION: isChangedDecision4_myRule_1_Description

DECISION: myDecision
Executed this outcome: myRule_1
Outcome conditions: or
1. {!isChangedRule_2_myRule_1_EventName_c} (false) Equals true
2. {!isChangedRule_3_myRule_1_Name} (true) Equals true
3. {!isChangedRule_4_myRule_1_Description} (false) Equals true
Logic: One condition must be true (OR)

RECORD CREATE: myRule_1_A1
Create one Campaign_History_Status__c record where:
Campaign_Name__c = {!myVariable_current.Id} (70128000000RuVGAA0)
Description__c = {!myVariable_current.Description} (Test Campaign for Merit Trade Expo)
Name = {!myVariable_current.EventName__r.Name} (Merit Trade Expo)
Target_Contacts__c = {!myVariable_current.Estimated_Contacts__c} (5)
Result
Failed to create record.

Error Occurred: INSERT --- INSERT FAILED --- ERRORS : (STRING_TOO_LONG) Campaign Name: data value too large: 70128000000RuVGAA0 (max length=15), ----------------------------------------------------------this was the custom  field which i was referencing to  standard field which later , increased length which solved my issue.


 
Eric Wilson 23Eric Wilson 23
I found that changing the 18 Digit Code in Process Builder to a 15 Digit Code worked for me.
Joe Cavicchia 3Joe Cavicchia 3
I found a dirty way to get this. Disable and then enable the first process flow. Check the "View Setup Audit trail".  The flow ID is there. Repeat until you find the bad flow  
If you created or enabled the flow in the last 6 months, download the audit trail .csv file and then search the ID.
nandu s 15nandu s 15
Hi,
I got this email...please help me
Error element myRule_1_A1 (FlowRecordCreate).
This error occurred when the flow tried to create records: REQUIRED_FIELD_MISSING: Required fields are missing: [AccountId]. For details, see API Exceptions.
 
AD RokaAD Roka
@nandu s 15 well then you should enter all the required fields. Maybe you have created validation rules somewhere along thats making those fields required. Check that out. I was having similar issue with my opportunity not closing and come to find out some of my variables weren't set or assigned. Hope that works for you.
MythreyeeSSMythreyeeSS
Hi - To find the Flow which causes the error, the Flow Id in the error message can be substiturted in this url https://yourinstance.my.salesforce.com/designer/designer.apexp#Id=30116000000PPKL. Thanks.
Dara WardeDara Warde
MythreyeeSS = LIFE SAVER! Thank you - brilliant!
Sharma.ArunSharma.Arun
Thanks Eric Wilson 23, It works for me!!
Su Wang 4Su Wang 4
@MythreyeeSS Your link really helps to find the flow and figure out who created it.  Thanks!
Dhanik L SahniDhanik L Sahni
Thanks @MythreyeeSS.
Michelle BentleyMichelle Bentley
Thanks MythreyeeSS!!!!  That identified it for me!