+ Start a Discussion
TheRealistTheRealist 

why i am not able to see tab even user's profile has access on that object?

something strange happend, i have created a custom object,its related tab and linked it with the a user's profile, the profile has access on that object and app ,even i set the tab to "Default On" ,i have checked thoroughly but still i am not able to see the tab and not even in the "customize tabs" page,when logged in with that user account. i wonder what migh have happend ?
Best Answer chosen by TheRealist
Hargobind_SinghHargobind_Singh
Hi, 

If you have already checked: 

- Tab is included in app
- Profile has access to tab
- Profile has access to object

Can you go to your custom object and see that it is not marked as "in development", you can go to your custom object, click edit on object properties, and check.. the "Deployment" property at the end of the screen, it should be marked "Deployed".

 "in development" objects are visible to only administrators/developers, and users cant see them.

=========

ps: If your problem/question is resolved/answered, please mark your post as 'Solved' so that the community can benefit with resolution of issues. 

All Answers

Hargobind_SinghHargobind_Singh
Hi, 

If you have already checked: 

- Tab is included in app
- Profile has access to tab
- Profile has access to object

Can you go to your custom object and see that it is not marked as "in development", you can go to your custom object, click edit on object properties, and check.. the "Deployment" property at the end of the screen, it should be marked "Deployed".

 "in development" objects are visible to only administrators/developers, and users cant see them.

=========

ps: If your problem/question is resolved/answered, please mark your post as 'Solved' so that the community can benefit with resolution of issues. 
This was selected as the best answer
Philippa WilfordPhilippa Wilford
Thank you for this! I was having the same issue and couldn't work out what was wrong... turns out although I had "deployed" one object, there was a master-detail relationship and I still had the master object in "development". 
Pavlo Shchur 31Pavlo Shchur 31
I have similar issue.
http://prntscr.com/nn7z3m
I am not able to add "Feedback" tab to Service app. I am admin.