+ Start a Discussion
Rohit TripathiRohit Tripathi 

Assiging Object Access to a Custom Profile

Hello,

I was going throught Trailhead tutorial for Sales Force and under Data Security I found this challenge to,

"Create a 'Account Reviewer' profile which should only have read access to the Account object (and no access to any other object in the Org)."

When I am creating Account Reviewer profile, it is by default linked to all the objects. I am not able to see any Edit button while going inside Account Reviewer profile and select only Account object.

Can anyone please help me !!!
 
Best Answer chosen by Rohit Tripathi
Sakthivel ThandavarayanSakthivel Thandavarayan
Rohit, 

You have "Enhanced Profile User Interface" enabled in your org.

So you have to follow this step on all objects to modify object settings.

For account, 

Click on object settings - Account - Edit - Check "Read" and Uncheck All other permissions(Create,Edit,Delete,View All, Modify All)

But there is another way to modify the all settings in one place. 

You have to change the profile interface back to old style.

Setup - Customize - User Interface - Uncheck "Enable Enhanced Profile User Interface".

Now you will have the option to edit the profile directly in profiles list view.

All Answers

Sakthivel ThandavarayanSakthivel Thandavarayan
Clone standard user profile and try again.
Rohit TripathiRohit Tripathi
I tried cloning standard user profile but it is still not working. I am not getting options to edit object access. 
Sakthivel ThandavarayanSakthivel Thandavarayan
Can you provide screenshot of Account reviewer profile settings page !
Rohit TripathiRohit Tripathi
Here is the screen shot of profile :

Account Reviewer Profile
Sakthivel ThandavarayanSakthivel Thandavarayan
Rohit, 

You have "Enhanced Profile User Interface" enabled in your org.

So you have to follow this step on all objects to modify object settings.

For account, 

Click on object settings - Account - Edit - Check "Read" and Uncheck All other permissions(Create,Edit,Delete,View All, Modify All)

But there is another way to modify the all settings in one place. 

You have to change the profile interface back to old style.

Setup - Customize - User Interface - Uncheck "Enable Enhanced Profile User Interface".

Now you will have the option to edit the profile directly in profiles list view.
This was selected as the best answer
Raj MantenaRaj Mantena
@ Sakthivel Thandavarayan, your answer to Uncheck "Enable Enhanced Profile User Interface" helped out. Thanks!
Suvarna RathiSuvarna Rathi
The answer helped. Thanks :)