+ Start a Discussion
Dan Cobb 9Dan Cobb 9 

Field level security for sites?

I am creating my first site. It will contain a single Visualforce page. The page is using a case field set. The page worked fine, I was able to access it throught the site url and test it's functionality. I added a new field to the field set, and I now get the generic, "Authoriziation Required" page when I navigate to the site url. I remove the field from the field set and can view the page as before.

My first thougth is that it's field level security around that field that is causing the problem. When I go to the field accessibility for the field in question, I see no entry for the site profile at all. I can find no other way to change field level security for that field, or even view what the accessibility is for my site profile. What am I missing? Or am I way off base?

Thanks,
Dan

Best Answer chosen by Dan Cobb 9
Mohit Bansal6Mohit Bansal6
Hi Dan

Go to Setup > develop > Sites > Click on the site label > click on "Public Access Settings" button. There you can find your object and set the security for field and enable it for site.


Please mark this as solution by selecting it as best answer if this solves your problem, So that if anyone has this issue this post can help

All Answers

Mohit Bansal6Mohit Bansal6
Hi Dan

Go to Setup > develop > Sites > Click on the site label > click on "Public Access Settings" button. There you can find your object and set the security for field and enable it for site.


Please mark this as solution by selecting it as best answer if this solves your problem, So that if anyone has this issue this post can help
This was selected as the best answer
Mohit Bansal6Mohit Bansal6
Hi Dan

Are you able to resolve your issue?

Kindly share.

Regards
Mohit Bansal