+ Start a Discussion
Michael CerulloMichael Cerullo 

Not able to see the Service Provider listed under Identity Provider for Single Sign On

I am facing an issue while configuring SSO. I have 2 free Developer Edition orgs.  One is set up as the Identity Provider using Salesforce's built-in IDP service.  I set up the othe org as a Service Provider. In the IDP org, I added the Service Provider as a connected app as defined under "Setup" > "Security Controls" > "Identity Provider".  I also assigned a profile to the connected app. I should end up with a new Service Provider listed under Identity Provider. However, when I go to the Identity Provide page under "Setup" > "Security Controls" > "Identity Provider", the list of Service Providers is empty . What could be the possible reason? Am I missing any other step? Below is a link to the workbook exercise I am following:

https://developer.salesforce.com/page/Implementing_Single_Sign-On_Across_Multiple_Organizations

Thank you for your help!
Amit Chaudhary 8Amit Chaudhary 8
Hi Michael,

Service Providers are now created via Connected Apps.
Login as an Administrator in your identity provider org, and browse to "Setup" > "Security Controls" > "Identity Provider" and follow these steps:

1) Click “Service Providers are now created via Connected Apps. Click here.” under the list of "Service Providers"
2) Enter a name for your first Connected App. In this case, I put Amit Org1.
3) Select Enable SAML under Web App Settings.
4) Enter the 'My Domain' of the Service Provider Org as the "Entity ID"
5) Enter the ACS URL - this is the "Salesforce.com Login URL" you made note of in Step 5
6) Select "Federation ID"
7) Assign this SSO configuration to any Profiles of your choosing


User-added image

Please mark this as solution by selecting it as best answer if this solves your problem, So that if anyone has this issue this post can help

Thanks
Amit Chaudhary
amit.salesforce21@gmail.com
 
Ronan O'Neill 6Ronan O'Neill 6
Hi Michael, 

Did you ever find the solution to this? I'm trying the exact same exercise and have the same issue. After adding the service provider as a connected app it doesn't show up under the identity provider as it should. 

Amit, I think you just copied the instructions that he was following to reach this issue. 
Ronan O'Neill 6Ronan O'Neill 6
Amit, those are the steps I've followed to get here. But the problem is the service provider connected app doesn't show up under identity provider. 

User-added image

So you can see no service providers, but I have created a connected ap. Is there an issue with what I've filled in?

User-added image
Amit Chaudhary 8Amit Chaudhary 8
Make sure below point only other wise all other wise all look good to me
4) Enter the 'My Domain' of the Service Provider Org as the "Entity ID"
5) Enter the ACS URL - this is the "Salesforce.com Login URL" you made note of in Step 5
satya chikkalasatya chikkala

Hi,

I am facing the similar issue. Unable to find the connected app under the Idp's list of service providers.
 

Regards,
Satya