+ Start a Discussion
Suneel#8Suneel#8 

PageRedirection is not working in Salesforce1

I am trying to redirect to specific record type's edit page layout of an object. Redirection works in Full salesforce site but not Salesforce1. I tried below function to redirect the page in Salesforce1. But it doesn't work, it always displays default record type's page layout of the object
sforce.one.navigateToURL("/006/e?RecordType=01280000000UIuJ&nooverride=1",true);
I tried redirecting the page by below way.Redirection hapens in Salesforce1 but it displays the page of full salesforce site. Please advise how to achieve this
window.location.href="/006/e?RecordType=01280000000UIuJ&nooverride=1";

 
NagaNaga (Salesforce Developers) 
Hi Suneel,

Please follow this idea

https://success.salesforce.com/ideaView?id=08730000000kyo3AAA

Best Regards
Naga Kiran
kgilkgil
Salesforce1 unfortunately does not have a way to load a specific Record Type for the Edit page other than what is default. Also, try to avoid any use of the standard object URL identifiers like "006" etc. since those are only designed for the full desktop site. For Salesforce1 the following call should be used, but again it only accepts an ID and goes to the default Record Type the record is defined with:
sforce.one.editRecord(​recordId)
https://developer.salesforce.com/docs/atlas.en-us.salesforce1.meta/salesforce1/salesforce1_dev_jsapi_sforce_one.htm

Also note that you cannot skip an override with sforce.one.editRecord if one is present on the object, so "nooverride=1" does not work with this call. I believe any other solution for this would need to be a custom implmentation.