+ Start a Discussion
Lewis RichardsonLewis Richardson 

Enable Lightning App Builder

I don't see a Setup menu to run the Lightning App Builder for a challange.  I'm using the Summer `15 Developer Edition.  How is it enabled? 
SonamSonam (Salesforce Developers) 
hi Lewis,

Can you please share your ORG ID with me @ sraju @salesforce dot com
I will check the configuration in your ORG and see how we can get that activated.
Lewis RichardsonLewis Richardson
Hi Sonam, Here it is: Salesforce.com Organization ID:00D37000000HgMr Thanks.
KristofferGreeneKristofferGreene
You can also use http://bit.ly/Lightning_QS to get an org with it and anything else (lightning-oriented) you need for the trails.
Lewis RichardsonLewis Richardson
Has it been enabled??
SonamSonam (Salesforce Developers) 
Hi Lewis,

I've go the lightning app builder activated on your ORG, please check and confirm.


 
Lewis RichardsonLewis Richardson
Hi Sonam, Yes, it is available now in the Build menus. Thanks.
Nageswara KapalavayiNageswara Kapalavayi
Hi Sonam,

Could you please enable lighting app builder to my ORG.  Please find below the ORG id details
00D1a000000aySm
 - Nagesh
seamas liseamas li
Hi Sonam, I can see the menu too, I am a new developer on SalesForce, I am studying  in Trailhead, could you please set me the access on Lightning app?
my username :seamas_lee@sina.com
SonamSonam (Salesforce Developers) 
@Nageswara, I've got lightning app builder enabled on your ORG, please check and confirm.
SonamSonam (Salesforce Developers) 
@Seamas  I've got lightning app builder enabled on your ORG, please check and confirm.
Nageswara KapalavayiNageswara Kapalavayi
Thanks Sonam.  I am able to see the Ligting App Builder.
George CookGeorge Cook
Hello Sonam: I have the same problem. I am going to email you my information right now. I hope you can enable Lightning App Builder in mine, too. Thanks!
Chris Green 4Chris Green 4
Sonam, Please enable lightning app builder in my org - 00D1a000000agQh  Thanks!
George CookGeorge Cook
Hi: Is anyone on Trailhead/SF Developer forum able to help???
I need lightning app bulider enabled in Salesforce.com Organization ID00D37000000IVNr so I can continue my trailhead.
Thank you!
 
Naveen ChoudharyNaveen Choudhary
Hi Sonam,

I have also the same issue in completion of my trailheads that i have to create a lightning page and in my org lightning app builder is not enable.
Could you please enable it to my org ID
My Org ID : 00D28000000XRoSEAW
Katherine BootheKatherine Boothe
Were you guys able to get this enabled in your Dev Orgs? It looks like no response after 7/20, and I'm running into the same issue.
Thomas CrawfordThomas Crawford
00D1a000000aZiP

Can you enable mine as well?
Thomas CrawfordThomas Crawford
@Sonam please enable for mine too 00D1a000000aZiP

 
Chris DuarteChris Duarte
Hi everyone - you don't need to have Lightning App Builder activated in your existing org. Just create a new DE and you'll get Lightning App Builder automatically enabled. Then you can log in to do the challenge in your new DE.

To be clear,  you'll stay logged in on the attached image at (1) with your existing login. This will ensure all your badges stay in one place. But you'll make a new DE just to log in at (2).

Hope this helps.Visual description of where to log in at (1) which is in the upper right, and (2) which is where you do challenges
George CookGeorge Cook
Thanks, Chris! Isn't it possible to just activate it as has been done above? I appreciate the workaround (creating a 2nd DE), and all the badges staying in one place as you've explained. However, I've done a lot of work in my current environment. I'd prefer to not split my work across different DEs and I'm guessing other people here might feel the same way.

Do you have any feedback about that? Thanks!
Chris DuarteChris Duarte
Hi George - we unfortunately don't have the bandwidth to activate features individually for users. Maybe Sonam will be able to write back and do it for you -- I'm trying to give you a workaround so you're not blocked! :-)

You might find as you're working through Trailhead that you need to create a new DE at some point. I've got a number of DEs myself, though I store all my badges in one place. I'm up to 24! How about you? 

My badges: https://t.co/UMnbsor0Fu
Thomas CrawfordThomas Crawford

User-added image

New DE org and I get this when clicking "New" under Lightning App Builder

Chris DuarteChris Duarte
Try an incognito window in Chrome. Or try a different browser.
Thomas CrawfordThomas Crawford
I tried Firefox as well
Thomas CrawfordThomas Crawford
Same error Incognito
Chris DuarteChris Duarte
I can't replicate it on my side.
Thomas CrawfordThomas Crawford
I have two developer orgs and i can't get this Trail Head done. One it isn't enabled and the other when I click New Under Lightning App Builder I get the above error.
Chris DuarteChris Duarte
Thomas: I'm asking internally. There was a known issue for this, but it shows fixed with a patch. Let me see what I can find out for you.
Chris DuarteChris Duarte
And my apologies for the inconvenience, Thomas.
Katherine BootheKatherine Boothe
I'm now receiving the same thing, it occurred after I enabled "Enable Lightning Components in Salesforce1 (BETA)". I'm staying tuned for the solution...
Thanks!
Naomi HarmonNaomi Harmon
I am having the same issue.
Chris DuarteChris Duarte
Katherine and Naomi - which issue are you having, the DNS issue or you don't see Lightning App Builder in Setup?

If you don't see Lightning App Builder in setup, just create a new DE - check out my earlier instructions in this thread.

If you're seeing the DNS issue, let me know.
Naomi HarmonNaomi Harmon
I have the Lightning App Builder in Setup. But once I "Enable Lightning Components in Salesforce1 (BETA)", I get a "Server not found" error any time I try to add a new or edit a Lightning App using the Lightning App Builder.
George CookGeorge Cook
Since Midnight today (8-4-2015) to now, about 13.5 hours, I've had the same problem. The Lightning App Builder in my DE won't launch. Tried variations of browser (Firefox, IE, Chromium-based), and mode (private/not private), and not working. All other aspects of the DE platform are working.

FYI- before midnight I was able to use the Lightning App Builder to complete one of the challenges, so I know at one point Lightning App builder was working.

My current screenshot:

User-added image

Thank in advance the trailhead team for any effort to resolve.
Thanks!!!


 
Chris DuarteChris Duarte
We figured out the issue with those of you having a DNS or server not available issue. By my count, that's George, Naomi, and Thomas. Can all of you confirm your DE orgs are on NA34?
 
George CookGeorge Cook
Yes, mine is
https://na34.lightning.force.com/visualEditor/appBuilder.app?pageId=0M0610000004CAG
Thank you for your attention to these matters, Chris!
Naomi HarmonNaomi Harmon
Yes, mine is too! Thank you.
Thomas CrawfordThomas Crawford
All set Chris thanks!
George CookGeorge Cook
looks like the DNS propogated, I'm also back in.
Thank you!
Katherine BootheKatherine Boothe
Chris, I was on NA34 and am good to go now, too! Many thanks!
Chris DuarteChris Duarte
Great, thank you Katherine, George, and Thomas - and so sorry for the inconvenience. I sincerely appreciate you hanging in there while we figured it out, and many thanks for checking out Trailhead.

Anyone else who's having issues, just create a new DE org following the instructions I posted earlier in the thread. We are working on getting Lightning App Builder enabled in the Summer 15 DE but until then, a new DE should be a good workaround.

And George, I'm still waiting for that post on how many badges you're at. :-)
Sebastian Röder_CognizantSebastian Röder_Cognizant
Hi hope anybody can help me out :) im maken the lightning App Builder in Trailhead but in my filter section in Lighntning App Builder i cant choose ACCOUNT object its not even shown in picklist. DO i have something to activate before it shows up in App builder?

Thank you :)
Chris DuarteChris Duarte
Hi Sebastian - I'm assuming you're doing the Lightning App Builder module in Trailhead: https://developer.salesforce.com/trailhead/module/lightning_app_builder

And I'm assuming you are on this challenge: https://developer.salesforce.com/trailhead/lightning_app_builder/lightning_app_builder_apphome

When you create the recent items component, "Account" is already selected for you. 

The account object is already selected when you add the recent items related list

If this isn't what you were asking about, please give us more details so we can help you.
Sebastian Röder_CognizantSebastian Röder_Cognizant

Hey Thanks for help yes its exactly this Trail im doint at the moment, but i solved it just a couple of minutes ago.. It seems like my Dev Org was to old. I tryed with a new one and it worked fine! :)

But there is a another thing comming up and in the Trailhead you mentioned on step Three add components... I dont have custome components where do i get the ContactsNearby component from / how does it look like?

Sebastian Röder_CognizantSebastian Röder_Cognizant
actually its this one: https://developer.salesforce.com/trailhead/project/quickstart-app-builder
Chris DuarteChris Duarte
So I see now that you are doing the project Quick Start: Lightning App Builder. 

In the first step of this project, you are directed to sign up for a special Developer Edition org, which will have all of the components you need to complete all 4 of the Lightning Quick Starts: https://developer.salesforce.com/trailhead/project/quickstart-app-builder/quickstart-app-builder1

"This special Developer Edition (DE) org comes preconfigured with the data and components that you need to complete all the Lightning Quick Starts. You cannot use a standard Developer Edition to complete this Quick Start; you must sign up for this special DE. Like all Developer Editions, this DE environment never expires. You can complete all the Lightning Quick Starts in the same special DE."
Sebastian Röder_CognizantSebastian Röder_Cognizant
Oh OK i thought i can use my own DEV ORG.  Do i have to open / create a new Org for every project? After a while i`ll have 20 Orgs...
Sebastian Röder_CognizantSebastian Röder_Cognizant

Well even in the special Org there is nothing available....Its the new Org from Step ONE.

User-added image

Chris DuarteChris Duarte
The special DE is for use in the 4 Lightning Quick Start Projects. It contains all of the data and components you need for these 4 quick starts.

You can use your regular DE org for anything else. Good luck!
Sebastian Röder_CognizantSebastian Röder_Cognizant
But there are no Custom components aas you can see in picture. http://bit.ly/Lightning_QS i used this ORG.
Chris DuarteChris Duarte
Hi Sebastian -- I just created a new special DE from the link and the custom component is there. Not sure why this is happening to you, but here's what I'm going to do. I've taken the special DE I just created, and I've changed the main user's email address to you - you should be getting a notification email right now verifying the change. Then log in to that DE and tell me if you see the component.
Alyssa FowersAlyssa Fowers
Hi, I'm trying to do the Admin Tral - Starting with Lightning Experience, but when I try to create an app I get a redirect loop error. I'm working with a DE I just created (org ID 00D61000000JmHb) that has the summer '15 icon.. Can you help?
Bill DodsonBill Dodson
I am working on this trailhead course:

https://developer.salesforce.com/trailhead/project/quickstart-app-builder/quickstart-app-builder1

When I add the Filter List onto the page and go to the Object drop down list Account does not show up.  Instead I get objects related to the Recruiter application such as Job Application, Position, etc.

I do not see anywhere in the course instructions where I need to use a special DE. Please advise on how to resolve this issue, thanks.
 
Chris DuarteChris Duarte
Hi Bill - we updated this project so that you no longer have to use a special DE. So you can disregard my earlier comment to that effect.

I am running through this right now in my DE. I've dragged the filter list onto the page, and Account is the default object on the picklist. It sounds like you're just seeing custom objects on the filtered list -- but I can't reproduce it on my side.
Chris DuarteChris Duarte
Bill, how old is your DE?
Bill DodsonBill Dodson
Hi Chris thanks for reply. Yes I only see custom objects in drop down list. Please let me know how to resolve, thanks. Sent from my Verizon Wireless 4G LTE DROID
Bill DodsonBill Dodson
I signed up for my developer addition late summer 2014. Any help greatly appreciated. Thanks, Bill Sent from my Verizon Wireless 4G LTE DROID
Chris DuarteChris Duarte
Bill, there was a problem with the Summer 15 Developer Edition and Lightning App Builder. It was unrelated for Trailhead, but we've observed folks having challenges with this Quick Start who are using a Summer 15 DE. I recommend creating a new Developer Edition and working through the challenge with the new DE. I'm sorry for the inconvenience.

To be clear, you'll stay logged in with your username for developer.salesforce.com, so your badges stay intact. You'll just do this challenge in the new DE. There's a screenshot in this thread with more details.
Bill DodsonBill Dodson
Thanks for reply Chris. Please note my DE is summer 2014 not 2015. Anyway, there is a more in depth trailhead App Builder course I was planning to give that one a try. Bill Sent from my Verizon Wireless 4G LTE DROID
Chris DuarteChris Duarte
I highly recommend a newer org, even more so now that I know yours is from last summer. We recommend a new DE for Trailhead exercises. What you're describing, I can't replicate, so it's hard to guess root cause. I'm using a brand new DE and having no issues. It just takes a few minutes to get one, and you could see right away if it solves your issue.
Bill DodsonBill Dodson
Hi Chris, I created a new DE and was able to complete the first module without issue.  Thanks for your help, Bill
Bill DodsonBill Dodson
Also, the new DE allowed me to complete the entire course without issue.  Thanks for your help Chris, much appreciated, Bill
Missy LongshoreMissy Longshore
Hi, I'm getting an error in the 'Building an App Home Lightning Page.' It looks like I'm not allowed to Save to turn on the pilot Lightning App Builder. Is this a known issue?
Thanks!
Chris DuarteChris Duarte
Hey Missy - are you using a new DE?
Missy LongshoreMissy Longshore
Hi @Chris Duarte - it turned out it was an IE thing. I use different browsers since I'm logged into so many different orgs throughout my day as a consultant. Firefox worked great but I did sign up for a new DE org I named 'Astro' just to be sure! Thanks!!!
anjali sharma 20anjali sharma 20
i can't get lightning app builder.so,how can work on with?
David Baumann 40David Baumann 40
Hi,

I tried to set up a new App within the Lightning Setup. Unfortunately I dont have the opportunity to create new Custom Objects in order to assign them to this app. When I click on "Create -> Custom Object" the page is blank. However, I can edit older customs objects I created in Salesforce Classic.

Any tips or ideas how to solve this issue?

Thanks!
David
Othmane SGHIROthmane SGHIR
Hi,
I have the same problem as Lewis. We use the Lightning Professional Edition but the App Builder does not appear in the Setup Quick Find box as it should. How can I get it enabled ?
Thanks !
ROHIT.KUMAR.VERMAROHIT.KUMAR.VERMA
@ sraju @salesforce.com : Please enable the Lightning App Builder for my Developer Org. Organization ID: 00D90000000lq4w