+ Start a Discussion
Calvin SmithCalvin Smith 

Object Specific Actions Challenge - Visualforce Action won't validate

I keep getting a message telling me " The 'Call Assistant' action wasn't added to the Contact page layout." despite the fact that I've added it to the Contact Page layout. 

Here's my page code:
<apex:page docType="html-5.0" standardController="Contact" title="Show Assistant Info" >                       

    <div>
    
    <p>Assistant Name : {!Contact.AssistantName}</p> 
    
    <p>Assistant Phone : <a href="tel:{!Contact.AssistantPhone}">{!Contact.AssistantPhone}</a></p>

    </div>
    
    </apex:page>
A screen shot of the Page Editor to show it's enabled for SF1 and properly named:

Page Editor Screen Shot

A screen shot of the Contact Action:
Contact Action
A screen shot of where it's been added to the Salesforce1 Action Bar on the Page Layout:
Page Layout - Salesforce1 Action Bar
And finally, a screen shot of where the page has also been added to the SF1 Mobile Navigation Menu: 
Mobile Navigation Menu

I don't know what else I can do differently to get this to validate. Is there something I've missed? I've even added the fields to the mini page layout! I've no clue what the real problem is that's behind this not passing the challenge. 
Best Answer chosen by Calvin Smith
SunJo31SunJo31
Ran into the same issue. Looks like someone found a workaround.

https://developer.salesforce.com/forums?id=906F0000000BMGYIA4

All Answers

Himanshu ParasharHimanshu Parashar
Hi Calvin,

Everything seems to be fine.. Can you verify that you are adding that in correct  Contact layout. You can check which layout assigend to your profile.
Calvin SmithCalvin Smith
It's going into the Master Contact Page Layout. Here's a screen shot:

Contact Page Layout
And as you can see below, that's also the one assigned to the System Admin as well as the Standard User.

Page Layout Assignments
 
Himanshu ParasharHimanshu Parashar
Hi Calvin,

Are you able to see Call Assistant Action in Saleforce1 ?
Calvin SmithCalvin Smith
Yes, it shows up and is there.
sfdcdevsfdcdev
Everything looks fine to me.Try this challenge with a new org,see if error still persists.
SunJo31SunJo31
Ran into the same issue. Looks like someone found a workaround.

https://developer.salesforce.com/forums?id=906F0000000BMGYIA4
This was selected as the best answer
Calvin SmithCalvin Smith
That solved it! That's absolutely nuts. I thank you immensely for pointing me to the workaround. :)