+ Start a Discussion
Phil RowlinsonPhil Rowlinson 

Flow "unable to find field dataType for complex reference"

Have a flow which contains a multi-select picklist type. Worked yesterday - no longer works today. Change the field type back to Text, and same error. Anyone any idea how to trouble shoot this?
The flow is a headless flow called from process builder on the Oppty Line item. I am passing in Opportunity LI ID and Product ID. AS I said it worked yesterday but no longer does and there have been no changes.
ShashankShashank (Salesforce Developers) 
You may have to try deactivating and reactivating the flow to see if the issue gets resolved.
TS-ITWTS-ITW
I'm having the same issue.  Did you find a solution?
Phil RowlinsonPhil Rowlinson
Hi Tricia, No, I'm sorry but I never did.
Prathyusha JPrathyusha J
Hi,
Creating a new version of the existing flow and activating it once again will solve the issue.
Thank you,
Prathyusha.
Adam GrossmanAdam Grossman
I had a slightly different use case and was able to overcome the issue by assigning the value that needed to be used to its own text variable then referencing that variable for assignment.
Ken ShvetzKen Shvetz
In my case, I was getting this error in a flow due to either an error with an HTML template AND/OR because I was referencing a variable in the template that I hadn't yet assigned a value - I had a couple of things wrong:

- the URL had accidentally changed from /{!variable}/ to /%7B!variable%7D/ or something like that (ASCII code substitution), which I've seen happen sometimes when cutting/pasting or resaving.  I also had an extra http//http://... in front so the whole line was kinda messed up.

- the template itself was actually referencing a collection variable populated later downstream; I fixed it to reference the collection variable in the current loop instead

Not sure which or both of these was causing the error, but that fixed it. Hope this helps someone. :-)