+ Start a Discussion
Mark Coburn 4Mark Coburn 4 

Read Access to Accounts Only

I am going through the Admin Trail - Intermediate in Trailhead. The second piece in the Data Security Module has a challenge that says create a profile with read access to the account object only. This is not possible. If you give read access to the account object, the contact object automatically also has read access, even if you do this through a permission set. I cannot pass this challenge in Trailhead, because it always says that there is something wrong with the profile. "The profile does not work as expected"

Am I missing something, how can I pass this challenge if this isn't possible? 

Thanks all. 
Amit Chaudhary 8Amit Chaudhary 8
Hi Mark,

You can proved the read only access on account object only. Contact access is not requried. Please check below screen shot

User-added image
I hope this wil help you.

Please let us know if your issue will resolve
 
Mark Coburn 4Mark Coburn 4
That is very interesting that you were able to do this. In my dev org, whenever I check the account read box, the contact read box is automatically checked as well. Is there something that I'm missing here?
Amit Chaudhary 8Amit Chaudhary 8
Please try below option. I am not sure that will help you or not
1) Try to modify OWD setting of contact from controll by Controlled by Parent to read only and then try again.
2) I hope you are using clone of "Salesforce"  User License. Please try to create new profile.
Mark Coburn 4Mark Coburn 4
Thanks for the help here. Yes, I am using a Salesforce user license. 

Currently the contact OWD are actually greyed out, and set to Controlled by Parent, I'm not able to change it. 

Again, appreciate the effort. 
Mark Coburn 4Mark Coburn 4
Yeah, tried that, that doesn't work unfortunately. It still stays as "controlled by parent" and greyed out. Cheers, *Mark Coburn* Consultant akaCRM mcoburn@akacrm.com Office: (970) 658-9986 Mobile: (720) 775-4438 *Skype: m.c.oburn* Linkedin *www.akacrm.com *
Mark Coburn 4Mark Coburn 4
I finally figured this out, it's because I have person accounts in the org. If you have person accounts, then you have no option to only give the account object read access. So, I simply created a new org, w/o person accounts, as was able ot pass. Cheers.
Vineeth PydimarryVineeth Pydimarry
Hi,

Uncheck the Read button in each object. It automatically considers that the profile which is created would have no access. Make sure you are on the Obkect settings page and check all permissions are either -- or No access.