+ Start a Discussion
Tushar Mahadik 2Tushar Mahadik 2 

Issue in completing challenge under Data Security (Controlling Access to Fields)

Hi,

I am trying to complete challange inside Data Security (Controlling Access to Fields) but i am facing below error:
Challenge not yet complete... here's what's wrong: 
The 'Basic Account User' profile did not have the appropriate object and field-level security for the Account object

I followed below steps as per mentioned in question:
1. I have created one profile Basic Account User
2. Assign one user to this profile. So I can assign him permission set
3. I have created one permission set as Account Rating and in that object setting I have assigned Account object read and edit access for Object as well for Rating field.
4. Then I assign that permission set to user inside Basic Account User Profile.

Please let me know if I am doing any mistakes or the question with wrong steps.

Question Is: Create a Profile and Permission Set to properly handle field access
The Marketing Coordinator and Account Manager both require access to view and update Account Records, but only the Account Manager should be able to see and edit certain fields. Specifically, only the Account Manager should be able to see and edit the Rating field. The Marketing Coordinator should not be able to see or edit the Rating field. Create one profile and one permission set with the appropriate field-level security to solve for this use case.
  • The profile must be named 'Basic Account User' and result in an API name of 'Basic_Account_User'. It should use the 'Salesforce' user license type.
  • The permission set must be named ‘Account Rating’ and result in an API name of 'Account_Rating'.
Best Answer chosen by Tushar Mahadik 2
William TranWilliam Tran
In the basic account user profile, did you turn off the visible/readonly? 

You need to go in to basic account user profile -> Field security -> Account -> uncheck the rating checkbox the save.

Thx

All Answers

William TranWilliam Tran
In the basic account user profile, did you turn off the visible/readonly? 

You need to go in to basic account user profile -> Field security -> Account -> uncheck the rating checkbox the save.

Thx
This was selected as the best answer
Chandra Sekhar CH N VChandra Sekhar CH N V
Make the field level security of Rating field as 'Visible' on the account object level !!!
Mark Korf 6Mark Korf 6
Neither of these solutions worked in my case. Still stuck.
 
Leo TorresLeo Torres
@Wiliam Tran, That worked and I was thinking it had to be something alonmg those lines. But I was trying to get it done via the instructions, i.e. crating a permission set named account rating etc. which it looks like we do not have to do at all, or?