+ Start a Discussion
Edwin VijayEdwin Vijay 

Unable to retrieve and deploy all WORKFLOW components

Hello All,

We are using jenkins and SVN for source control. Below are the steps for the issue i am facing. Any help is greatly appreciated.
  1. I used the salesforce ANT tool to retrieve ALL workflow and pageLayout components from production.
  2. I used the retrived folder to deploy the same to production again.
  3. Error thrown: 
    1. Workflow - Question : Cannot create workflow directly; must create the CustomObject first
    2. Workflow - SocialPost : Cannot create workflow directly; must create the CustomObject first
    3. Workflow - Reply : Cannot create workflow directly; must create the CustomObject firs
    4. Page Layout - FeedItem-Feed Item Layout: Layout must have at least 1 section
    5. Page Layout - SocialPost-Social Post Layout: Layout must have at least 1 section
Please note: the page layouts and workflows are not custom, the look like standard ones since they are without the __c.
Best Answer chosen by Edwin Vijay
Fahad-AkhtarFahad-Akhtar
Hi There,
I always had trouble with these components and we have used diffrent approaches:
  1. Remove these component from your package.xml
  2. After retrieve use ANT to remove these components from your directory, if they were pulled and remove from package.xml as well
  3. There is nothing like fullly automated continious integration in salesforce so do expect some manual steps and workaround while doing it.
FYI: Unsupported metdata types https://developer.salesforce.com/docs/atlas.en-us.api_meta.meta/api_meta/meta_unsupported_types.htm
Thanks,
Fahad Akhtar