+ Start a Discussion
RustyboyRustyboy 

Unable to set Author Apex Permission

Hi,

I am trying to submit my package to the source scanner but it failed (and now I have to wait 24 hours befre resubmitting) because I did not have Author Apex Permissions for the user. I did the research and learned that I need to set this on the user profile, but I cannot find this setting on my user profile.

Any help greatly appreciated - I need to get this release out soonest

Thanks

PS: I have submitted several source scans in the past and never hit this problem. Has it changed in the past few months?
ShashankShashank (Salesforce Developers) 
You should be able to find the Author Apex permission under the Administrative Permissions section of your profile. Please see attached.User-added image
Mukesh Kumar 107Mukesh Kumar 107
Open Profile -> Page Section - Adminstrative Permissions -> check/uncheck "Author Apex" checkbox.
Orlando BricenoOrlando Briceno
Thank you!
Henrik Johansson 9Henrik Johansson 9
Hi,

I really can't find it either. The "Administrative Permissions" on the "System Administrator" profile is ju not there.
I have started a trial with the express purpose of testing integrations.
What can be wrong here? I am not an experienced Salesforce user although a long time programmer.
Parag SevraParag Sevra
FYI:

"Author Apex" User Permission is needed to define, edit, delete, set security, set version settings, and run tests for Apex classes. 

It is only Available in: PerformanceUnlimitedDeveloper, and Enterprise Editions

Also check:  

Regards,
Parag Harji Sevra
Deb HalderDeb Halder
Hi @Rustyboy,

'Apex Author' permissions are available under Profiles. Type 'Profiles' under Quick find box and open System Administrator (if you are one or if you belong to a different profile) and scroll down to that profile to see "Administrative Permissions". You can find Author Apex marked under it. Certain profiles may not be enabled with this option, so you could think of switching profiles.

If this helped please mark as helpful.


Thanks
Tushar Shirsath 1Tushar Shirsath 1
For  Salesforce Platform Profile Apex Author Option is not there for checked or Unchecked.
Terence MillsTerence Mills
I'm trying to set Apex Author permission but it's not giving me the option under Administrative Permissions. Please adivse how I can set this up
RRAJRRAJ
It is now under "System Permissions".
sukriti gupta 9sukriti gupta 9
Hi Everyone, I am unable to find Author apex setting in administrative/system settings in developer org for system administrator profile. Help me out pls