+ Start a Discussion
Kaustav BhattacharyaKaustav Bhattacharya 

Trailhead: Unable to create Visualforce pages

I'm following a Trailhead excerise in creating a custom object. In the tutorial it advices to create a help page for the custom object. The action to carry out is:

From Setup, enter Visualforce Pages in the Quick Find box, then select Visualforce Pages.

However, when I type Visualforce into the setup > search box nothing appears. 

I did a search on these forums and it seems I need to enable developer mode, so I followed a link to v34 of the Visualforce guide which has a step by step guide on how to enable developer mode. Incidentally this guide is badly out of date as none of the links in any of the steps are correct. I messed around and eventually found the screen in which I could activate developer mode. Saved. 

I still cannot see Visualforce in Settings > Search.  What am I doing wrong?

Thanks in advance.
Best Answer chosen by Kaustav Bhattacharya
Shyama B SShyama B S
Or you can go to :
       Setup -> Build -> Develop -> Pages
       Click 'New'.
You can create the page there without going to developer console.

All Answers

Luke SimpsonLuke Simpson
This is probably because you don't have a Dev Org with the new Lightning Experience UI enabled (https://developer.salesforce.com/lightning/platform-features).  You will have to wait until Winter '16 is GA to be able to get a dev org with the Lightning Experience, or you can request a pre-release org here (https://www.salesforce.com/form/signup/prerelease-winter16-partner.jsp).
Shyama B SShyama B S

Hi Kaustav,

Go to:
Setup -> Build -> Develop -> Pages

Click on Developer Console.
 
Then go to File -> New Visualforce Page.

Thanks,
Shyama
Shyama B SShyama B S
Or you can go to :
       Setup -> Build -> Develop -> Pages
       Click 'New'.
You can create the page there without going to developer console.
This was selected as the best answer
Amit Chaudhary 8Amit Chaudhary 8
  Setup -> Develop -> Pages
User-added image

Please let us know if this will help you

Thanks
Amit Chaudhary

 
John HJohn H
I also ran into this issue during the trailhead exercise.  I can confirm that you can find it from "Pages"
   Setup -> Build -> Develop -> Pages
However the instructions are misleading since they do state to search for "Visualforce" in the setup search. Since trailhead is still a beta I would chalk it up to a bug.  Also just a side note but I had just spun up my org for Trailhead so if its due to the wrong type of org I would expect everyone would be run into a similar issue(Until the new updated trial org is released).  
Kaustav BhattacharyaKaustav Bhattacharya
Thanks everyone for helping out. Got it all working now. Lots of routes in. I think I've found my preferred method from all your help.