+ Start a Discussion
Adelchi PelizzoAdelchi Pelizzo 

How to customize Under Construction page in Site.com

Seems that Salesforce uses a default "Under Construction" VisualForce page.
This page is displayed when a specific page isn't available from Site.com.
I want to customize this page OR assing a different one when user wants to load an no-existing page.
I have found a page called "Under Construction" and tried to eliminate most part of it, but the final result remain unchanged.
Best Answer chosen by Adelchi Pelizzo
Adelchi PelizzoAdelchi Pelizzo
The page returned trying to retrieve an non-existent page is always the same. Declarative assigment do not change the result. Even editing the Default Under Construction page will not take effect. The returned page will be still the same one.

All Answers

Neetu_BansalNeetu_Bansal
Hi Adelchi,

May be you are not allowed to override the existing pages, but you can create your own page and assign it by following the below steps:
To set the error pages for your site:
  • From Setup, click Develop | Sites.
  • Click the name of the site you want to modify.
  • Click Page Assignment on the Error Pages related list.
For more info, please refer this link:
https://help.salesforce.com/apex/HTViewHelpDoc?id=sites_error_pages.htm&language=th (https://help.salesforce.com/apex/HTViewHelpDoc?id=sites_error_pages.htm&language=th)

Let me know if you need any other help.

Thanks,
Neetu
Adelchi PelizzoAdelchi Pelizzo
The page returned trying to retrieve an non-existent page is always the same. Declarative assigment do not change the result. Even editing the Default Under Construction page will not take effect. The returned page will be still the same one.
This was selected as the best answer
Anirudh SinghAnirudh Singh
Hi Adelchi,

Please follow the following steps:
1. Go to Setup--> Develop (On side bar)--> Sites--> Click on the relevant Site Label.
2. You will now be able to see the details of the Site now.
3. In Sites, you need to change the 'InMaintenance' visualforce page. If you navigate to Sites, you will find this page under 'Site Visualforce Pages'.
 

Below is a screenshot attached:

User-added image

If you will change this page, you will be able to see your changes.

Please let me know if this helps.
Please mark the question as solved if this resolves your issue.


Thanks and Regards,
Anirudh Singh
Adelchi PelizzoAdelchi Pelizzo

InManitenance page is not the one returned when trying to get an non-existing page.

Did you try? 

1 - Create a site
2 - Using your org url add /xxxx
3 - Verify that the page returned is always the same, even if you edit, replace , dis-allow page in your site settings.

Anirudh SinghAnirudh Singh
Hi Adelchi,

Yes, it is definitely working for me.

Please find below the screenshot for the changed Visualforce Page:

User-added image

On the site, the content is now visible as:

User-added image

Please let me know if this helps.
Please mark the question as solved if this resolves your issue.


Thanks and Regards,
Anirudh Singh
Neetu_BansalNeetu_Bansal
Hi Adelchi,

I guess you are not able to overwrite any pages. Please check have you specified any Path in custom URL's of Sites. If yes, please remove that. This is causing the issue.

Let me know if you need any other help.

Thanks,
Neetu