+ Start a Discussion
Matt Low 2Matt Low 2 

Challenge - Formulas & Validations/Using Formula Fields

Hello - I've completed the challenge for Using Formula Fields in Trailhead and I can see, by creating a new Case, that my formula is working correctly. However, when I click the Check Challenge button, I get the message, "Challenge not yet complete... here's what's wrong: 
The 'Days_Since_Last_Update__c' formula field did not return the correct number of days between an Account’s Last Activity Date and today"

My formula is:  TODAY() -  Last_Activity_Date__c

User-added image

User-added image

User-added image

Can you please help me figure out how to get past this? Thanks.

 
Best Answer chosen by Matt Low 2
Chris AldridgeChris Aldridge
Hi Matt,

You need to make a slight tweak to your formula.

You need to use the Last Activity Date on the Account - I made the same mistake!

Try:
Today()- Account.LastActivityDate

 

All Answers

Chris AldridgeChris Aldridge
Hi Matt,

You need to make a slight tweak to your formula.

You need to use the Last Activity Date on the Account - I made the same mistake!

Try:
Today()- Account.LastActivityDate

 
This was selected as the best answer
Matt Low 2Matt Low 2
Thanks Chis, that worked. Strange how mine seemed to work correctly. You really have to read the wording carefully! Thanks again.
Cori O'BrienCori O'Brien
I'm having the same error on this test. I've confirmed my formula is correct, but for some reason it's not working. I can't see it working in action though...I don't seem to have an Account field called Last Activity Date, even though I can choose it in the formula "Insert Field" area. Any idea why I don't have this accout field in my Dev edition org?

 
Cori O'BrienCori O'Brien
No Last Active Field on AccountMy Formula

Here are my screenshots if they help. 
Michael Richards 16Michael Richards 16
Cori, 

The issue is that you have the two fields in the wrong order. Just change it to be TODAY() - Account.LastActivateDate. 
Elizabeth SElizabeth S
I also had an issue on this and I wonder if it has to do with the API name.   The assignment given API Name (Days_Since_Last_Update__c) is different than that it defaults to AND I got an error message I couldn't save this API name with two underscores (after update).   So I removed one, but that does mean the API field name would not match what the exercise has listed.   Is that part of the issue with this exercise not being able to be completed?    field does not exist

Also, despite matching the correct formula (TODAY() - Account.LastActivityDate), no number is returned.   Would the API Name issue be involved in that or it is a separate issue?