+ Start a Discussion
Kevin Nussbaum 7Kevin Nussbaum 7 

All the expected custom fields for the Campsite_Reservation__c object could not be found.

All the expected custom fields for the Campsite_Reservation__c object could not be found. can anyone help... im in trailhead taking a module
Brian Sherman 22Brian Sherman 22
From another thread:

Turns out that his problem can be related to Fied Level Security (FLS) settings for your Org. For some unknown reason, the FLS for one of the fields on the Campsite Reservation object made that field invisible to the System Administrator profile. That was the reason the challenge check couldn't 'find' the field and was throwing an error. 
For future reference, please make sure that all the objects and fields that you create as part of this challenge are visible to the System Administrator profile.
Kevin Nussbaum 7Kevin Nussbaum 7
Thanks Brian, how do I fix the Problem though...?
Brian Sherman 22Brian Sherman 22
Check the field-level security on all the fields on that customer object.  ALL fields should be visible to the System Administrator proile.
Brian Sherman 22Brian Sherman 22
In setup, search for Field Accessibility and click it.  Then, click on your custom object, and click view by profile and select System Administrator.  ALL fields should be viewable.
Kevin Nussbaum 7Kevin Nussbaum 7
How do you make them viewable... they all say read-only....?
Brian Sherman 22Brian Sherman 22
You should be able to click where is says Read-Only and change it from there.
Brian Sherman 22Brian Sherman 22
Read only is ok by the way, hidden is not.
Kevin Nussbaum 7Kevin Nussbaum 7
So if they all say read only I should be good..?
Kevin Nussbaum 7Kevin Nussbaum 7
Still Coming up with...Challenge Not yet complete... here's what's wrong: 
All the expected custom fields for the Campsite_Reservation__c object could not be found.
Kevin Nussbaum 7Kevin Nussbaum 7
they all read User-added image
Kevin Nussbaum 7Kevin Nussbaum 7
Still not working
Parker EdelmannParker Edelmann
Hi @Kevin Nussbaum 7,
Right click Read-Only and open a new tab for each field. It will take you to another page where you can configure the field settings. There should be a check box with a read only label, Deselect it. Try that and see if it helps. By the way, you wouldn't happen to have any app exchange packages would you? That could be messing with the field names and cause it to give an error.