+ Start a Discussion
Lizzie1379Lizzie1379 

Configuring a Salesforce Console - Trailhead

Hi,

I'm trying to activate the Service Cloud sample console and i was getting this when i was assigning it to the profiles. I alread delete some of my apps but still im geting the error below. Any ideas? Thanks for your help!

App Limit Exceeded
Can't complete this operation because it would exceed the number of apps allowed by the user license. 
Amit Chaudhary 8Amit Chaudhary 8
Can you please post the screen shot of your app and Module URL.

Please check below post.
1) https://success.salesforce.com/answers?id=90630000000h6eVAAQ
2) https://success.salesforce.com/answers?id=90630000000h3hNAAQ
3) http://help.salesforce.com/HTViewSolution?id=000220879

When assigning a user a permission set that gives them access to Work.com app you may encounter this error.  This error will typically only occur when trying to assign a permission set that grants access to the Work.com app to a user whose license limits them to custom apps (e.g. Salesforce Platform, Force.com App Subscription).

To resolve the issue, remove Work.com / your App as an assigned app from the permission set:

1. Go to Setup | Manage Users | Permission Sets and select your permissions set
2. Click on Assigned Apps
3. Remove Work.com / your App from the Enabled App list
4. Optionally add the Work.com tabs (e.g. Goals, Coaching, Feedback) to an app already accessible to these users.

 
Chris ChurchChris Church
On the screen prior to receiving that error message, the last section of that page is the "Assign to Profiles". You're shown that you check the "Visible" box at the top & thereby make the app visible to all the profiles listed. Here's the problem; some of those profiles don't have the "Sample Console" app checked in the "Visible" column on there profile in the "Custom App Settings" section (visible after clicking the "Edit" button). Some profiles don't have the app listed in their "Custom App Settings" section at all (you can add it if you wish).
If you go into the "Sys Admin" profile, you should see that app & if the box isn't checked - check it. Now go back into that "Sample Console" app and check only "Sys Admin" in the visible column. Save. It should now work - mine did. 
If you feel the need to add more profiles, just add the app to the profile "Custom App Settings" and check the box under the "Visible" column. I think the "Sys Admin" is all you need to complete the trailhead though.