+ Start a Discussion
Nisha BabuNisha Babu 

Admin Beginner  Reports & Dashboards :Challenge Not yet complete... here's what's wrong: The 'LEAD Trend by Source' dashboard component is not a pie chart.

Hi all,
The question is
Install an AppExchange dashboard package and make updates to one of the dashboards.
You’ve been asked to create a new Lead trending dashboard. Rather than creating the dashboard from scratch, install a CRM adoption dashboard package from the AppExchange into your Developer Edition environment and update one of the dashboard components as specified below. (Note: While it's a best practice to always clone a dashboard before you modify it, for this example, you can go ahead and modify the dashboard directly).
Install Salesforce Adoption Dashboards from the AppExchange into your Developer Edition.
Refresh the '3 - Sales & Marketing Adoption' dashboard in the 'Salesforce Adoption Dashboards' folder at least once.
In '3 - Sales & Marketing Adoption' dashboard, change the dashboard component for 'New LEAD Trend by Source' to a pie chart and set the wedges to Lead Source.

The thing that I did:
User-added image

The Error I am getting:
Challenge Not yet complete... here's what's wrong:
The 'LEAD Trend by Source' dashboard component is not a pie chart.

With Regards,
   Nisha



 
Best Answer chosen by Nisha Babu
Nisha BabuNisha Babu
Hi all,

Install Salesforce Adoption Dashboards.

Salesforce Adoption Dashboards---->View Component---->3 - Sales & Marketing Adoption--->Refresh---->drag the pie diagram to the LEAD Trend by Source-------->Components----->Wedges----->Lead Source.

With Regards,
   Nisha.

All Answers

Pritam ShekhawatPritam Shekhawat
Verify in Lead Trend By source you set to group by Lead Source. Take  below image for reference. 
User-added image
Nisha BabuNisha Babu
Hi Pritam,

Actually, I did that.
The error is :Challenge Not yet complete... here's what's wrong:
The 'LEAD Trend by Source' dashboard component is not a pie chart.

I  named the dashboard as 'LEAD Trend by Source'.

With Regards,
    Nisha

 
Nisha BabuNisha Babu
Hi all,

Install Salesforce Adoption Dashboards.

Salesforce Adoption Dashboards---->View Component---->3 - Sales & Marketing Adoption--->Refresh---->drag the pie diagram to the LEAD Trend by Source-------->Components----->Wedges----->Lead Source.

With Regards,
   Nisha.
This was selected as the best answer
Joseph Enrique PerezJoseph Enrique Perez
Hi Nisha, I think you did that but you have to save the changes.
Nisha BabuNisha Babu
Hi Joseph,

That is correct.

With Regards,
    Nisha
Christie Diedrick 2Christie Diedrick 2
Hi there, I am following the  instructions above but the chart says it returns zero results, see record count in the pic below. new lead trend by source
Christie Diedrick 2Christie Diedrick 2
I did change the wedges to Lead Source. Thx.
SUCHARITA MONDALSUCHARITA MONDAL
getting error in the same task-----------------The 'LEAD Trend by Source' dashboard component does not have the wedges set to 'Lead Source'.
SUCHARITA MONDALSUCHARITA MONDAL
getting error in the same task-----------------The 'LEAD Trend by Source' dashboard component does not have the wedges set to 'Lead Source'. thoug I think I'm on correct path but still getting problem..User-added image
Ekta Jain 13Ekta Jain 13
Sucharita, 
I am stuck in the same challenge, were you able to solve it. If so can you explain me?
 
John Adams 31John Adams 31
For me, the dashboard was pulling the chart directly from the report.  At first I just changed the chart in the report which worked on the dashboard but didn't pass the test.  On the dashboard, I had to uncheck the box "Use chart as defined in source report" in the component editor.  I was then able to drag the pie chart component over and change the wedges to "lead source."  That seemed to make Trailhead happy.
Anand DeshpandeAnand Deshpande
I agree with the solution proposed by John Adams.
User-added image
Randolph Abelardo 7Randolph Abelardo 7
Hi everyone! 

I also experienced the same error on the last challenge for the Admin Beginner module. 

I renamed the title, changed the wedges from "Lead Source" to "Created Month" (thinking this might work), saved then refreshed the dashboard - didn't work. So I reverted setting the wedges to "Lead Source" again, saved then refreshed - nogo. 

I'm not sure if it's because of my persistence clicking the Check Challenge button after I saved and refreshed or if it's because I also reverted the settings under the Formatting tab that I finally passed the challenge (that is, leaving all the graph settings to default - except for the wedges, as instructed in the specs). 

Hope this helps.

- Randy, Trailhead newbie

User-added image
User-added image
Megan Manetas 1Megan Manetas 1
Randolph Abelardo 7 - your suggestion worked for me! Finally! THANK YOU!
Raja SFDC 8Raja SFDC 8
Hi Folks,

I faced the same issue too, I don't think that is my mistake. 

Here is the issue I faced:
      I cloned the DB and updated only the original DB, so TH showed the error when I challenge it.
      This issue got resolved After updating the Cloned DB as well.

To identify the issue, it took 30 mins for me....... crazy
 
Rodolfo Rodriguez 8Rodolfo Rodriguez 8
I just had the same error, but I figured out the problem I was having. I edited the chart from the Report itself using the customize option -> edit chart. Turns out after I edited the Dashbaord then selected "edit attributes" on the chart, even though I had already selected the Wedges to Lead Source in the report, the component editor has "Auto" under Wedges. once I fixed it, and saved I completed the challenge no problem.
Nathalie Breysse 6Nathalie Breysse 6

Hi everybody. HELLLPPPP   I have the same problem... In fact, it's worth : the is no "Lead Source" text so I can't us it !

 

 

Patricia WoodsPatricia Woods
Help!!! I can install the app, but it only shows up if I install it in production. When I do, the report dashboard does not include pie wedges as an option so I cannot complete the task.
Taiwo Aladeojebi 8Taiwo Aladeojebi 8
You need to get to this view to be able to successfully save the Lead Source
How to successfully edit and save lead source
Kellye SibleyKellye Sibley

I was very confused by this one, because I was attempting to edit the graph from the wrong location. I hope the screenshots below will help others avoid the mistake I made.

To change the graph, do not click on the graph itself. When you click on what I've X'ed out in red below, you can navigate to a dialog box that looks very similiar to the ones shown by Anand and Randy above, but it does not have the checkbox at the top, and has fewer options. Editing the graph this way was not accepted by Trailhead.

Instead, click the edit button at the top.

User-added image

Then you will see the view that Taiwo Aladeojebi mentions above. Drag the pie chart on the left to the New LEAD Trend by Source.

User-added image

Trailhead verified this and awarded me the points without me making any further edits to the pie chart. However, you can click the little wrench at the top of the pie chart section, and you will see the dialog box shown by Anand and Randy in the posts above if you need to make more edits.

I hope this clears up some confusion about where the edit needs to be made to be verified by Trailhead.

 

 

Chad Sutton 1Chad Sutton 1
^^ Thanks, Kellye! That worked for me.
Amit SahooAmit Sahoo
Hello everybody,
I tried the options mentioned above, but nothing worked for me. Not sure how do I clear this issue.

User-added imageUser-added imageUser-added image
Any solution is much appreciated.
Thanks
 
Patricia WoodsPatricia Woods
None of the solutions presented have worked for me either. I do not get a pie chart as an option.
Tony Stark 45Tony Stark 45
I've tried every step from above suggession but I got below error.

Challenge Not yet complete... here's what's wrong: 
The '3 - Sales & Marketing Adoption' dashboard wasn't found. Make sure that you've installed the 'Salesforce Adoption Dashboards' AppExchange package and refreshed that dashboard
Jourdan Harding 8Jourdan Harding 8
Pie chart is not an option for me to select in the Trailhead Playgound. The interface looks like it's Lightning and not Salesforce Classic. How do you complete this challenge if you can't select Pie Chart?
Amanda McCrackenAmanda McCracken
None of the above is working for me at all. Begining to wonder if its a glitch.
Akila RajmahadevAkila Rajmahadev
The above steps dont seem to work.
Error:Challenge Not yet complete... here's what's wrong: 
The '3 - Sales & Marketing Adoption' dashboard wasn't found. Make sure that you've installed the 'Salesforce Adoption Dashboards' AppExchange package and refreshed that dashboard

\
Claudio Bruno 8Claudio Bruno 8
My challenge give this error:
User-added image
I tried to follow the tips above, but I didn't solve
Ana Karen HernandezAna Karen Hernandez
I can´t clone the dashboard to edit it. I don´t have that button:User-added image
Surivan SimmalavongSurivan Simmalavong
Hi !
I did all the stages : 
- Install Salesforce Adoption Dashboards from the AppExchange into your Developer Edition.
- Refresh the '3 - Sales & Marketing Adoption' dashboard in the 'Salesforce Adoption Dashboards' folder at least once.
- In '3 - Sales & Marketing Adoption' dashboard, uncheck the 'Use chart as defined in source report' box. Change the dashboard component for 'New LEAD Trend by Source' to a pie chart and set the wedges to Lead Source.

But I have the same error : "Challenge Not yet complete... here's what's wrong: 
The '3 - Sales & Marketing Adoption' dashboard wasn't found. Make sure that you've installed the 'Salesforce Adoption Dashboards' AppExchange package and refreshed that dashboard"

I tried some tips but I can't validate this step
Katherine PatettaKatherine Patetta
I followed the steps in the challenge, but I keep getting this error message. Clearly the chart is a pie chart. I refreshed the page, didn't work. I tried uninstalling and reinstalling the app, too. Anyone know how to fix this error message?User-added image
James LoghryJames Loghry

Katherine,

Did you create the chart directly in the report builder, or did you create it through the dashboard?  I ask, because others have had success resolving your issue by unchecking the "use chart as defined in source report" button, as discussed in this thread: https://developer.salesforce.com/forums/?id=906F0000000DDsuIAG.  Also, double check and make sure the wedges are set to "Lead Source" in the pie chart (which it looks like they are).

 

Katherine PatettaKatherine Patetta
Hi there, I just uninstalled and installed the app to see if it would work. The error message was the same. This is what I did: I installed the app. Clicked view components, then 3 - Sales & Marketing Adoption. Refreshed the dashboard. Pressed Edit. Edit the New LEAD Trend by Source diagram. Unchecked the box "Use chart as defined in source report." Then edited the chart to be a pie chart with Lead Source as the wedges. Pressed Save and close. The error message appeared again. I am not sure what is wrong. Thanks for helping me out! Best, Katherine
KAMAL GARG 11KAMAL GARG 11
I run into the same problem: The '3 - Sales & Marketing Adoption' dashboard wasn't found. Make sure that you've installed the 'Salesforce Adoption Dashboards' AppExchange package and refreshed that dashboard"

Here is my solution and it worked!
1) Go to developer.salesforce.com and sign up a DE edition
2) you'll get an email to verify your account and set up pw
3) Go to Trailhead and launch deverloper version with the new account
4) Redo the task and it shows 'Challenge Complete"!
Ragavendiran Manohar 6Ragavendiran Manohar 6
I have uninstalled and reinstalled Salesforce Adoption Dashboards and re did the Challenge and it worked
TapeshwarKumarTapeshwarKumar
Follow Below Steps
1. User-added image
2. User-added image
3. User-added image
Hiran Bhatt 6Hiran Bhatt 6

Hi everyone, I'm getting the same error message: "The '3 - Sales & Marketing Adoption' dashboard wasn't found. Make sure that you've installed the 'Salesforce Adoption Dashboards' AppExchange package and refreshed that dashboard"

I've tried all the steps above but this is the problem:

User-added image

I've uninstalled and reinstalled the app several times and even tried to login in a private browser. Nothing is working. Please help!

Nicholas C. BrownNicholas C. Brown

@Hiran- I get the same error; I'm pretty sure this excercise is bugged. I'm experiencing the same issue and have not been able to resolve.

User-added image

User-added image
User-added image
I will try one last step in uninstalling the package, then reinstall, and finally try the excercise again.
Hopefully this gets examined in the mean time.

Best,
N. Brown

 

Lorraine Goodman 7Lorraine Goodman 7
When I try to do this exercise, there is no Pie Chart option. (And in Classic View, I cannot even edit the dashboard at all.)


User-added image
Bhuvanesh MohankumarBhuvanesh Mohankumar
This exercise has to be done in Salesforce classic and does not support in Lighting version
Ganesh DakshinamoorthyGanesh Dakshinamoorthy
Thank you Tapeshwar Kumar it works exactly the way you did!!!
Jarrell DunsonJarrell Dunson
OK, this is really frustrating... I've tried multiple times follow the instructions fo this trailhead: 
https://trailhead.salesforce.com/modules/reports_dashboards/units/reports_dashboards_appexchange
The instruction link, Salesforce Adoption Dashboards, takes me here: https://appexchange.salesforce.com/listingDetail?listingId=a0N30000004gHhLEAU
*** Every time I've tried this... it takes me to my a) Production enviroment ... https://na40.lightning.force.com/.... 
OR my Sandbox environment: https://test.salesforce.com/...

**** But I cannot install on my trailhead environment....https://brave-raccoon/....so, I can't complete the rest of the steps.  I'm not the only one having this issue (see above)... 

I've tried going through developer.salesforce.com login... to no avail...

*** Can someone please help??? ... **** Can someone at Salesforce please fix this???
There are three of us on our staff that can't get past it....
Thanks
 Jarrell

Here are some more links...  



"Install an AppExchange dashboard package and make updates to one of the dashboards." bugged - Salesforce Developer Community
https://developer.salesforce.com/forums/?id=906F0000000BMXoIAO

Error in Hamds on challenge - Salesforce Developer Community
https://developer.salesforce.com/forums/?id=9060G000000MSe8QAG

Admin Beginner  Reports & Dashboards :Challenge Not yet complete... here's what's wrong: The 'LEAD Trend by Source' dashboard component is not a pie chart. - Salesforce Developer Community
https://developer.salesforce.com/forums/?id=906F0000000DDsuIAG

Salesforce Developers | API Documentation, Developer Forums & More
https://developer.salesforce.com/

Install an AppExchange dashboard package and make updates to one of the dashboards - Salesforce Developer Community
https://developer.salesforce.com/forums/?id=9060G000000MRP7QAO

Install an AppExchange dashboard package and make updates to one of the dashboards - YouTube
https://www.youtube.com/watch?v=IFdz4TLvVlc








 
Jarrell DunsonJarrell Dunson
I figure this out myself... 
I had to "Enter an Alternate Domain" and use the full name of my trailhead domain: 
  Not this: https://brave-raccoon-111111.com
  But this: https://brave-raccoon-111111-dev-ed.lightning.force.com

(where 111111 would be the number of your trailhead URL)
 
RangnathRangnath
Hi All,

PROBLEM SOLVED!!!

I have also been struggling a lot to achieve this.

When you are deploying the package you should select the second option i.e, For Admin and all other users

doing so will give you option to edit the Dashboard (use classis view) and change the report accordingly.
Brajesh jha 6Brajesh jha 6
Challenge not yet complete... here's what's wrong:
There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Delete failed. First exception on row 0 with id 5007F00000KBnpiQAD; first error: DELETE_FAILED, Your attempt to delete 00001037 could not be completed because it is associated with the following caseinprogresstimes.: a017F00000gUEVy : []
Luca CroceLuca Croce
Challenge not yet complete... here's what's wrong:
The 'Web Leads' report is not using Leads as the report type.

It's not true. I have created a Report with Lead Report Type. I CAN'T COMPLETE THE MODULE. I'M BLOCKED!!!
Arthur Martins SilvaArthur Martins Silva
People that couldn't complete the module I suggest to uninstall the package "Salesforce Adoption Dashboards" and install again using Salesforce Classic. Here it's work!
Oscar EscobarOscar Escobar
Hope this helps.

1) You will need to do it in Salesforce Classic
2) When you install the package "Salesforce Adoption Dashboards" choose : "For all users" (If you choose "For admin only" you will not get the "Edit" button 
3) Clic on "Edit" button and then modify the component "New Lead Trend by source"
4) You need to uncheck the option "Use chart as defined in source report" and then you will have access to pie chart
5) Change the wedges to "lead source."

Done.
Renato RibasRenato Ribas
In case you've initiated the exercise in Lightning relax but note it is impossible to complete in Lightning. The way to fix this is:

1) Uninstall the package "Salesforce Adoption Dashboards". Do this by going to Setup, searching for "Installed" on quick box and click on Installed Packages. Select Uninstall.
2) Once this is done go back to appexchange and re-install Salesforce Adoption Dashboards.
3) when back to the home page before even accessing the dashoboard change it Salesforce Classic. Continue as per post above.

If you're like me, who completed most of the exercises in Lightning you'll struglle with the classic view but be patient and you'll get throught this.
This finally worked for me.
Milan NandanMilan Nandan
Kindly make sure during Installation, you should select "Installation for Admin". Otherwise you will not get "Edit" option as per-- Kellye Sibley 
Debaranjan GhoshDebaranjan Ghosh
Thanks for all the informtion I was able to fix my problem with this two things I did 1> did it in ClassicView and 2> Edit and Save the Dashboard as suggested
Yogendra MohanYogendra Mohan
Thanks All
Finally, I have completed my challenge using "For all users" ("For admin only" I did not get the "Edit" button) during the installation of Sales & Marketing Adoption package.
After installation, edit the Dashboard and then modify(click wrench) the component "New Lead Trend by source"

Remaining steps are same as mentioned by Oscar Escobar.

Done :)
Amanda LougeeAmanda Lougee
THANK YOU!! After what seems like forever this feed helped me pass the challenge. I had to uninstall and, like many said, re-install "FOR ALL USERS". Once installed, go to the cassic view and find the Sles & Marketing Adoption dashboard. You'll notice the edit button appears (vs. before when installed for admin only). Then, follow TapeshwarKumar's awesome directions. 
Abhishek Sharma 283Abhishek Sharma 283
I have seen that many are facing issues in this task(including me). Even when I did google, there were not well explained solutions for it. Finally! I have resolved it  after 2 days and thus posting key steps that must be followed. 
1) Uninstall and delete the dashboard package.
2) Close all google chrome instances and open new incognito window.
3) Create new playground and reset its password. Note the username and password somewhere.
4) After resetting the password, you will be automatically logged in with that new password via link in email. 
5) Use salesforce classic for this task. Install package by going to app exchange. (Don't click on the link provided to install step up in trailhead.)
6) During installation you will be asked for relogin. Please enter the username and password which we have noted in step 3 above.At one place you will be asked to select either Production or Sandbox installation. Select production and give access to ADMIN only.
7) After successfull installation, go to dashboard and refresh it.
8) Click on the report component and edit the chart only by clicking on edit button.
9) Choose pie chart and set the wedges to "source". Save it.
10)Imp. Now go to dashboard list,refresh & select the dashboard and click on an tools icon above the piechart component. 
11)Imp. Select piechart and wedges here again, click save and run report.
12) Before clicking on verify step button, refresh the page. Done. 
 
vishal garud 27vishal garud 27
same error " it is not a pie chart" though I see it in the dashboard... not sure if a bug!!!!