+ Start a Discussion
Geoff SpozettaGeoff Spozetta 

CmsForce2 Web form not displaying

Hi All,

I'm currently attempting to put a CMSforce2 web form on a page, however I'm seeing that upon inserting into a page, the form elements are not displayed and I am unable to find out why.   The only thing that will appear is a greyscale button, however this tiny and thin:

User-added image


Would love to know if there;s something I am missing - This one does not quite make sense to me
 
pconpcon
Can you please include the code you have currently in place?

NOTE: When adding code please use the "Add a code sample" button (icon <>) to increase readability and make it easier to reference.
Geoff SpozettaGeoff Spozetta
Hi pcon,

Thanks for taking the time to look at my question. With CMSforce 2, there's no code that I'm manually writing. However, this is what is being rendered for that block in HTML5:

 
<div class="contentblockwebform">
<form id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138" name="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138" method="post" action="/csas/page" enctype="application/x-www-form-urlencoded">
<input type="hidden" name="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138" value="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138" />

	<br />
		
		<b>&nbsp;</b>
	<br />
	<br />
	
		
	<table><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:0:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:0:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:1:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:1:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:2:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:2:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:3:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:3:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:4:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:4:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:5:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:5:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:6:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:6:j_id151"></span>
				</td>
				</tr></span><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:7:j_id149">
				<tr>
				<td></td>
				<td><span id="j_id0:j_id5:j_id6:j_id116:j_id117:j_id127:0:j_id135:j_id136:j_id138:j_id144:7:j_id151"></span>
				</td>
				</tr></span>


The template that I am using is writting like so:
 
<apex:page showheader="false" sidebar="false">

<html lang="en">
  <head>
    <meta charset="utf-8"/>
    <meta http-equiv="X-UA-Compatible" content="IE=edge"/>
    <meta name="viewport" content="width=device-width, initial-scale=1"/>
    <!-- The above 3 meta tags *must* come first in the head; any other head content must come *after* these tags -->
    <meta name="description" content=""/>
    <meta name="author" content=""/>


    <title>innovations| ordering portal</title>

    <!-- Bootstrap core CSS -->
    <apex:stylesheet value="{!URLFOR($Resource.bootstrap, '/css/bootstrap.min.css')}" />

    <!-- Custom styles for this template -->
    <apex:stylesheet value="{!URLFOR($Resource.bootstrapjumbo)}" />

    

    <!-- HTML5 shim and Respond.js for IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
      <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
  </head>

  <body>

    <nav class="navbar navbar-inverse navbar-fixed-top">
      <div class="container">
        <div class="navbar-header">
          <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false" aria-controls="navbar">
            <span class="sr-only">Toggle navigation</span>
            <span class="icon-bar"></span>
            <span class="icon-bar"></span>
            <span class="icon-bar"></span>
          </button>
          <a class="navbar-brand">Welcome {!$User.FirstName} to the |innovations ordering portal.</a>
        </div>
        <div id="navbar" class="navbar-collapse collapse">
          <form class="navbar-form navbar-right">
          <p> style="color:white"
            <div class="form-group"/>   

            </p>
            
          </form>
        </div><!--/.navbar-collapse -->
      </div>
    </nav>

    <!-- Main jumbotron for a primary marketing message or call to action -->
    <div class="jumbotron">
      <div class="container">
        <h1>nbn™|innovations</h1>
        <p>Bringing you the latest from the  product portfolio.</p>
   
      </div>
    </div>

    <div class="container">
      <!-- Example row of columns -->
      <div class="row">
        <div class="col-md-4">
          <h2><c:contentblock name="grid-heading-left"/></h2>
          <p><c:contentblock name="grid-left"/></p>
          
        </div>
        <div class="col-md-4">
          <h2><c:contentblock name="grid-heading-centre"/></h2>
          <p><c:contentblock name="grid-centre"/> </p>
        
       </div>
        <div class="col-md-4">
          <h2><c:contentblock name="grid-heading-right"/></h2>
          <p><c:contentblock name="grid-right"/></p>
        
        </div>
      </div>

      <hr></hr> 

      <footer>
        <p>; Company 2014</p>
      </footer>
    </div> <!-- /container -->
    

    <!-- Bootstrap core JavaScript
    ================================================== -->
    <!-- Placed at the end of the document so the pages load faster -->
    <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
    <script src="../../dist/js/bootstrap.min.js"></script>
    <!-- IE10 viewport hack for Surface/desktop Windows 8 bug -->
    <script src="../../assets/js/ie10-viewport-bug-workaround.js"></script>
  </body>
</html>
</apex:page>


 
pconpcon
I would take a look at your browers' console and see if you have any errors.  I'm guessing that your scripts on line 96 and 98 are not going to load.  Also you'll want to change your apex:page to the following:
 
<apex:page docType="html-5.0" showHeader="false" applyBodyTag="false" applyHtmlTag="false" standardStylesheets="false">