+ Start a Discussion
Luison Lassala 13Luison Lassala 13 

Custom object does not show up on "Related to" for testing Emails

Hi,
I have a link custom object called "Registrations" which links a Contact with a Course (another custom object) on a many-to-many relationship.
So Registration is the child object for Contact, and Course is the lookup object when creating a new Registration.

I want to send Emails to Contact showing which Course they are booked into (not a problem, as I can specify the Course on the "Related to Record:" look-up. But I need to specify the Registration instead, so that I can display merge fields from the Registration object on the Email.
There is no problem inserting Registration fields on the Email or the Template (the field chooser includes all the fields from Registration) but what I not allowed to do is to choose a specific Registration record - so when the email is sent (or tested) all the fields from Registration are blank.
 
User-added image

Any ideas greately appreciated.
Luison
Best Answer chosen by Luison Lassala 13
AnupPrakash_AlgoworksAnupPrakash_Algoworks
You need check the box allow Activity on the particular Object.

Please mark as best answer and do not miss giving a KUDOS

All Answers

AnupPrakash_AlgoworksAnupPrakash_Algoworks
You need check the box allow Activity on the particular Object.

Please mark as best answer and do not miss giving a KUDOS
This was selected as the best answer
Luison Lassala 13Luison Lassala 13
Wow! That simple!!! Thank you so much Anup: it worked.
Luison Lassala 13Luison Lassala 13
Can't find how to give you Kudos! Please direct me. Thx
Luison Lassala 13Luison Lassala 13
I don't see any blue star under your avatar on the reply.