+ Start a Discussion
Mark RootMark Root 

Visualforce page domain not changing

I'm working with an EE Salesforce org that's exhibiting some strange behaviour when it comes to Visualforce pages.

Normally, when I create a Visualforce page and then preview it, the domain changes because of the cross-domain security fix that was introduced a while back.  For example, the following is what the full URL of a VF page called "test" should be:

https://c.cs23.visual.force.com/apex/test

Here's what I'm getting on this particular org, though:

https://cs23.salesforce.com/apex/test

How is that possible?  I cannot seem to find anything that overrides the new visual.force.com domain with the old salesforce.com technique.  Has anyone seen this before or is there some kind of setting I'm not familiar with?  Thanks.

Mark.
Best Answer chosen by Mark Root
Mark RootMark Root
Turns out that there's a hidden permission that prevents the new URLs from being used.  You can file a case to have the permission disabled but Salesforce will warn you that it could break other functionality.  This presents a bit of a problem for us because we went to the trouble of updating our code to be compliant with the new security protocols but now the apps don't work for orgs that still have this permission enabled.

All Answers

pconpcon
How are you getting to the preview.  It should change the domain correctly.  Also, what version of the API are you using?
Mark RootMark Root
Turns out that there's a hidden permission that prevents the new URLs from being used.  You can file a case to have the permission disabled but Salesforce will warn you that it could break other functionality.  This presents a bit of a problem for us because we went to the trouble of updating our code to be compliant with the new security protocols but now the apps don't work for orgs that still have this permission enabled.
This was selected as the best answer