+ Start a Discussion
Charmian McIntyreCharmian McIntyre 

Error at Step 4

I am receiving this error message:
Step Not yet complete... here's what's wrong: 
An update to a Battle Station record with Weapon Status of 'Fully Operational' failed to post a Chatter message to the record. Make sure that the process is configured correctly and that it is activated. 
Note: you may run into errors if you've skipped previous steps.

The Validation rule is correct, the "Project Status' field update occurs correctly, the post is made to the chatter feed of the record (mine and the SF record that is used to verify the step) - and yet I get the error.
How should I troubleshoot this?
 
Charmian McIntyreCharmian McIntyre
Here is the Validation Rule:
User-added image
The  Process Builder:
User-added image
User-added image
User-added image

The Chatter Post from the verifcation:
User-added image

Thanks!
PhyoPinePhyoPine
I got the same issue. Not sure what is going on. I have deleted and recreated the process to no avail. 
PhyoPinePhyoPine
Just FYI, I use another Dev Org and start the process from scratch. It works fine in new Org now.
Charmian McIntyreCharmian McIntyre
I have deleted this process (re: the battle ship) and written another process for the Trailhead section on Process builder (contact address field updates from Account) - and am finding the same problem - the feilds are updating correctly in my dev.org but the trailhead process is reporting an error in the setup.  Is any one else having a similar situation?
Joanne Dority 20Joanne Dority 20
This is still broken....
Jeff DouglasJeff Douglas
If you are having a problem with this challenge, please send me (jdouglas at salesfoce) your credential and I'll log into your org and check it out.

Sorry for the inconvenience.

Jeff Douglas
Trailhead Developer Advocate
Joanne Dority 20Joanne Dority 20
Hi Jeff - I believe I made a very minor spelling  ...  After changing this, and logging in/out I fixed it.     The error message doesn't give you a very good hint.    Thanks!
AKASH KUMARAKASH KUMAR

Hi Jeff,
i still got the same error.
Please help to complete this module.

Thanks!!!

Jeff DouglasJeff Douglas
If you want to send me (jdouglas@salesforce.com) your DE login credentials I'll take a look for you.

Jeff Douglas
Trailhead Developer Advocate
AKASH KUMARAKASH KUMAR
Hi Jeff,
Now i got below error.
User-added image

I will send my credential.

Thanks!!!
John TraceyJohn Tracey
I am having the same problem. Very frustrating. Can you help me also, Jeff?
John TraceyJohn Tracey
Just sent you an email, Jeff.
Venkatesh SettyVenkatesh Setty
Help Jeff,
Getting the same error, 

Challenge Not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: QOJTNXPL
Houri Ohanian 7Houri Ohanian 7
I'm seeing this error - I've deleted the objects and recreated and still no luck...

Challenge Not yet complete... here's what's wrong: 
An insert of a Battle Station record failed. Make sure all of the fields are configured correctly.


 
John TraceyJohn Tracey
This is not from me. I had no problems with battle station Sent from my Verizon, Samsung Galaxy smartphone
Komal Tirmal 6Komal Tirmal 6
I was able to fix this error. I had made a spelling mistake in the field name. I put in "Weapon Status" instead of "Weapons Status". Also, after correcting this, I went back to the process builder and created a new version of the process picking the correct (updated) field name. I needed this because I was already at step 4, when I realized I made the spelling mistake.
Charmaine van der MerweCharmaine van der Merwe
I am also getting this error:  An insert of a Battle Station record failed. Make sure all of the fields are configured correctly.
I have double checked all the fields, but I can't find the problem