+ Start a Discussion
Yoshi RubinYoshi Rubin 

Having Trouble With Battle Station Module 5 - Reports

The Error I get is: "Step Not yet complete... here's what's wrong: 
Please check that your report includes at least all of these columns: Supply: Supply Name, Unit Cost, Quantity and Total. 
Note: you may run into errors if you've skipped previous steps."

this is my report:
my Report
not sure where I made a mistake
pconpcon
Try putting in them in the order that is provided.  There may also be a problem with the type of currency you are using since it's in Euros and not USD.
Yoshi RubinYoshi Rubin
The order the same as the example they provided and the currency is set by default I just set the type to currency not a specific one
pconpcon
What is the Report Name and Report Unique Name of your report?  You should get a different error if the name is wrong but it's worth checking.
Yoshi RubinYoshi Rubin
Hope this helps
User-added image
pconpcon
Those are both correct.  I'm going to reach out to someone on the Trailhead team and see if they can help.  In the meantime you can always follow this (you would have to re-do the other steps) [1]

[1] https://developer.salesforce.com/forums/?id=906F00000005JciIAE
Yoshi RubinYoshi Rubin
Would hate to have tos start from the beginning, Thank you for all the help if the Trailhead team can provide any info id be very greatful.
lee Kenneybrewlee Kenneybrew
I am having the same issue.  My issue occurs when I  (Summarize this Field.).  There is no data for the reports and I have no records for the report to pull/ I have tried the exercise 5 times to the letter.  Am I misisng data to pull from or is there an error in the coding for the records to populate?  
David Pirrie 5David Pirrie 5
I did get this Challenge to work and my report  looks very similar to yours! I used GBP. A couple of thoughts:
1/ If you have more than one Battle Station does the others have Supplies? (thinking nil records might be giving you the response)
2/ In the Report Filters check the Range is "All Time"
May the force be with you
Jeff DouglasJeff Douglas

Yoshi,

This particular check is just looking at the names of the fields in your report. It's checking to see if Supply: Supply Name, Unit Cost, Quantity and Total are the names of fields in the report. Perhaps you have some special characters in the field labels or maybe trailing spaces?

Jeff Douglas
Trailhead Developer Advocate

Jeff DouglasJeff Douglas
Lee,

What's the error message you are receiving?

Jeff Douglas
Trailhead Developer Advocate
lee Kenneybrewlee Kenneybrew
Jeff,I am getting the below message. Error: This report cannot be used as the source for this component. If it is a summary or matrix report, add one or more groupings in the report. If it is a tabular report with a row limit, specify the Dashboard Settings in the report.Source: Battle Station Supplies.  On the create a dashboard page, I am getting teh below message: This report cannot be generated be used as teh source for this component, if it is a summary or matrix report. add one or more groupings in the report.
Michael Kolodner 6Michael Kolodner 6
I'm having the same error as Yoshi. I have set all the names EXACTLY as the module indicated. I've learned about that problem from past experience.

But having followed directions, the resulting column names aren't quite the same as this step of the module indicates: Instead of "Total" it's "Total Cost" and instead of "Supply: Supply Name" it's "Supply: Supplies Name"

I tried changing the Total Cost field into the Total field, but that didn't fix it. I'll now try both. But others who try this module and follow the directions exactly for naming their custom fields are going to have problems.
Michael Kolodner 6Michael Kolodner 6
Nope, changing the field names to make sure my columns are named as shown in the module didn't work.
 
Michael Kolodner 6Michael Kolodner 6
But now I changed them back to the original method and it did work. Frustrating...
Yoshi RubinYoshi Rubin
Jeff I checked all the Field labels for any starnge spaces or any other characters out of place and didn't see any, tried to verify again and it wasnt accepted.
Yoshi RubinYoshi Rubin
Michael what did you do to get it to work?
Michael Kolodner 6Michael Kolodner 6
I had set Total Cost to be "Total" (and changed its API name as well.) I then went back and put it back to Total Cost and Total_Cost. I also went out of that page of the trailhead module--back to the steps in the Battle Station module. Then clicked on the step for reports. Then verify and this time it worked.
Jeff DouglasJeff Douglas
If anyone is having problems with this, email me your org credentials (jdouglas at salesforce) and I'll take a look. Please send the URL of the unit you are having problems with and any error message.

Thanks!
Jeff Douglas
Trailhead Developer Advocate
Moritz Behringer 4Moritz Behringer 4
Hi all,
had the same issue. Fixed it by changing the Supply Name.
Agree with Micheal, it's really frustrating if the tutorial doesn't match with the Org approval.
It took some time to find the problem -> maybe it's not a problem but the real challange ;) 

Best regards,
Moritz
Musa YildizMusa Yildiz
Had the same issue. Changing the Supply Name and Battle Station Name, fixed it!
Bill Powell - CSS IncBill Powell - CSS Inc
See I got beyond that part, and now getting "Please check that you summarized the total cost column for the report. " When the column is indeed summarized. Any ideas? 
Christopher Brenz 8Christopher Brenz 8
Hi All - I had the same error message and could not get Verify to work.  With Jeff Douglas' help I was able to resolve this.  In my Supply custom object, my Total Cost custom field had an extra space in the Field Label which was causing the verify error.  Changing "Total  Cost" to "Total Cost" (only one space between letters) fixed my issue, and then the verify step worked!
Jason CarwellJason Carwell
Hello,

The solution of Re-entering the Label, Plural Label, Object Name and Record Name of the Battle Station and Supply objects helped me with the error message: The 'Battle Station Supplies' report was not the correct report type. It needs to be using the type 'Battle Station with Supplies'.
Forrest Muldune 31Forrest Muldune 31
I tried all these solutions mentioned above, but nothing worked. Does anyone have any other solution(s)?
Kathy Callaghan-BixlerKathy Callaghan-Bixler
I need help with a trailhead verify steps: Expand the Other Reports folder, select Battle Station with Supplies and click Create. - this is the instruction trailhead gives and the reports only gives us Battle Stations with Supplies.  How do I fix this?
 
Chris BowersChris Bowers
I cannot complete this module due to the following error:

Challenge Not yet complete... here's what's wrong: 
Please check that your report includes at least all of these columns: Supply: Supply Name, Unit Cost, Quantity and Total Cost.

I have verified all fields are present and are correctly named. I am using a Trailhead Playground. Please help me complete. Thank you.
Claudio Bruno 8Claudio Bruno 8
Challenge Not yet complete... here's what's wrong:
User-added image

But, my report type is:
User-added image

Thanks in advance,
Claudio
Georgina RotenbergGeorgina Rotenberg
I have also had the report type error and when I tried to rename everything, one of my troubleshooting steps was to delete my report to start over.  Now I cannot recreate the report with the same name to test whether my corrections have worked.  I cannot complete the module even though I know how to create reports and dashboards from my own work experience.  Help!  Thanks, Gina Rotenberg 
Norbert WieruszewskiNorbert Wieruszewski
Here is my solution for problem:
The 'Battle Station Supplies' report was not correct report type. Id needs to be using the type 'Battled Station with Supplies'.
Solution:

You don't need to create custom report type! Delete it if you already created one.
What you need is to check Enable Reports checkbox on Battle Station custom object - this generates standard report types for us ;)

User-added image

@Georgina Rotenberg
Please try to set 'Supplies' as a report name and let me know if it works ;)
Georgina RotenbergGeorgina Rotenberg
Thanks but I never created a custom report type.  I selected the Battle Stations with Supplies from the standard report types as you described.  I have named my report as "Supplies" as well.  Neither works.  I tried recreating the master detail field in case the relationship was not set up properly.  I've tried using different browsers as well.  Also - I tried renaming the plural of Battle Stations to be Battle Station since the error is that you should have the report type of "Battle Station (no S) with Supplies.  I have no luck getting the trailhead to verify which is frustrating since I know how to create reports and dashboards, I just want to complete the badge!  I've tried following all of the solutions listed above, naming and renaming fields multiple times but so far I cannot get it to verify. Thanks, Gina
Georgina RotenbergGeorgina Rotenberg
Also - why does your code reference 'Battled Station with Supplies' when the error message never has a "D" at the end?  Is there something in the validation rule that is being used that doesn't match?
Norbert WieruszewskiNorbert Wieruszewski

Ah, no! That "d" at the and is just a missclick ;)

Can you show us here how your reports looks like and what message you exactly receive?
Don't worry, I also had problems with this step...

Tobias Bossin 19Tobias Bossin 19
I have the same issues. The objects are named correctly and the report does too. But I get the same errer-message. I tried the whole module in a new instance and finally I get the same error-message. A little bit frustrating ;)
Norbert WieruszewskiNorbert Wieruszewski

Let's try one more time with this.

Here are screenshots of my report Supplies Report. Check it and compare to your reports.

User-added image

User-added image

Claudio Bruno 8Claudio Bruno 8
Hi Norbert,
I have this error: "Challenge Not yet complete... here's what's wrong:
Please check that your report includes at least all of these columns: Supply: Supply Name, Unit Cost, Quantity and Total Cost.", but I don't figure out the error.

User-added image

User-added image
Thanks in advance.
Regards,
Claudio
Norbert WieruszewskiNorbert Wieruszewski

Hey Claudio,

Can you show me custom fields of your Supply custom Object?

User-added image

Claudio Bruno 8Claudio Bruno 8
Hi Norbert,
I show you custom field of my Supply custom object:

User-added image
Thanks for your support.
Regards,
Claudio
Norbert WieruszewskiNorbert Wieruszewski
Please try to change "_" to " " (space) character in Total_Cost label.
Claudio Bruno 8Claudio Bruno 8
Hi Norbert,
I solved the error following your advice.
Thank you very much.

Have a nice day,
Claudio
Norbert WieruszewskiNorbert Wieruszewski
Good job Claudio ;)
Tobias Bossin 19Tobias Bossin 19

I#ve done already read above but I still have the error-message. I despair slowly.Attached screenshots of my settings...

 

User-added imageUser-added imageUser-added imageUser-added imageUser-added image

 

If you see the error, please tell me ;)

Norbert WieruszewskiNorbert Wieruszewski

Hey Tobias,

Try to change NAME field labels on your custom objects:

On Supply Object: Supplies-Name -> Supply Name
On Battle Station Object: Battle Station-Name -> Battle Station Name​

Tobias Bossin 19Tobias Bossin 19
I did but I get the same error message

User-added image

 
Norbert WieruszewskiNorbert Wieruszewski

Well, I have 3 more ideas (just 3 : /):

  1. Please go to Setup -> Report Types and check if you did not create custom report type with name Battle Stations with Supplies. Maybe you created something like this and you've used this in your report insted of standard report?
  2. Check if you don't have any another reports with name starting with Supplies.
  3. I heard about something like "reports cache". When you delete report it is not really deleted until cache clearing.
Nedko NedkovNedko Nedkov
REGARDING:
Challenge Not yet complete... here's what's wrong: 
The 'Supplies' report was not the correct report type. It needs to be using the type 'Battle Station with Supplies'.


I've tried all the different suggestions and still have this issue. I made the challenge on 2 two more freshly made playgrounds and still got to this issue.

The thing that I noticed is when you change the plural name for object "Battle Station" changes in the report type name. I don't know if ths might be cousing some issues. 

If someone finds the solution will be great...

Some screenshots:
User-added image
User-added image
User-added image
User-added image

 
Norbert WieruszewskiNorbert Wieruszewski
Plural label should be: Battle Stations
Tobias Bossin 19Tobias Bossin 19

Hi Norbert,

I tried all of your tipps above but nothing helped. Maybe I need direct help from a salesforce specialist for trailhead?

Or do you have any other idea?

Norbert WieruszewskiNorbert Wieruszewski

Tobias,

I have no more ideas : /

Ch. Szandor KnappCh. Szandor Knapp

Hello Tobias, 

as per your screenshot you might need to check your Organisation's language settings. Or rather make sure you start with an all English (English Org language / english user settings) for trailhead in general. You can achieve that by registering for a new Dev Org and selecting UK or US as the signup country. You wont be able to opt out from marketing emails but the orgs will be created in plain english. 

You seem to have used an English End User with a Org Language set to German. Your screenshot shows 'Gender' which does not appear in an all english org: 

create new object
 

Since Org language determines how different things are named upon creation, this might be why the trailhead breaks for you. 

Patrick GrundyPatrick Grundy
Tobias-
Change your Supply object -- object name for the API from "Supplies" to "Supply"
I had the exact same problem and fixed it doing that
Patrick GrundyPatrick Grundy
User-added image
Tobias Bossin 19Tobias Bossin 19
Hi everyone,

my problem is now solved.
I did following:
- Created a new playground and changed the organisation language to english (united states)
- I did the whole module again from the beginning but from now it has been revised in trailhead, now the whole module is based on lightning and not on classic

And now all worked fine.


Thanks to all the help and support
Sai Kumar 449Sai Kumar 449
Hi Guys Even i Face the Same SItuation for this from the Past Two Weeks am not able to Figure it out , what to do evevn i mailed to the Jeff Dogulas he was evUser-added imageen not Solving nor Helped in this Situation 
Vijay_sfnerdVijay_sfnerd
I too faced this issue. This can be corrected by Checking "Total Cost" field name in Supply custom object. There is an extra space between "Total" and "Cost". Removed it and it worked like a charm.
Kathryn ChlostaKathryn Chlosta
I have gone through all of the tips on this thread and still hit the error message "Challenge Not yet complete... here's what's wrong: 
Please check that your report includes at least all of these columns: 'Supply: Supply Name', 'Unit Cost', 'Quantity' and 'Total Cost'." After I first hit the error message, I deleted the report, but I realize now that I may have not entirely deleted the report. What are the steps to totally delete a report in Lightening Experience? Thanks in advance.
 
Marshall PriestMarshall Priest
I also have tried every solution suggested here and still get the message about the report not including the correct columns. Not sure how to proceed from here. Any suggestions? Thanks
Elizabeth Gilbert 17Elizabeth Gilbert 17
Not sure if this helps, but a problem I had was that I was dropping the items in the "grouping section" and  couldn't understand why it was not creating columns. If I hovered right next to the "Battle Station: Battle Station Name"  I would get a red X, it did not allow me to just add a column to the right. When I just dropped the items right on top of "Battle Station: Battle Station Name" It would finally create the columns,. and I could drag them into the order I wanted left to right. Also, after corrections are made, it has to be saved again before you run the reports, or it will just re-run them from the last save, not the edits. 
Aarthi RajendrenAarthi Rajendren
check the space inbetween supply name
Aarthi RajendrenAarthi Rajendren
The 'Battle Station Supplies' report was not correct report type. Id needs to be using the type 'Battled Station with Supplies'.
ans:check the spelling for supply custom object api
veluri  venkateshveluri venkatesh
Hi, Just remove Extra space from Record name (Supply Name) in Supply Custom Object
User-added image
FabienneIshimweFabienneIshimwe
Just removed the space too in Supply Name and it worked like Magic
bhargav patel 10bhargav patel 10
IN CASE OF ERROR: The 'Supplies' report was not the correct report type. It needs to be using the type 'Battle Station with Supplies'
In case of ERROR: The 'Supplies' report was not the correct report type. It needs to be using the type 'Battle Station with Supplies'
use object name as Supply instead of Supples and that was worked for me.
Loic TRONETLoic TRONET
My problem was on record Name, I add to change Supplies Name by Supply Name
Shaumit KumarShaumit Kumar
Hi Everyone, I have read all the answers and suggestions and I did try some of those suggestions. I would like to inform all the new users/aspirants to try Battle Station Module of creating reports and dashboards in Incognito Mode of your respective browser and log out of your org in the browser you were earlier doing this trailhead. It worked for me beautifully and I completed my trailhead in 20 mins of facing this problem.
naser shaikh 2naser shaikh 2
Supply: Supply Name,Unit Cost,,Quantity,Total Cost use this correct format
melobabu bmelobabu b
I think you have set the object name as "Supplies". Please try to set it as "Supply".

Reference:

https://trailhead.salesforce.com/content/learn/projects/workshop-battle-station/battle-station-2