+ Start a Discussion
Dennis J SDennis J S 

Issue with field update in lead

In my salesforce org, whenever a lead is saved with LeadSource value as "Automation In Action", it automatically changes the LeadSource to "AE Generated" after about 30 minutes. I can't find from where it is getting changed. I checked the workflows, process and triggers except those in the managed packages. Is there any way to find from where the field update is getting triggered?

Thanks
jyothsna reddy 5jyothsna reddy 5
Hi Dennis,

Please check if there any Schedule Job  running on the Lead object and  also deactivate Triggers on it.

Regards,
Jyothsna D
 
Gyanender SinghGyanender Singh
Hi Dennis,
As per jyothsna suggestion check if there is any shedule job and apex job and also check in the debug log because in the debug log you can find sure that what's going on in the opportunity and before this please deactivate all the triggers,workflow rule, process builder on the opportunity and check the debug log imediately after that action is going on the place like when value of the leadsource change.

Thanks
Gyani
http://www.mirketa.com
SYED MOOSA NAZIR T NSYED MOOSA NAZIR T N

Hi,

Check Visual Flows as well. Flow would have triggerd from process builder or trigger to update the LeadSource.
And also check the scheduled Classes.
If Visual Flows and scheduled class doesn't have impact then See who has modified the record after 30 minutes. For that user, keep a debug log. And the replicate your scenario and wait for 30 mins. And the check the debug log and find out the cause for it.

Please let me know if this will help you.
Thanks
Syed Moosa Nazir TN
smartmoosa@gmail.com