+ Start a Discussion
JO_DevJO_Dev 

Salesforce Data Loader OAUTH Blank Screen

When using the Salesforce Data Loader and trying to login with the oauth option. I get a blank screen. Why is that?

User-added image

 
Vasani ParthVasani Parth
Is there any error message you are getting? Apart from this you could also check Proxy setting and see whether you are using any of it. Server host URL depends on whether you are using sandbox or production.for eg if you are using sandbox:- it should be https://test.salesforce.com/ 
for production/developers edition it can be what you have suggested. https://login.salesforce.com

Please mark this as the best answer if this helps

 
Sell Your ForceSell Your Force
Before you click on Login In button, please select the environment - Production or Sanbox and then it should be fine.

Regaards,
Vishal
Prasanth M AbrahamPrasanth M Abraham
Hi 
Vishal (Sell Your Force) is right; once you select the environment on the dropdown just above the login button, the page should load correctly with the user name and password pages. 

Also if you are using an SSO, use the Custom Domain link on the page and populate the login url (note: check the url generated below on screen to ensure that a valid url is generated)

Thanks
Jonathan JamesJonathan James
I'm having the same issue with both production and sandbox OAUTH. After logging in and clicking 'Allow,' Data Loader prompts to download a file called 'success.' Whether you download the file or click 'Cancel' the login window goes white and hangs. The process does not continue after any amount of waiting, and the login is never verified, so you can't use the application.
Jonathan JamesJonathan James
FYI, just updated my Java version (1.8) and updated to the latest Data Loader (39.0.0). 
Jonathan JamesJonathan James
Data Loader Authorization Hanging White Screen
Sacha VilleneuveSacha Villeneuve
Hi get the same issue as Jonathan. Seems to be a new issue with Data Loader and Mac.
Samantha Bell 3Samantha Bell 3
I am experiencing the same issue as Jonathan. Just updated from 37.0.0 (where the error was occurring) and now on 39.0.0 and still having the same issue. 
Beto Carvalho 11Beto Carvalho 11
It would be nice if people read the issue before answering.
  • This is happening for me with Data Loader (mac) 39.0.0, and Java 8 Update 121 (8u121).
  • OAUTH - meaning, you don't have to enter login link, only choose 'production' or 'sandbox'
  • Enter credentials
  • Click "Allow"
  • It prompts me to save a file named "success", I hit "Save"
Get just the blank screen. I've tried deleting Data Loader, and re-installing it. No luck so far.
Beto Carvalho 11Beto Carvalho 11
I had to switch to using Password login (with Security Token), instead of OAuth login.

This worked and will have to be the method until someone figures out what is going on.
Stephanie EbertStephanie Ebert
Same as Jonathan here.  Getting this same error when it was working fine last week.  
Matt RushMatt Rush
Experiencing the same problem as Jonathan with my org, and I know another admin experiencing it too. Worked fine last week, but having troubles this week.