+ Start a Discussion
Sammy7Sammy7 

Insufficient privelages as sys admin

I am creating a VF page in my developer org and getting insufficient privelages page when acessing the related list  below on account even though I am the account owner....
<apex:page standardcontroller="Account">
         <apex:detail relatedList="true">
         <apex:relatedList List="Contacts"/>
         </apex:detail>         
</apex:page>
Best Answer chosen by Sammy7
Prateek Singh SengarPrateek Singh Sengar
Hi Simran,
Are you passing Id to the page, your url should look like
https://Salesforce_instance/apex/Your_Page?id=001D000000IRt53

Also please confirm if you are using a standard system admin profile or a custom system admin profile.

Another thing worth checking is the permission on vf page.
  • Go to Visualforce page in setup.
  • Next to your visualforce page name there would be a link called security
  • Click on that link and ensure that your profile is added in enabled profile section

All Answers

Prateek Singh SengarPrateek Singh Sengar
Hi Simran,
Are you passing Id to the page, your url should look like
https://Salesforce_instance/apex/Your_Page?id=001D000000IRt53

Also please confirm if you are using a standard system admin profile or a custom system admin profile.

Another thing worth checking is the permission on vf page.
  • Go to Visualforce page in setup.
  • Next to your visualforce page name there would be a link called security
  • Click on that link and ensure that your profile is added in enabled profile section
This was selected as the best answer
Sammy7Sammy7
Yes, I'm passing the id as above and on that account id, I am the owner and yes, Im using the standard system admin profile: 
See below: 
User-added image

User-added image
 
Sammy7Sammy7
Nevermind, I forgot the "id" syntax   :-/
Prateek Singh SengarPrateek Singh Sengar
Simar, Please mark the topic as solved to help the contributors.