+ Start a Discussion
saran kumar 9saran kumar 9 

Help Me - Create a Self-Registration Page

I did exactly what was told in the trail yet i am unable to find the custom link( not a member?) in the login page .....check the images and help me ..stuck here for last two days User-added imageUser-added image
Jim BahanJim Bahan
I've got the same problem.  Did you figure it out yet?
Sankeerth ReddySankeerth Reddy
Hi Jim, I got the same problem. But, I got a 'Sign Up' option below the 'Log In' button. So, I created a new user which helped me pass the trailhead challenge
Ryan DRyan D
So frustrating.  It worked for the Customer community, but NOT the partner community.  I wonder if it would work if you only have 1 community in your dev org instead of 2.  I clicked the 'sign up' link since I also did not get the 'not yet a member' link in the Partner community.  I got the nice sign up page and tried with 'Simon Tram' but I got the error 'Your request cannot be processed at this time. The site administrator has been alerted.'  I was not alerted...
Ryan DRyan D
Ok, I got the 'not yet a member' link to show up.  Under the Login section choose Community Builder Page, and choose the 'login' page.  BUT I still can't create Simon Tram as a Partner!  Same error.
Mars Rover 735Mars Rover 735
I can't create Simon Tram as a user either. I keep getting "Your request cannot be processed at this time" I followed the same steps used for Customers and everything worked fine for that one.
Mars Rover 735Mars Rover 735
Try a different DE. I had to use one of my other DEs and set up Partners Community to get this to work.
Ryan DRyan D
Thanks Mars Rover!  I suspected it might have something to do with having 2 identity communities running in the same org.  At first the Customers community worked, then it stopped working after I tried to add the Partners community.  Spinning up the Partners community in a fresh playground did the trick!  Just gotta follow all the steps :)
Rob SherwoodRob Sherwood
Go to your new Partners Community > Administration > Login & Registration > Change Login page from 'Default' to 'Community Builder Page'  and choose 'Login' from the drop down. Then proceed to do the Self Registration steps in the tutorial challenge. Annoyingly, this step is easily forgotten as it's from the tutorial before. Doing this will mean you can have self registration in multiple communities in the same org, whether dev or production.
Ranil Goonesekera 5Ranil Goonesekera 5
When you know you have done everything right and it is not working, start a new Trailhead Playground and work your way.  This gives us additional practice plus, I think Salesforce throws a curve ball from time-to-time to see if we can figureout when it is not straight forward.
Jeevan Pratheek DaraJeevan Pratheek Dara
Try to give a different email while Self Registration. Intially I got this message ('Your request cannot be processed at this time. The site administrator has been alerted'). But after trying various methods for few hours, changing email while self registration worked for me.
Lachlan Stott 18Lachlan Stott 18
What Jeevan said! It says to use your email, but it should say 'use your email, but make sure it's not the same one that was used for your internal user'
Sai chand Bitra 8Sai chand Bitra 8
Hi guys, Any luck on this. I am facing the same issue following these steps.
Atla Satheesh 8Atla Satheesh 8
Hi Guys,

I have successfully completed this badge. Please use new Dev org/New Trail head org and follow teh same stets which was mentioned in the Trail Head.
You can use same emial Id. Make sure use profile on Login & Registartaion page. 
Try with incognito window and sign up for teh new partner user
You will receive the Link. Now create the password and login into the org then check tthe badge.

Cheers!!
Sai chand Bitra 8Sai chand Bitra 8
Thanks Satheesh this resolved the issue
DamianSummersallDamianSummersall
Lachlan's suggestion fixed the issue for me! I just used a different email!