+ Start a Discussion
Praneetha MurakondaPraneetha Murakonda 

ActionId specified was invalid for ActionType QuickAction.

Hi All,

I'm deploying Account and Contact layouts to production using Eclipse Ide. While validating i'm facing issue like  "ActionId specified was invalid for ActionType QuickAction". Please let me know how to resolve the issue.

Thanks
R Z KhanR Z Khan
Were you able to resolve this? I am having the same issue
Lyndsay NeerLyndsay Neer
We were working in a developer org installing a managed packaged and received the same error. We discovered it was because we had the post and file actions on the layouts and didn't have chatter enabled. Once it was enabled problem fixed. 
Emily Morse 15Emily Morse 15
Hello; we weren't able to resolve the issue until we enabled Notes in Production.
SForceBeWithYouSForceBeWithYou
The offender for me was FeedItem.AnnouncementPost, which seems to have been deprecated: https://developer.salesforce.com/docs/atlas.en-us.api.meta/api/sforce_api_objects_feeditem.htm (under field Type).  I didn't see it anyway... removing it got me deploying successfully.  Found this on CollaborationGroup layout.
Dharmil ShahDharmil Shah
Hi Praneetha,
Enable chatter in the org you are trying to deploy to and then try deploying. i.e. Enable chatter in the destination org.
Annette Abell 6Annette Abell 6
Thank you for this post and your answer (NOTES needing to be enabled was the answer for me too!)
NevDevNevDev
After a lot of frustration I finally found the culprit. I had to remove the Chatter component from the page layout in a Sandbox environment and then it worked. 
I would have thought that this would be a basic feature that would have worked in a managed package but it's obviously not. 

User-added image
Ritesh Mohapatra 4Ritesh Mohapatra 4
It worked for me when i followed this 
1. Enable Note Settings and Chatter Settings in both Source and Target Environments. 
Kai TribbleKai Tribble
Thanks to @SForceBeWithYou for providing the answer that helped me here. Even in SFDX, the FeedItem.AnnouncementPost action item is automatically loaded onto the Collaboration Layout.
SForceBeWithYouSForceBeWithYou

I ran into this for another situation similar to @Lyndsay Neer above... adding this to the scratch org def json fixed it

"settings": {
    "orgPreferenceSettings": {
        "chatterEnabled"  : true
     }
}
 

Hope that helps!

GunwantGunwant
I enabled chatter and notes, still getting the same error when I am trying to install unmanged package. Is there any help for me?
Dorothy Elaine Mangubat 8Dorothy Elaine Mangubat 8
Hi All, just set target org's email deliverability to All Emails. I logged a case with salesforce and they documented it here: https://help.salesforce.com/articleView?id=000351699&type=1&mode=1
Marc SofiaMarc Sofia
Hello All. Just to echo that I found today the culprit in my case was an org that did not have Notes enabled and a package that included Notes related lists on page layouts. Solution: enable Notes in target org (a sandbox, in this case). (Chatter was already enabled in the target org.)
Ritesh Mohapatra 4Ritesh Mohapatra 4
You will need to enable Chatter in your Salesforce organization. To do that, go to Setup | Feature Settings | Chatter | Chatter Settings. Enable Chatter Settings and Actions in the Publisher.
Stephanie Grau 10Stephanie Grau 10
Hello everyone,
after trying all possibilities mentioned above finally it worked by taking the Email Action from the page layout. Maybe this is also useful somehow.
Greetings,
Stef