+ Start a Discussion
Todd KadasTodd Kadas 

cannot validate set-up two factor authentication challenge

Continue to receive the following error message "Could not find a Permission Set named 'Trailhead' that has the 'Two-Factor Authentication for User Interface Logins' permission enabled.".  I have created the following: new developer edition, new user,  and new permission set with required 'Two Factor Authentication for User Interface Logins' ticked.  I then assigned the permission set to the new user, logged out, logged back in as the new user and was successfully able to log in using 2FA.  I am logged in to the same developer edition that I used to create user and set.
Vivek DVivek D
You have to add 2FA to your user detail. The same user you are logged in. 
Todd Kadas 9Todd Kadas 9
Thanks! I found that changing the API name to Trailhead did the trick.  Appreciate your response!
Anthony Torrero CollinsAnthony Torrero Collins
I had the same issue. Please update the Trailhead content. Thanks!
Pam LukePam Luke
I have set up a new developer log in and also set up a permission with Trailhead. This isn't working. Vivek, when you say add 2FA to user detail, do you mean in the "new user's" ID name? Frustrated. Ready to move on.
 
Guy_KeshetGuy_Keshet
same here, tried chaning API name, tried using another org and no luck. I can test as the named user and the mobile app requires two factor authentication, however the valdiation is still failing ...
Rodolfo Rodriguez 8Rodolfo Rodriguez 8
I was having the same error. After I set up the 2FA and assigned the permission set to the user, then loged out of the DE org, and Logged back in as the user to setup the 2FA the first time, I needed to log BACK out and log in again as the user and actually use the 2FA that was already setup. Then the validation worked.
M.C. De LeonM.C. De Leon
I even logged in with a user, passed the 2 factor validation and then when redirected to the trailhead page ... nothing at all.
M.C. De LeonM.C. De Leon
After two days I could finally make it, if it helps anybody, my problem was that the permisson set licence must be Salesforce platform and the user you use to login must have that licence.
Juan An MunozJuan An Munoz
Using the playground, the main defined user must have assigned the permission set. I've lost a lot of time trying to assing the permission set to a new created user.
Madhurima Bhattacharjee 6Madhurima Bhattacharjee 6
I was getting the same issue and after a day i finally was able to complete this. What i did was on Session Settings deselect "Allow location-based automated verifications with Salesforce Authenticator". Then relogin with the user which is attached to the Trailhead permission set. It would work! Hope this helps.
james chan 17james chan 17
When you create the new permission set, make sure you choose "Salesforce Platform" in License type, if you have selected your user as a saleforce platform user.
create new permission set