+ Start a Discussion
Justin Kitagawa 11Justin Kitagawa 11 

Record Lookup not working in Flow

I have a flow that is used for lead assignment that uses other, existing leads as the basis for assignment. As such, there is a Record Lookup that finds another lead with the same website and grabs the LeadOwnerID. However, for some reason it keeps failing and saying that there are no leads found, even though there are definitely leads that meet that criteria. 

The issue only happens intermittently, and I cannot figure out why. 

RECORD QUERY: Find_Existing_Owner
Find one Lead record where:
OwnerId Does not equal 005d0000005BQ42
Website Equals {!WebsiteFormatter} (juniper.net)
Id Does not equal {!thisLead.Id} (00Qd000000nSdjcEAC)
Result
Failed to find record.

Has anybody had an issue like this? I tried contacting support but they said that they did not have expertise in Flows... 

AmandaByrnePBOAmandaByrnePBO
I'm experiencing this as well- I've tried using both a fast lookup and a Record Lookup- both fail to find record. But I can write a SOQL in workbench with the same parameters and find the record.

The lookup is for Campaign Members in a specific campaign- and there are only 26 members, so the size of the search shouldnt be an issue, unless there's just an ungodly amount of campaign members to even reduce to the ones in that campaign.