+ Start a Discussion
Raja Bipin Chandra  M BRaja Bipin Chandra M B 

Remove x-panel border on Visualforce page (CSS)

Hello Guru's,

I have a weird problem, I don't have any specific script in VF however, if i use  the below code and try to print i have a 'blue' border line coming along.My need is to get over it.
 
<apex:page sidebar="false" showHeader="false" >
 
  <h1>Congratulations</h1>
  This is your new Page

</apex:page>
I also tried debugging using the chome developer mode, i could see that following class are setting border in 'blue; colors.I tried to over-ride the class in my <Style> tag but did not work. Please help! 

Chrome Developer mode

Thanks,
Raja Bipin Chandra
Best Answer chosen by Raja Bipin Chandra M B
Raja Bipin Chandra  M BRaja Bipin Chandra M B
Dear Boni,

Thanks for your help, it was a silly mistake. I was trying to print with editor mode enabled. After disabling it the border was gone.

Thanks,
Raja

All Answers

Raja Bipin Chandra  M BRaja Bipin Chandra M B
When i am printing, i am getting like this.Please help

User-added image

Regards,
Raja
☯ BonY ☯☯ BonY ☯
Hi Raja,

Try this 
<apex:page sidebar="false" showHeader="false" >
 <style>
.x-panel-body-noheader, .x-panel-body{
	border:0px !important;
}
</style>
  <h1>Congratulations</h1>
  This is your new Page

</apex:page>

If you have any question let me know,

Thanks,
boni
Raja Bipin Chandra  M BRaja Bipin Chandra M B
Hi Boni Boss,

Thanks for your respone.I tried the  code, it did not work. However, there is one thing i noticed... When i am printing, if i select the Margins as "None" these borders will disappear. I want to restrict this feauture within script and doesnt want users always to set Margins as None.Please help

Thanks

User-added image
Raja Bipin Chandra  M BRaja Bipin Chandra M B
Dear Boni,

Thanks for your help, it was a silly mistake. I was trying to print with editor mode enabled. After disabling it the border was gone.

Thanks,
Raja
This was selected as the best answer