+ Start a Discussion
Mark Smith 64Mark Smith 64 

Superbadge: Security Specialist - Step 1

Hi Forum,
This is a bit of an embarrsement. Having read through the superbadge requirements and spending most of Sunday configuring and re-configuring User profiles, I havent passed this check.
 
The Inside Sales User does not appear to have the correct object permissions for Accounts and Opportunities

What's strange is that I was stuck on "field sales user" and now I'm stuck at "Inside Sales User".

I believe the OWD's are fine as well as the Object Permissions as well as the Profile setup. I was wondering if there would be a way to verify the error.  In the meantime I will continue to persist.

Regards
Mark
 
Best Answer chosen by Mark Smith 64
global4gglobal4g
I just made the first step.  
for the benefit of others, in order to make that, record level sharing is not required.

Appears that only Profile Names & Account+ Opp object permissions need to be  set up and correctly

@Mark :  Per the notes, "All new accounts are created by inside sales people."  so this profile needs more access than what you mentioned above, yet they are not admins!

 

All Answers

Ajay Anikar H RAjay Anikar H R
Hi Mark,

I had to travel the same couple of days back before completing the superbadge.
Do you have the ViewAll on Account Object for profile - Inside Sales User checked ?

Thanks
Mark Smith 64Mark Smith 64
Hi Ajay,

yes. Have R/C and View All on Account. Have switched various options for Opportunity. (Although No direct reference to Inside Sales and Opportunities)
 
Ajay Anikar H RAjay Anikar H R
Hi Mark,
For Inside Sales Profile - View All on Account is what which could be causing the error.
Uncheck and hope that helps.
Kindly review the requirement as well which would justify this setup
Mark Smith 64Mark Smith 64
Hi Ajay,
Confirmed "View All" is off (I think I had tried this off as well) and same result...

"The Inside Sales User does not appear to have the correct object permissions for Accounts and Opportunities"

Just to confirm: Inside Sales User:  R/C on Account.  Nothing for Opportunity.

Will keep trying but any further pointers from the community would be great.

Regards
Mark
global4gglobal4g
I just made the first step.  
for the benefit of others, in order to make that, record level sharing is not required.

Appears that only Profile Names & Account+ Opp object permissions need to be  set up and correctly

@Mark :  Per the notes, "All new accounts are created by inside sales people."  so this profile needs more access than what you mentioned above, yet they are not admins!

 
This was selected as the best answer
Mark Smith 64Mark Smith 64
Hi Global4g,
"Inside Sales User" Profile was cloned from "Standard User" Profile. As per requirements: They need Create Access on the Account object. Although no specific mention of managing / maintaining the Opportunity Object...  Through trial and error, I have now moved past the error...  So that's good news and thanks very much for your help, but I do need to review this scenario again and whether there is some "interpretation" needed...  Kind Regards!
Bill Powell - CSS IncBill Powell - CSS Inc

Pretty much have given up on this super badge. Through hours of trial & error, can't get past part 2. 

User-added image

Tried creating sharing rules for field sales to share with inside sales, tried creating a public group and adding those profiles, etc. Ran the apex test executions with other trial and error ideas.  Nada.  Any suggestions? 

GanchoGancho
Hi @Bill Powell - Css Inc,
Please try sharing with role:
Owner in Role and Subordinates: Sales Executive
Role: Inside Sales
Read/Write
Darrell GallegosDarrell Gallegos
What are the instructions referring to regarding Mobile access, granted by the admin on demand? I completed the challenge but I made no changes to this and do not have any idea of what this is referring to. I cannot find a setting or documentation regarding this.

Any ideas?
Frank Mamone 19Frank Mamone 19
@Darrel : https://developer.salesforce.com/docs/atlas.en-us.salesforce1.meta/salesforce1/setup_s1_intro_define_users.htm
Frank Mamone 19Frank Mamone 19

Hi,

I'm getting the same error but for the Sales Executive. I set Accounts and Opportunities to Read-Only.  Perhaps Account is not needed since I set it to Public Read-Only on OWD??
 

Derhyk Doggett -Derhyk Doggett -
For others that get this error, it is likely that you have used 'View All' on Accounts or Opportunities in the Profile settings.
I misread the requirements and when they mentioned to not use View All, I thought they were referring to the System Permission View All Data.

The solution is to remove all the View All Object permissions from the Profile if you have them, and create the neccessary sharing rules to share with the Roles that require access to all records.

Hope that helps.

​--Derhyk
Lenore MLenore M
I'm trying to complete the Security Specialist superbadge. Getting stuck on Step 1: Error message: The Sales Executive User does not appear to have the correct object permissions for Accounts and Opportunities. 

I've done the following: 
1. In the profile, Read the only access selected for both accounts and opportunities
2. I created several sharing roles for both accounts and opportunities.  
Any ideas what I am missing? 
Tracy GarzaTracy Garza
Lenore, did you select "View All" for accounts and opportunities? 
Gary SalvadorGary Salvador
Sales Executive (and only Sales Executive) needs View All selected in object permissions for both Accounts and Opportunities with Read as the only other permission selected for that profile
Lucas Marquez Morato Fedrigo 5Lucas Marquez Morato Fedrigo 5
Hello everybody,

Sorry for this very basic question, but which user profile do you guys use to start the 3 custom profile we need to create?

screen shot profiles

Thanks for your help!

Lucas
Ruchika BishtRuchika Bisht
Hi Lucas , 
I have system administrator profile  as Existing profile and created all three new profiles. Followed steps mentioned in the requirement and removed unnecessary permissions from the new profile. I am able to clear the step 1 :).
ShabneezShabneez
Hello Lucas, 
I have used the Custom:Sales profile (which was on the trailhead playground) as Existing profile and it also worked for me. 
Winny SilvaWinny Silva

Someone to help with this challenge? I'm breaking my head and I do not see any solutions.
Satish InugantiSatish Inuganti
Hi Ruchika,

Sys Admin is under Salesforce Licensce and how do you managed to assign for 3 different profiles? Any tips please?? Because currently in Trailhead Playground it is allowing only 2 Salesforce Licences (One Sys Admin is Already Occupied). i'm not getting profiles and licences could be used to cross this STEP1.

Please help __/\__
SankushaSankusha
Hi ,

If someone is still stuck with Challenge 1 please try these steps as i have passed challenge 1
1.Use Standard User as existing profile.
2.For Field Sales User profile make sure you have selected 'Read' and 'Edit' for Accounts and  'Read ' 'Create' and 'Edit' for Opportunities.
3.For Inside Sales User make sure you have selected 'Read ' 'Create' and 'Edit' for both Accounts and Opportunity and also set The Login hours as per the requirements (I have not set any IP range still i could clear the challenge).
4.For Sales Executive User make sure you have selected 'Read' and 'ViewAll' for both Account and Opportunity.
Divya KannayagariDivya Kannayagari
Hi @Satish Inuganti,
Follow All the steps 
Firstly you should be clear that you should create Profiles not users ...
Quick Box----> Profile ----> New ------> Select any profile from dropdown Ex;- custom:support /sales user ------>Field Sales User....then follow below steps...Try to complete 3 profiles...you will clear the challenge
1.For Field Sales User profile make sure you have selected 'Read' and 'Edit' for Accounts and  'Read ' 'Create' and 'Edit' for Opportunities.1
2.For Inside Sales User make sure you have selected 'Read ' 'Create' and 'Edit' for both Accounts and Opportunity and also set The Login hours as per the requirements (I have not set any IP range still i could clear the challenge).
3.For Sales Executive User make sure you have selected 'Read' and 'ViewAll' for both Account and Opportunity.