+ Start a Discussion
EmilienGuichardEmilienGuichard 

Security Specialist superbadge - Set up reporting error

Hi,

I'm trying to validate step 5 for the Security Specialist superbadge "Set up reporting error" and I'm geeting the following error :

Challenge Not yet complete... here's what's wrong:
The Field Sales User profile does not appear to have the correct permission for create and customize reports.

I don't understand what's wrong cause I've check all reports permissions on the Field Sales User profile.

Could you please advice ?

Thanks.
Best Answer chosen by EmilienGuichard
Henk WalgemoedHenk Walgemoed
Create and Customize Reports - off
Create Report Folders - off
Edit My Reports - off
Export Reports - off
Manage All Private Reports and Dashboards - off
Manage Custom Report Types - off
Manage Reports in Public Folders - off
Report Builder - off
Run Reports - on
Schedule Reports - off
View Reports in Public Folders - off

Hope it helps

All Answers

Henk WalgemoedHenk Walgemoed
Yeah, this seems to be a bit of a bug. With me it worked when I unchecked the 'Create and Customize Dashboards' setting in the Field Sales User's profile (I know it doesn't make sense but I was trying everything)
EmilienGuichardEmilienGuichard
Hi Henk,

I have already tried with this permission unchecked but still the same error message.

Here is the list of check reports and dashboard permissions on the Field Sales User profile :
Create and Customize Reports
Create Report Folders
Edit My Reports
Export Reports
Manage All Private Reports and Dashboards
Manage Custom Report Types
Manage Reports in Public Folders
Report Builder
Run Reports
Schedule Reports
View Reports in Public Folders

Could you please compare with what you have ?

Thanks a lot.
Henk WalgemoedHenk Walgemoed
Create and Customize Reports - off
Create Report Folders - off
Edit My Reports - off
Export Reports - off
Manage All Private Reports and Dashboards - off
Manage Custom Report Types - off
Manage Reports in Public Folders - off
Report Builder - off
Run Reports - on
Schedule Reports - off
View Reports in Public Folders - off

Hope it helps
This was selected as the best answer
EmilienGuichardEmilienGuichard
ok finally got it, it is required to pay a special attention to the permission "Create and Customize Reports"
only the inside sales user needs it.

Thanks a lot.
Rajesh BhoirRajesh Bhoir
For Step 5-I am trying to set the Permissions for Reports and Dashboards but the very first step I am getting stuck is I am  not able to locate the “Folder Sharing ” options .I searched through Quick Find box , looked through various options but still I am not able to locate the enhanced folder sharing option.. As per the guidelines if my Org was setup before Summer 13 then I would need to enable analytics folder sharing which is not the case as the Org was setup 6 months back. Not sure which step is missing or what needs to be done. Any help is really appreciated.
 
Thanks,
Rajesh
bhanu pbhanu p
Hello,

i'am getting this error can anyone help me exactly what permissions i have give?
User-added image

and i have given these permissions

User-added image
 
Niran NSNiran NS
Hi Bhanu,

i see that Manage Public List Views is checked in your screen because this violates requirement 2.
Please uncheck it and try ..

Below is the screen shot of permissions which i have used to pass the challenge.

Field Sales User​
1. Field Sales users should be able to create their own list views, 
2. but not create or manage list views for others.
3. They should also be able to create reports and dashboards
4. but not create or manage report and dashboard folders. 

Field Sales User​

User-added image

Sales Executive User​
User-added image
BijaySBijayS
Hi ,
I am facing the below issue while submitting chalenge 5:

There was an unhandled exception. Please reference ID: TRUDYEHH. Error: Faraday::ClientError. Message: INVALID_FIELD: PermissionsEditPublicFilters, PermissionsCreateCustomizeReports ^ ERROR at Row:1:Column:77 No such column 'PermissionsCreateCustomizeReports' on entity 'Profile'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

Anybody got the same and resolved it?

REgards
BW ShreevesBW Shreeves
I'm getting the same error:
User-added image
 
Emmauel KingEmmauel King
User-added image

Hi all,

Is anyone able to help with the above error? 
Marcos Joel Ipanaque MedinaMarcos Joel Ipanaque Medina

Hi everyone,

I have the same problem, is someone can helpme, I'll be very greatful
Error
Sales executive user

Prashant DhangarPrashant Dhangar
Provide the below permissions on profiles

1. Inside Sales User Profile 

Create and Customize Dashboards     - true
Create and Customize List Views     - true
Create and Customize Reports    - true 
Create Dashboard Folders     - true
Manage Public List Views    - true 
Manage Reports in Public Folders     - true
Manage Reports in Public Folders - true

2. Field Sales User Profile
Create and Customize Dashboards     - true
Create and Customize List Views     - true
Create and Customize Reports    - true 
Edit My Report - true 
Manage Public List Views - false

3. Sales Executive User Profile
Create and Customize Dashboards     - true
Create and Customize List Views     - true
Create and Customize Reports    - true 
Manage Public List Views     - false
Manage Reports in Public Folders     - false
Manage Dashboards in Public Folders     - false    
Renan AraújoRenan Araújo

I have the same problem already made several changes and nothing to complete the challenge
User-added imageUser-added imageUser-added image