+ Start a Discussion
Savita VermaSavita Verma 

TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.","errorCode":"UNSUPPORTED_CLIENT

Facing problem "TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.","errorCode":"UNSUPPORTED_CLIENT"

How can i resolve this issue kindly help me
Savita VermaSavita Verma
Hi Amit,

There is no update name "Require TLS 1.1 or higher for HTTPS connections"  in Setup->Build->Critical Updates
Amit VaidyaAmit Vaidya
It shouln't happen. Please check below:

 Snapshot

 
Amit VaidyaAmit Vaidya
Hi Savita,

1) Please Setup->Build->Critical Updates
2) Deactivate the "Require TLS 1.1 or higher for HTTPS connections" updates.

This should help to resolve your issue.

Thanks,
Amit
Daniel BallingerDaniel Ballinger
Have a read of the knowledge article Salesforce disabling TLS 1.0 (https://help.salesforce.com/apex/HTViewSolution?id=000221207#Inboundintegrations). In particular, the ,NET sections under API (Inbound) Integrations.

You will need to switch to a version of .NET that supports TLS 1.1 and 1.2. With .NET 4.5 and 4.5.2 this may require a specific registry key or line of code:System.Net.ServicePointManager.SecurityProtocol = ...

Disabling the critical update will be a short term solution at best. You will just be facing the same problem within a year when all orgs have the critical update enabled.

 
Kennie__cKennie__c
I currently developed a .net app connect to sf via oauthor and its been working fine until this morning and adding the below is working for me

System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls11 | SecurityProtocolType.Tls;
Gerald WangGerald Wang
Hi Kennie

Does it work now? Can you please let me know how to set up:

System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls11 | SecurityProtocolType.Tls;

Many thanks.
Kennie__cKennie__c
There is no setup
In my .net app, I just add the below line of code before I call salesforce to get my oauth tokens

System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls11 | SecurityProtocolType.Tls;
Kennie__cKennie__c
There is no setsup, in your code just add this line of code before you call salesforce  System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls11 | SecurityProtocolType.Tls;
Santiago PerezSantiago Perez
Kannie, running Windows 7 with .Net 4.0. Tried your approach and didn't make a difference. 
Kennie__cKennie__c
Go here  https://help.salesforce.com/apex/HTViewSolution?id=000221207#Inboundintegrations
Look for .net 4.0 you might need to play with the registry setting
Credit go to: Daniel Ballinger
Kennie__cKennie__c
Or update your .net framework to 4.5 , 4.6
Matthew HansenMatthew Hansen

If you are running .net 4.0 and don't want to mess around with the registry, you can still set the SecurityProtocol to TLS 1.2 in code, the value needed just doesn't exist in the SecurityProtocolType enumeration yet, so you have to set the value yourself, like this:

System.Net.ServicePointManager.SecurityProtocol = ( System.Net.SecurityProtocolType ) 3072;

I was getting the exact error as the original poster, but setting the SecurityPortocol as shown above sometime before attempting to login fixed the issue for me.

Ishan MalikIshan Malik

Can you all please provide the one stop solution?

I am using .Net framework 4.5.2
Use TLS 1.0, 1.1, 1.2 is already checked from Internet options -> Advanced
I am not getting any option in critical update section

but still I am getting following error:
UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.

I have an urgent requirement. Please answer asap.
 

Daniel BallingerDaniel Ballinger
Ishan, For .NET 4.5.2 to support TLS 1.2 you need to modify the ServicePointManager.SecurityProtocol to include SecurityProtocolType.Tls12.
Ishan MalikIshan Malik

Hi Daniel

Thanks for answer but can you please explain me what to modify & how to modify.

Daniel BallingerDaniel Ballinger
Ishan, You will need to get a developer to set that property in code, compile it, and deploy to your production instance(s).
Shivesh Pandey 1Shivesh Pandey 1
 System.Net.ServicePointManager.SecurityProtocol = (System.Net.SecurityProtocolType)3072
Write this before initializing your SforceService. For more information look at attached image.
Sample