+ Start a Discussion
amrit bansalamrit bansal 

Isuue in SOAP API

The Issue In requesting SOAP API.Please resolve it

soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:sf="urn:fault.enterprise.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Body>
      <soapenv:Fault>
         <faultcode>sf:UNSUPPORTED_CLIENT</faultcode>
         <faultstring>UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.</faultstring>
         <detail>
            <sf:UnexpectedErrorFault xsi:type="sf:UnexpectedErrorFault">
               <sf:exceptionCode>UNSUPPORTED_CLIENT</sf:exceptionCode>
               <sf:exceptionMessage>TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.</sf:exceptionMessage>
            </sf:UnexpectedErrorFault>
         </detail>
      </soapenv:Fault>
   </soapenv:Body>
</soapenv:Envelope>
Amit Chaudhary 8Amit Chaudhary 8
Please check below post for same issue
1) http://help.salesforce.com/HTViewSolution?id=000232847&language=en_US
2) https://help.salesforce.com/apex/HTViewSolution?urlname=TLS-1-0-Disablement-Critical-Update-Console-CRUC-Setting&language=en_US
3) http://support.picnet.net/entries/107992083-Resolving-error-UNSUPPORTED-CLIENT-TLS-1-0-has-been-disabled-in-this-organization-
4) https://github.com/joeferraro/MavensMate-SublimeText/issues/769


1) Go to Build > Critical Updates
2) Under the Update Name column, look for "Require TLS 1.1 or higher for HTTPS connections"
3) For the row that has "Require TLS 1.1 or higher for HTTPS connections", click the "Deactivate" link
If you want to reactivate this update in the future, just click the "Activate" link.

Let us know if this will help you

Thanks
Amit Chaudhary
Vacha ShahVacha Shah
Hi Amit,

I have the same issue but in my critical updates tab, there is no option to deactivate the 1.1 version.

Can you help me with this?

Thanks
Vacha.
Shamugapriyan SelvamShamugapriyan Selvam
To enable TLS 1.1 or 1.2 in SoapUI,
  • Locate the "soapUI-4.5.2.vmoptions" file in your SoapUI directory. (Drive name:\Program Files (x86)\SmartBear\soapUI-4.5.2\bin)
  • Open the file with notepad, add the following line and save the file. 
-Dsoapui.https.protocols=SSLv3,TLSv1.2
Let me know if this will help you.

Thanks
Shanmugapriyan 
 
Gautam_KasukhelaGautam_Kasukhela
The solution provided above by Shamugapriyan Selvam works perfectly.
@Amrit, if the above resolves your issue, request you to mark Shamugapriyan's answer as the Best Answer.