+ Start a Discussion
Javier Escobar 2Javier Escobar 2 

Home tab is missing

Hi there!

From one day to another, my Home tab has dissapear from all the apps for all the profiles (including System Admin). Does anybody has any idea of what could be happening and how to solve it?

Thanks a lot in advance!
SalesFORCE_enFORCErSalesFORCE_enFORCEr
Strange. Not sure about the reason but you can fix it by adding the Home tab to your apps. Setup>Create>Apps>Edit your app and add the tab
Stuart GreenbergStuart Greenberg
We're having the same problem but only for the System Administrator profile. The solution suggested is not possible since the dialogs won't allow the Home Tab to be removed or change position. 

Any more ideas?
Vigneshwaran GopalVigneshwaran Gopal
I could bring the HOME tab back by simply creating a permission set (with access to the Home tab) and assigning it to the user. No idea about the root cause still. :-)
Richard Hind 13Richard Hind 13
I've encountered this a few times recently and found this knowledge article which solved it for me:

https://help.salesforce.com/apex/HTViewSolution?urlname=Home-Page-Tab-is-Missing-for-Users&language=en_US

The trick seems to be to edit your profile and check the box Overwrite Users Personal tab Customizations to force it to re-evaluate which tabs should be displayed for that profile. The Home page should then appear once more.
Anvesh ThakkallapallyAnvesh Thakkallapally
I have encountered this for System admin profile, the root cause is still unknown. I agree with Richard, instead of creating a permission set(since which should be Default On for system admin profile in my case), follow the below steps which will re-evaluate profile display:
     a) Go to Setup | Manage Users | Profiles
     b) Click on Edit on affected Profile
     c) Go to Tab Settings
     d) Check the box for Overwrite Users Personal tab Customizations
     c) Click on Save.
 
Beto Carvalho 11Beto Carvalho 11
Richard and Anvesh. Worked like a charm. Wow, what a pain.

Some additional notes (in my case). I could not find a way to do this in the Enhanced Profile Editor. Had to:
  1. Navigate to Setup > Customize > User Interface > uncheck Enable Enhanced Profile User Interface
Checking "Overwrite Users Personal tab Customizations" in my cloned System Admin profile worked like a charm. Thank you.
Matthew Hauck 8Matthew Hauck 8
Holy cow! That was an incredible illogical series of steps. Go to Salesforce Classic, restore the 'old way' of looking at Profiles, then use an old check box - all for a lightning UI change. Weird cause and effect I still don't know why it disappeared. For sake of others, I am adding some keywords into this search. Thank you all for giving this solution. I am sure many more will find themselves here in Home missing land. keywords; home component missing in lightning - home tab missing - home missing in lightning app components home component home tab missing
S Singh 33S Singh 33
Thanks, it helped.
Tina Y.T. ChangTina Y.T. Chang
Thank you! It helped a lot!!!
Sarah Martin1Sarah Martin1
I have hit this issue in a sandbox, unfortunately the issue with a sandbox is that you can't get to the setting that disables the enhanced profile editor, this is only available in Production! I don't know what made my page disappear, it was there one minute and gone the next. However, the quick solution to this was to use Anvesh's fix mentioned above, ie create a permission set for the home tab, assign it to myself and then the tab reappeared.
Michael MattiaccioMichael Mattiaccio
We are also having this problem that there is no Home for System Administrators but the recommended fixes and knowledge article have not been helpful. We do not have the option to Disable Enable Enhanced Profile on User Interface so we cannot Overwrite Users Personal tab Customizations. This is a very inconvenient bug. 
Ajay K DubediAjay K Dubedi
Hi Javler,
Home page Tab is not visible for the users. On Profile the Tab permission is set to Default On and on Customize My Tabs option, 'Home tab' is selected.
Steps To check the settings on Customize My Tabs:
1) Login in as User:
       a) Home Page Tab is missing after logging in.
       b) Click the (+) icon to access All Tabs
       c) Click on Customize My Tabs
       d) Home Tab is already part of the Selected Tabs
Steps for System Admin to check the permission on Profile:
1) Click on Setup | Manager User | Profile |
      a) Click on the affected users' Profiles.
      b) On Tabs Permission | Home tab is already set as Default On for the affected users.
 
Resolution   
To resolve issues with Home Page Tab visibility
 
To resolve issues with Home Page Tab visibility
 
In Lightning Experience UI:
1) Click on Setup | Users | User Management Settings |
     a) Disable Enable Enhanced Profile on User Interface.
     b) Click on Save.
 
In Classic UI:
1) Click on Setup | Manage Users | User Management Settings |
     a) Disable Enable Enhanced Profile on User Interface.
     b) Click on Save.
2) Enable Overwrite users personal tab customizations
     a) Go to Setup | Manage Users | Profiles
     b) Click on Edit on affected Profile
     c) Go to Tab Settings
     d) Check the box for Overwrite Users Personal tab Customizations
     c) Click on Save.
I hope you find the above solution helpful. If it does, please mark as Best Answer to help others too.
Thanks,
Ajay Dubedi