+ Start a Discussion
Katie JeanesKatie Jeanes 

Related Contacts "Add Relationship" button missing

Has anyone run into an issue when adding related accounts/contacts to their page layouts? I've added and saved everything but the "add relationship" button that should be to the right of"merge contacts" is not showing up in my training account. Thanks!
RbnRbn
Hi Katie,

Navigate to Account- Account Settings-Need to check the (Allow users to relate a contact to multiple accounts)checkbox.

Now you can go to your Account Page layout - Related Lists - Drag and Drop Related Contacts .

And you would be able to view the Add relationship button.

Do let me know if it solves your question.

Rgrds,
Rabi
Ragava reddyRagava reddy

Hi,

Go to Account settings--> Enable "Allow users to relate a contact to multiple accounts" check box.

Go to Account page layout ---> Related List-->Add Related Contacts ---> Save It.
Now you have to see the add relationship button.

Thanks,
Raghavendra Reddy.D
 

Nathalie Breysse 6Nathalie Breysse 6

Hi everybody

i am sorry, I'm new on Trailhead and I have the same problem as Katie. How do I acceed to Account settings (to solve the same problem of missing relationship button) ?

Looking for reading you

Nathalie

Nathalie Breysse 6Nathalie Breysse 6

"Go to Account settings--> Enable "Allow users to relate a contact to multiple accounts" check box."
I have found it ! Yes ! 

Next step

Cassandra Anderson 5Cassandra Anderson 5
This will also make the button appear if it's missing. I was working on a trailhead challenge and "related contacts" was not available. Thank you!
-Cassandra
Laetitia WodiaLaetitia Wodia
Hi,
I have the same problem with the button "add relationship"
I did "Go to Account settings--> Enable "Allow users to relate a contact to multiple accounts" check box."
But nothing , do you have others solutions ?
Shelly HamannShelly Hamann
Hi,

I too am doing a challange in Getting Started with Accounts and Contacts. I created the account Smith Enterprises and the contact Amanda Smith and connected her to the account, however I don't see a "Related To Account" field anywhere. I am supposed to be doing this challange in Classic view but I have also tried Lightning. I have also tried the suggestions above about the multiple accounts but it doesn't work. Any ideas?
John BauerleJohn Bauerle
Any answers to this? Very new to salesforce, just start trailhead this week. The related contacts button is on the related list but not related accounts or anything pertaining to accounts. Thanks 
Gnana Moses 5Gnana Moses 5
Finally, Create a Contact (John Smith) manually for the Account Greendot Media as a workaround if you do not find Add Relationship button
Varun SinghVarun Singh

I am able to complete the challenge. I follow the below steps:
1-Go to Setup -> Customize -> Account -> Account Settings -> Enable Contacts to Multiple Accounts Seetings
2-Create new Account with Name 'Acme Corporation'.
3-Create new Account with Name 'Greendot Media'.
4-Edit Account Layout and add 'Account Teams' and 'Related Contacts' related list.
-5Create New Contact 'John Smith' and add Account 'Acme Corporation'.
6-Go to Greendot Account and Add relationship to John smith contact using 'Related Contacts' related list.
7-Go to Acme Corporation Account and add Team for myself.
Check the challenge and it was successful.