• Jayanth Thathapudi
  • NEWBIE
  • 119 Points
  • Member since 2016


  • Chatter
    Feed
  • 2
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 16
    Questions
  • 60
    Replies
Hello Everybody,

I m looking for some assistance please.
im running a basic Osql query : 
public List<Quote> getclosedwonlist() {
  		return [SELECT Id, Quote.Name, Opportunity.status FROM Quote WHERE Opportunity.status='Closed Won' ORDER BY Id];
	}
Even there is a relationship between Quote and Opportunity, system return the following error :

No such column 'status' on entity 'Opportunity'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

By advance thank you
how can i make a wizard visualforce for a custom Object ? please help
Hi All,

I will be using Apex Replay Debugger alot for the debugging purpose. It used work perfectly but now I am getting the below error while toggling the checkpoint and  Update Checkpoints in Org

"Command 'SFDX: Toggle Checkpoint' resulted in an error (command 'sfdx.toggle.checkpoint' not found)"

"Command 'SFDX: Update Checkpoints in Org' resulted in an error (command 'sfdx.create.checkpoints' not found)"

Any suggestion or help is highly appreciated.

Thanks,
Jay
List<OpenActivity> openList=  new List<OpenActivity>();
for(OpenActivity oA :OpenActivitieslist){
                                oA.OwnerId=''012200000000MqA';
                                openList.add(oA);
                        } 

    Update openList;

While I am trying to upade it is showing error as "Field is not writeable: OpenActivity.OwnerId"

Any help is highly appreciated:)

Thanks,
Jay
I want to use the role name in HTML email template and I have used the below to get Role of the user but it is displaying as null

{!Target_User.UserRole.Name}

Any help is highly appreciated:)
I want to bypass the standard merging if one lead has a record type of XYZ.....I want to check the whether merging is happening through standard salesforce merge tool.

Any help will be highly appreciated.
I want the report of campaign field history on the campaign so that I can get the report of tracking fields.
This functionality is working perfectly in classic(achieved by using custom button URL via URL hacking) but it is not working as expected in Lightning. 

Any help would be appreciated :)
Hi All,

I am unable to "Campaign Field History" feature in my Developer sandbox. Do we need to make any settings to make to visible? because I can see it my colleague's sandbox. 

Navigation:
Setup->Build->Customize->Campaign->PageLayouts ->click on edit "Main Layout"->go to Related lists-> Here you should be able to see "Campaign Field History"

I am  not able to see this "Campiagn Field History"

Any help will be really appreciated.

Thanks
Jay
What does "remote access client" error in login history mean?
How to assign a Home Page Layout to a profile in eclipse. i.e using ANT
User-added image
Eclipse Version: Mars.2 Release (4.5.2)
Force IDE version: 38

Please help me to resolve this issue.
So that while activating the App Page we can change the permissions of user from Administrator to all users
I am getting error as
Challenge Not yet complete... here's what's wrong:
The 'Cases by Status' report does not include the Owner and Account Name columns

Did everything as mentioned in the challenge..Screenshot that shows case woner and account name

Please help me to resolve this issue
Faced this type of use many times...Is der any way to refresh the metadata so that reference of deleted names will be removed?
Hi All,

I will be using Apex Replay Debugger alot for the debugging purpose. It used work perfectly but now I am getting the below error while toggling the checkpoint and  Update Checkpoints in Org

"Command 'SFDX: Toggle Checkpoint' resulted in an error (command 'sfdx.toggle.checkpoint' not found)"

"Command 'SFDX: Update Checkpoints in Org' resulted in an error (command 'sfdx.create.checkpoints' not found)"

Any suggestion or help is highly appreciated.

Thanks,
Jay
Step 1:I select my project in IDE and do Deploy to server.
Step 2: I given my dev org credentials and presee next.
Step 3: Added project archive and destination archive folder
Step 4: Validate Deployment : showing me several errors:
Problem: Property 'shouldOverrideOrgTheme' not valid in version 38.0
Problem: Property 'isNavAutoTempTabsDisabled' not valid in version 38.0
  Problem: c:BR_Carousel:1,1: ParseError at [row,col]:[2,1]
Message: Content is not allowed in prolog.
Problem: Invalid definition for null:CreateCaseController: null

others too.

I have verified my package.xml which have version 43.0. 
I have taken the code from other dev org as a baseline and want to move it to development org for each developer .
Please guide me, how to resolve thie issues ?
Hi Every one ,
Could you please explain what is Schema ,in which case we need to use Schema , how to use and what is advantage of Schema in salesforce
i am new to this plese explain about Schema
thanku
For example we have a related list button in lightning does the following
  1.  select the records within the related list that you want to update (Display Checkboxes (for Multi-Record Selection)) is enabled.
  2. click the button
  3. Custom JS is ran, part of it calls on apex global methods, but at the end of the day the selected records on that related list are 'updated'. OR a simple window.open('/00O140000091FlJ?pv0={!Account.Id}'); is ran
So far I have only seen this option online: http://succeedwithsalesforce.com/multi-select-and-mass-update-records-in-lightning-list-views-using-flows-visualforce-and-a-list-button/
Flow: A screen flow that would accept user’s input and then update the selected records with the new owner

Visualforce Page: The flow would be embedded inside this Visualforce page and the page performs the primary job of passing over the selected records in the list view into a Flow SObject collection variable.

Custom List Button: This button will reference the Visualforce page and will be placed on the List view

Now if that works, couldnt i just create a VF page and then apex code instead of a flow (i hate flow builder i'd rather code). Heck, since i'm running VF coulnd't i just and call on global methods, keeping some of the if/else structure of the original JS related list button.

What's everyone's experience with migrating list view buttons from classic-->lightning.

In regards to a window.open('/00O140000091FlJ?pv0={!Account.Id}');  Could that be recreated in a standard custom link button? Would something like below work or would it not pick up the {!Account.Id}?  
 
https://<domain>.force.com/lightning/r/report00O140000091FlJ/view?fv0={!Account.Id}

I'd like to keep a button on the related list itself instead of just jamming loads of related list buttons into the lightning quick action section (the fact that you cant have lightning quick actions on related lists....is painfully bad) it makes it easy for the users, they go to the related record, they click the button, instead of trying to figure out what the buttons do from the lightning quick action section........

Has anyone been able to ghetto rig a custom button --> VF page/link ---> lightning component?
Hi There,

I thought I had a rather simple issue to implement but it seems to be more complicated:

I have been asked to put a link into our SF navigation to our Sharepoint. We have a list there for improvement suggestions by our users. I should put a link to this list in the navigation.
I tried to create a  web tab, but at the end, i get the error that Sharepoint does not allow the connection (I guess iframes are blocked). 
The only thing i need is a hyperlink, I dont need this to be embedded. It should open a new tab. I doubt this is impossible, yet i cannot find how to implement this.
any help is much appreciated!
 
Hi All,

When i execute the below SOQL query with around 100 fields from  the VF page,  it is counting the CPU Time. Where the SOQL is returning around  11K lineitems. 
System.debug('Start CPU Time===>'+Limits.getCpuTime());
Map<Id, OpportunityLineitem> oppMap = new Map<Id, OpportunityLineitem>([select Id, OpportunityId, ListPrice, CreatedDate, CurrencyIsoCode from OpportunityLineItem where OpportunityId = '006XXXXXXXXXXXX' ]);
System.debug('End CPU Time===>'+Limits.getCpuTime());
Due to security constraint i have removed remaining fields from the above code snippet.

Below is the screenshot of CPU Time consumed for the above SOQL code :
User-added image

User-added image

I am aware that the maximum synchronous CPU Time limit is 10000 milliseconds, due to this limit i am facing the Apex CPU Time limit exceeded error.
Can some one help me why it is consuming the CPU time for SOQL execution? 

As per the salesforce article (https://help.salesforce.com/articleView?id=000232681&language=en_US&type=1), it is mentioned that CPU Time is not counted for SOQL Queries.

P.S. As per business requirement, i don't want to do any changes to SOQL query (like reducing the no. of fields and adding additional filter conditions) and want to execute it from VF page(Syncronous).
  
Hi All,
i have useed a Lightning component on utility bar.By clicking on it,the utilitybar popup is opening and component is showing.Once after the component was fired,the component is not getting refreshed on UtilityBar.
I have tried in many ways using event.refresh tag and many.
can any one please help me.Your work is appreciated.Below I have posting screenshots.
User-added imageUser-added imageUser-added imageThankyou
i need to deploy a package contating Listview button of a Standrad Object, How can i assigen/add a Listview button automatically after installing a managed package ?
Hi,
How to call Scheduler class from the trigger?

Regards,
SFDC16
I have created a Unmanaged package and trying to install on other Sandbox. During installation it is giving me a message of Version mismatching. The Sandbox in which the installation is attempted is of API version 44.0 whereas the version of the Development Sandbox is 45.0
We have downgraded all the Components of the Development Sandbox to 44.0 and have re-created the Package but still the same issue exists.

User-added image
HI Everyonce,

Can anyone let me know how to integrate medical devices with salesforce using any middleware tools.
Hi,

I have a sObject variable say vDaysOfWeek which has values like 'Mon','Tue','Wed' etc.
In my flow decision box, I need to check my input variable vInputDay matches with my sObject value.

eg : Outcome1 : vInputDay  equals  'Mon' -> do some stuff
       Outcome2 : vInputDay  equals  'Tue' -> do something else... 

Please suggest a way to implement this in cloud flow designer.
I do not want to hardcode the values but retrieve them from sObject.

Thanks.
I want to use the role name in HTML email template and I have used the below to get Role of the user but it is displaying as null

{!Target_User.UserRole.Name}

Any help is highly appreciated:)
I want the report of campaign field history on the campaign so that I can get the report of tracking fields.
Hello,

i am strungeling with a custom "create"-Button. I want to select a recordtype and submit a parameter to prefill a field. Selecting a recordtype works, but submitting a value does not.

Can anyone give me an advice? I was looking around the web and tried some suggestions but nothing helps. 

Important: i am on Lightning!

My code:
var newTestpoint = $('<a href="/a0B/e?&ent=Warengruppen_Struktur__c&CF00N0O00000AfEAi='+node.title+'&CF00N0O00000AfEAi_lkid='+node.key+'"> neuer Endpunkt | </a>');
                    $nodeSpan.append(newTestpoint);



thanks
Peter
Hello,

I was going through the Trailhead for Lightning Components and saw a couple of methods that deal with the response from a Callback. There were response.isValid() and response.getReturnValue().

Can anyone point me in the right direction as to where I can find more not only about these two methods but any others that are applicable to service side responses? I've looked around and I haven't seen much.

Thanks,

Mike
In the 'Getting Started with APEX Triggers' (http://goo.gl/5YJ01q) module, an error message appears when attempting the first example/exercise. 
 The instructions read: 
  • 1. In the Developer Console, click File | New | Trigger. (The menu path is actually File | New | APEX Trigger).
  • 2. Enter helloWorldTrigger for the trigger name, and then select Account for the sObject. ClickSubmit. (stet)
When clicking submit in step 2, an error message appears: "The Trigger "HelloWorldTrigger " is not a legal name." The parenthesis around HelloWorldTrigger are not entered in step 2. 

Work Around:  
In Setup go Develop | Apex Triggers
Launch the Dev Console (DC) from setup UI. 
Removed previous text from within the Query Editor tab which contained an invalid query, and was promtping an error message itself.
Continued with set 2, above. 

I was able to save the new trigger in the Dev Console. I then deleted it, closed the DC, and repeated the steps from the Trailhead exercise (where the DC was launched from Name | Dev Console, not Setup | Develop). I was then able to save the trigger without error. 

Take Away: it may have been the erronous text in the query editor, when the DC was launched from Name | DC. Subsequently adding erronous text back into the query editor, and repeating set 2 above did not throw a naming error the second time.  
 
Hi Team,

We are facing an issue while retrieving Custom Fields through Retrieve methods of Sales force Metadata API. The issue is occcuring with Event and Task Standard Object (Basically Activity Object). Generated output files (e.g: Event.xml) is not retrieving any Custom fields from Event OR Task Object(e.g: •Color_vod__c
• Followup_Activity_Type_vod__c
• Mobile_ID_vod__c
• Override_Lock_vod__c
• TOT_ready_AZ_EU__c)

This is causing an serious issue for one of our development project for Metadata extraction and using the same information for other reporting tool purpose.
Any update or resolution on the same will be highly appreciated.

Barun Kumar Goswami
Cognizant Technology Solutions

I have a custom object Consultant which has a lookup to Account. The Account lookup is made read-only in the Consultant page layout level.


As Sys Admin, I am able to see the Account lookup getting populated when a New Consultant is created from Account related list. But when logged in as a different User, I am not able to see the Account lookup getting populated and since its read-only in the Consultant page layout, no data is available for the User to enter.

The same issue doesn't happen with standard Account - Contact relationship, if Account lookup is made read-only at Contact page layout.

Let me know if anybody can help in this issue!!!

 

Regards,

Karthik.