• Paul Worlton
  • NEWBIE
  • 0 Points
  • Member since 2017
  • Senior Software Engineer
  • Celtic Bank


  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
    Questions
  • 5
    Replies

I have a sandbox deploy script that works fine for setting environment variables but fails to create test data that I always need.  If I run the data insert methods manually, they work fine - but the deploy script seems to skip those methods. Is this an issue with calling static methods or does SandboxPostCopy intentionally block SOQL inserts?

The following is my main function:

// Main deploy script
    global void runApexClass(SandboxContext context) {
        // Set org to dev
        Server__c srv = Server__c.getOrgDefaults();
        srv.Environment__c = 'dev';
        srv.Disable_Rules__c = true;
        upsert srv;
        
        createDummyAccountContact();
        createTestLeads(10);
        createTestLoans(4);
    }
 



 

Hi,
    Eventhough my code works i still get the error "The page does not bind to the record ID value (in order to link to the record detail page) " when i tried to check in the challenge. any help is appreciated.
code below:
<apex:page standardController="Account" recordSetVar="accounts" >
   <apex:pageBlock title="Account List">
      <!-- accounts List -->
       <apex:repeat value="{! accounts }" var="a">
          <li>
            <apex:outputLink value="/{!LEFT(a.Id,15)}">/{!LEFT(a.Id,15)} </apex:outputLink>
          </li>
</apex:repeat>
</apex:pageBlock>
</apex:page>

Thanks

Can anyone suggest, how ca we delete apex class from production.

please provide step-step process to delete it from prod. through Force.com Eclipse.

  • October 29, 2010
  • Like
  • 1