• NSnyder
  • 0 Points
  • Member since 2018

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 1
As of today and the addition of Spring 18 to my developer sandboxes, I am no longer able to save lightning components that extend base components. I am getting an error that references an invalid type "UserInformation" (which does exist), that the child component is referencing from the parent component.

Has anyone else experienced or solved this issue?
Good Morning, Smart Folks!

It seems that our Lightning Out app which is embedded in a Sitecore site has completely stopped working after the application of Spring 18.  Everything worked GREAT(ish) on Friday the 5th Before the update was applied.  Now, I'm getting two Javascript errors when trying to render the app.  (It doesn't even hit our custom code...so, its not our app, and a simple "Hello World" lightning app does the same thing. 

Here's the Chrome dev tools output:

aura_prod.js:formatted:23327 Uncaught TypeError: Cannot read property 'create' of undefined
at a (aura_prod.js:formatted:23327)
at new A.ea.tq (aura_prod.js:formatted:23371)
at new $ (aura_prod.js:formatted:23425)
at new (aura_prod.js:formatted:24285)
at aura_prod.js:formatted:7279
a @ aura_prod.js:formatted:23327
A.ea.tq @ aura_prod.js:formatted:23371
$ @ aura_prod.js:formatted:23425
(anonymous) @ aura_prod.js:formatted:24285
(anonymous) @ aura_prod.js:formatted:7279

lightning.out.delegate.js?v=psg1JKA5EjWqfg8XQIV7lw:133 Uncaught TypeError: Cannot read property 'isEmpty' of undefined
at HTMLScriptElement. (lightning.out.delegate.js?v=psg1JKA5EjWqfg8XQIV7lw:133)