• alfo72
  • NEWBIE
  • 10 Points
  • Member since 2017
  • A Life Full Of Pty Ltd

  • Chatter
    Feed
  • 0
    Best Answers
  • 1
    Likes Received
  • 0
    Likes Given
  • 4
    Questions
  • 2
    Replies

We are building a new org and doing it programmatically as it is highly customised.  We are also going down the SFDX route, so Dev Hub, Scratch, Source, Branching etc.

Anyone creating scratch orgs needs to be active in the system with ther permission to build scratch orgs.  BUT what is the minimum license they need?

Other than developing in Scratch and potentially using a prebuild Sandbox for some testing (where we can create them as sys admin) they will have zero to no interaction with production.

As I have 4 new devs, I don't really want 4 x Full Salesforce licenses when they will never use the functionality.

Asking this on success as well but came here in case any dev managers or others have feedback.

  • April 24, 2020
  • Like
  • 0
Made some great advances in using SFDX, GIT and VS, mostly admin related stuff right now but we have a developer coming onboard soon.

One question (for now) how do we deal with custom development against an installed AppExchange app?

i.e. We have Linked In Sales Navigator in Production that requies page layout changes, FlexiPage Components, field permissions etc.  I have installed into a Scratch, built everything and pulled the meta into VS (note I am not trying to amend the Managed Package.)

When I come to create an unlocked package I get errors nearly all related to the managed package.  It will be errors like can't add that field because it already exists BUT that field is being included because I have permissions, layouts and maybe flexipages (with components.).  I don't want to add the base data from the managed package because it is installed in Production aleady.

Does it not work?
 
  • February 06, 2020
  • Like
  • 1
Just getting started here, crash course in Packaging for a new org we are building.

Created a scratch org, made some basic changes:
  • 5 x Account Record Types
  • 6 x Custom Text/Number Fields
  • Amended a Layout
  • Gave Sys Admin Profile field permissions.
Pulled the changes into my VS and Repository.

Now want to create a package and configured package.xml as:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    
    <types>
        <members>Account</members>
        <name>CustomObject</name>
    </types>
    <types> 
        <members>Account.AccountSource</members> 
        <name>CustomField</name> 
    </types> 
    <types> 
        <members>LeadSource</members> 
        <name>StandardValueSet</name> 
    </types> 
    <types>
        <members>Account.CXC_Client</members>
        <members>Account.CXC_Contractor_Company</members>
        <members>Account.CXC_Contractor_Employee</members>
        <members>Account.CXC_Entity</members>
        <members>Account.CXC_Service_Partner</members>
        <members>Account.CXC_Supplier</members>
        <name>RecordType</name>
    </types>
    <types>
        <members>Admin</members>
        <name>Profile</name>
    </types>

Get the following error :

Account.Client: Picklist value: Advertisement in picklist: AccountSource not found

Lots of reading and links and changes and variations but still can't get it working.  Do I have the order wrong?  Do I need to do something else first?  Everything i have read suggests it is the right approach.
  • January 03, 2020
  • Like
  • 0
My new company would like to include my learning on their Trailhead dashboard.  I don't want to move them across.

I thought I could connect the two accounts without physcially merging them.  Is this possible
  • October 09, 2019
  • Like
  • 0
Made some great advances in using SFDX, GIT and VS, mostly admin related stuff right now but we have a developer coming onboard soon.

One question (for now) how do we deal with custom development against an installed AppExchange app?

i.e. We have Linked In Sales Navigator in Production that requies page layout changes, FlexiPage Components, field permissions etc.  I have installed into a Scratch, built everything and pulled the meta into VS (note I am not trying to amend the Managed Package.)

When I come to create an unlocked package I get errors nearly all related to the managed package.  It will be errors like can't add that field because it already exists BUT that field is being included because I have permissions, layouts and maybe flexipages (with components.).  I don't want to add the base data from the managed package because it is installed in Production aleady.

Does it not work?
 
  • February 06, 2020
  • Like
  • 1

We are building a new org and doing it programmatically as it is highly customised.  We are also going down the SFDX route, so Dev Hub, Scratch, Source, Branching etc.

Anyone creating scratch orgs needs to be active in the system with ther permission to build scratch orgs.  BUT what is the minimum license they need?

Other than developing in Scratch and potentially using a prebuild Sandbox for some testing (where we can create them as sys admin) they will have zero to no interaction with production.

As I have 4 new devs, I don't really want 4 x Full Salesforce licenses when they will never use the functionality.

Asking this on success as well but came here in case any dev managers or others have feedback.

  • April 24, 2020
  • Like
  • 0
Just getting started here, crash course in Packaging for a new org we are building.

Created a scratch org, made some basic changes:
  • 5 x Account Record Types
  • 6 x Custom Text/Number Fields
  • Amended a Layout
  • Gave Sys Admin Profile field permissions.
Pulled the changes into my VS and Repository.

Now want to create a package and configured package.xml as:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    
    <types>
        <members>Account</members>
        <name>CustomObject</name>
    </types>
    <types> 
        <members>Account.AccountSource</members> 
        <name>CustomField</name> 
    </types> 
    <types> 
        <members>LeadSource</members> 
        <name>StandardValueSet</name> 
    </types> 
    <types>
        <members>Account.CXC_Client</members>
        <members>Account.CXC_Contractor_Company</members>
        <members>Account.CXC_Contractor_Employee</members>
        <members>Account.CXC_Entity</members>
        <members>Account.CXC_Service_Partner</members>
        <members>Account.CXC_Supplier</members>
        <name>RecordType</name>
    </types>
    <types>
        <members>Admin</members>
        <name>Profile</name>
    </types>

Get the following error :

Account.Client: Picklist value: Advertisement in picklist: AccountSource not found

Lots of reading and links and changes and variations but still can't get it working.  Do I have the order wrong?  Do I need to do something else first?  Everything i have read suggests it is the right approach.
  • January 03, 2020
  • Like
  • 0