• Tuur Dutoit 13
  • NEWBIE
  • 5 Points
  • Member since 2017
  • CTO
  • PursuitPower

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
    Questions
  • 9
    Replies
We're an ISV partner and we're creating a managed package which contains, among others, an app consisting of 2 Lightning tabs. Now, I tested this in multiple scratch orgs, packaged it up using SFDX (packaging2) and after a few hiccups, I got everything working, it seemed.
However, I just installed the same managed package in a developer org (instead of a scratch org) and for some reason, the tabs aren't showing up: the app is empty. I had seen this issue before, so I went to Setup to make them visible and add them to the app, but weirdly enough, the tabs aren't even listed in Setup! I checked and they are correctly listed as dependencies in the Installed Packages page, but they don't show up anywhere else in the org.
Does anyone know what the problem could be?
I'm trying to make a process in Process Builder that updates an record's owner when a picklist on that record changes from one specific value to another specific value. So I created a criteria, with the "Formula evaluates to true" option and this formula:
AND(
 ISPICKVAL([creddox__project_credential__c].creddox__Project_Record_Approval_Status__c, "Draft - Not Submitted"),
 ISPICKVAL(PRIORVALUE([creddox__project_credential__c].creddox__Project_Record_Approval_Status__c), "Requested - In Review")
)
(Followed by a field update action, of course, but that's not relevant here)
This tests whether the value is equal to "Draft - Not Submitted" and was "Requested - In Review"; in other words, it changed from the latter to the former.
Note that the "Do you want to execute the actions only when specified changes are made to the record?" checkbox is not checked, I inserted the fields in the formula using the field chooser dialog and copied the values from the setup page of the object in question. I checked a dozen times if the records were correctly updated from the first value to the second one. I also tested whether the process is triggered at all (with a second criteria that always executes), and it does. This also proves it's the criteria evaluating to false, and not the field update failing. So the formula should be correct, the tests I do are correct, and I know for a fact the process runs. This means the formula evaluates to false for some reason.

The weird thing is, this problem occurs when triggered by a field update (of the picklist), which was triggered as a final approval action of an approval process. So I tried what would happened if I changed the picklist manually, and lo and behold, the process works fine then.

Could this be bug in Salesforce, or am I missing something?
I'm making a Visualforce email template, and I would like to pass the recipient (a User) to a custom component. Basically, I have the following setup (leaving out some unrelevant content).

Template:
<messaging:emailTemplate subject="..."
    recipientType="User"
    relatedToType="Some_Custom_Object__c">
  <messaging:htmlEmailBody >
    <c:Email recipient="{!recipient}">
      <p>Some content...</p>
    </c:Email>
  </messaging:htmlEmailBody>
</messaging:emailTemplate>

Custom component:
<apex:component access="global">
  <apex:attribute type="User" name="recipient" description="The user recieving this email" access="global" />
  <html>
      <head>
          <c:email_styles />
      </head>
      <body>
          <p>Dear {!recipient.Name},</p>
          <apex:componentBody />
      </body>
  </html>
</apex:component>

I saved the component successfully, but when saving the template, I get the following error: Unknown property 'UserStandardController.recipient'​.

Any ideas what might be causing this?
Hi,

I have a lightning app, which sets a variable during first time. From next time when the user users the app it should fetch from the memory. 

what is the best place to store the variable details? (local storage/cookie/custom object etc) 
Can someone please help me on the below issue.
How can I pass the date field (i.e. in an Object) from Apex controller to lightning component (i.e. having date type attribute)? So that once I fetch the date then I need to perform some action in Lightning component based on the Date it got from Apex controller.
We're an ISV partner and we're creating a managed package which contains, among others, an app consisting of 2 Lightning tabs. Now, I tested this in multiple scratch orgs, packaged it up using SFDX (packaging2) and after a few hiccups, I got everything working, it seemed.
However, I just installed the same managed package in a developer org (instead of a scratch org) and for some reason, the tabs aren't showing up: the app is empty. I had seen this issue before, so I went to Setup to make them visible and add them to the app, but weirdly enough, the tabs aren't even listed in Setup! I checked and they are correctly listed as dependencies in the Installed Packages page, but they don't show up anywhere else in the org.
Does anyone know what the problem could be?
I'm making a Visualforce email template, and I would like to pass the recipient (a User) to a custom component. Basically, I have the following setup (leaving out some unrelevant content).

Template:
<messaging:emailTemplate subject="..."
    recipientType="User"
    relatedToType="Some_Custom_Object__c">
  <messaging:htmlEmailBody >
    <c:Email recipient="{!recipient}">
      <p>Some content...</p>
    </c:Email>
  </messaging:htmlEmailBody>
</messaging:emailTemplate>

Custom component:
<apex:component access="global">
  <apex:attribute type="User" name="recipient" description="The user recieving this email" access="global" />
  <html>
      <head>
          <c:email_styles />
      </head>
      <body>
          <p>Dear {!recipient.Name},</p>
          <apex:componentBody />
      </body>
  </html>
</apex:component>

I saved the component successfully, but when saving the template, I get the following error: Unknown property 'UserStandardController.recipient'​.

Any ideas what might be causing this?
Hi All,

I have requirement where i need navigate multiple visulaforce pages by clicking on save&next buttons on the page. Also i need to notify the user on the top of the page with bigger buttonns which page user is residing like page one, page two exc...
How to achive this in visualforce with out using bootstrap breadcrumbs?

User-added image
Thanks,
Anil Kumar
When I Press the Save button it saves the values but when I hit F5 or refresh the values are gone, they are not visible on my VF page.
And for this :
  • I have created VF page with standard controller and extensions.
  • created one controller.
  • And I have embedded VF page into Opportunity object.
Any idea how I can achieve this ??
Thanks.
  • September 02, 2017
  • Like
  • 0
I'm trying to create a validation rule that prevents reps from moving an opportunity forward until it has been approved by our ops team. I've tried a number of versions of formulas on the forum but I can't seem to get it quite right.

The formula should say that if the opportunity - is a Change Request and the stage has changed or if its new and the stage is either Closed/Won, Closed/Won - Pending, or Closing - 90%, and the Approval Status is either New, Pending, or Rejected - then show the validation rule error that says it must be approved before advancing.

Can someone please highlight where I am going wrong here? I would greatly appreciate any help I can get.
 
AND (RecordType.Name = "Change Request", 
OR( 
ISCHANGED(StageName), 
ISNEW()), 
OR( 
ISPICKVAL(StageName, "Closed/Won"), 
ISPICKVAL(StageName, "Closed/Won - Pending"), 
ISPICKVAL(StageName, "Closing - 90%")), 
OR( 
ISPICKVAL(Approval_Status__c, "New"), 
ISPICKVAL(Approval_Status__c, "Pending"), 
ISPICKVAL(Approval_Status__c, "Rejected") 
) 
)

 
I currently have a Hyperlink from a custom object "Document" to a VF page. This hyperlink is displayed on the related list on the Lead, Opp, and some other custom objects. So the VF Page can be accessed from any of the records related to the Document record. The issue I am running into is how to set the return URL. I can set the Return URL ID based on each related record but how can I tell which record the user just accessed the VF Page from?
Hyperlink formula: HYPERLINK("/apex/AttachDoc?id="& Id &"&retURL=%2F"& Lead__r.Id ,"Upload Docs Here","_self")
So the formula above would only return the user to the Lead, but what if they actually accessed the link from the Opp or one of the other custom objects?