• ramya sree 9
  • 5 Points
  • Member since 2017

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 4
I have installed salesforce cli windows 64 bit and I also installed it through npm globally. 
I am on windows 7 machine and behind a company firewall and I have proxy set on my computer

C:\Users\XXXXX>sfdx update
panic: Get https://developer.salesforce.com/media/salesforce-cli/sfdx-cli/channe
ls/stable/windows-x64: dial tcp XX.XX.XX.XX:443: connectex: A connection att
empt failed because the connected party did not properly respond after a period
of time, or established connection failed because connected host has failed to r

goroutine 1 [running]:
panic(0x6632a0, 0xc0420067b0)
        /usr/local/go/src/runtime/panic.go:500 +0x1af
main.must(0x7b92c0, 0xc0420067b0)
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/io.go:115 +0x63
main.GetUpdateManifest(0x6a4875, 0x7, 0x6a3c0d, 0x3, 0x7b92c0)
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/install.go:104 +0x2
main.GetUpdateManifest(0x6a4875, 0x7, 0x6a3c0d, 0x3, 0x0)
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/install.go:102 +0x2
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/install.go:33 +0x10
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/main.go:18 +0x3a

On my work laptop, my regular user doesn't have administrative permissions. To install Salesforce DX CLI, I needed admin permissions. Therefore, I used my secondary privelaged workstation user to "run-as" the installer. However, when I run command prompt under my regular user, the Salesforce DX CLI isn't accessable. I seem to only be able to access the Salesforce DX CLI when I run command prompt as administrator, which requires entering the credentials of my privelaged workstation user. Is this expected? Is there any way to access the Salesforce DX CLI when not running command prompt with administrator permissions?