• Andy Norman 3
  • 0 Points
  • Member since 2018

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 1
I'm trying to use the Query Plan tool in the developer console for the first time.

Every single query that I try ends up with a table scan, because of the IsDeleted field not being indexed. The notes always have this for every table in the query:
Not considering filter for optimization because unindexed.
Table: Opportunity Fields: ["IsDeleted"]
Even if the query is as basic as:
select Id from Opportunity
where id = 'xxxxxxxxxxxxxxx'
Am I doing something wrong or is something broken ?
Since the Winter 19 release, I am getting the above error when I run any unit test that modified a user record.

We are using the User License type: Overage Authenticated Website

I cannot locate the permission "Edit Self-Service Users" I turned off the enhanced user management to look for it and also tried giving my Users a permission set with all permissions under Users section.

Doing some research on previous posts about the  "Edit Self-Service Users" that what was recommended.

Thanks in advance,