• Resample Admin
  • 10 Points
  • Member since 2018

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 3
I am trying to insert platform events into my org in CSV format.  Very simple object with 3 fields:  DateTime / Numeric / Text 

However ... I am receiving the following error:  ERROR: EmpPublishRateLimitProv Limit exceeded.

I have tried dataloader.io and the standard Salesforce Dataloader App.  I am nowhere near my API limits for the org.  I can insert standard objects with no issue.  The Org is a Partner Developer Org.  

Any thoughts here?  Any reason why Platform Events would behave differently for INSERT?

The org is 
I have a trigger on a Custom Object which inserts Big Objects. These are separate objects.  

The actual Big Object insertion is done via an @future (callout=false) method.  This is due to the limitation described here:  

"Big objects don’t support transactions that include big objects, standard objects, and custom objects."

Now, I am trying to test this trigger and @future method.  The documentation states that I should use the Stub API and Mocking Framework to do so:  

Any Apex tests that use DML calls will fail and potentially insert bad data into the target big object. This data won’t be deletable. To test DML calls, use a mocking framework with the Apex stub API to contain calls to the target big object

However, the Stub API has a limitation that it cannot be used for @future (static) methods.  

Feel like I am going in circles here.  Is there another way to mock the @future insertion?  Or another way to decouple the custom object trigger and subsequent Big Object insertion? 

I am trying to use the Apex Debugger in VS Code (after following the steps at https://github.com/forcedotcom/salesforcedx-vscode/tree/develop/packages/salesforcedx-vscode-apex-debugger#set-up-the-apex-debugger), and I get the following error: "You exceeded your licensed number of debugging sessions. Please end other sessions or purchase more."

I have tried with scratch orgs with both "edition": "Enterprise" and "edition": "Developer" in the definition file, with "DebugApex" included in the "features" and the DebugApex permission granted to my scratch org user. The parent org for my scratch orgs is an Enterprise Edition, and under Apex Debugger it says "Your child orgs aren't using any Apex Debugger licenses. You have 1 license available.". Under Apex Debugger in my scratch orgs, it says "Your org doesn't have any active Apex Debugger sessions.".

Am I missing something that would prevent me from starting an Apex Debugger session in my scratch orgs?
I have used Database.insertImmediate(objOppSplitHistories); method to insert/update records into OppSplitHistories (my custom big object).
Here I have used the above method in apex class and called that method from oppsplit trigger to pass the old map/new map info for saving opp splits changes. But that is throwing the below error. I have observed if I run the same piece of code in ‘Execute Anonymous Window’ then data is  being inserted in to custom big object but despite using insertImmediate method it is not working through trigger.

Error: Update failed. First exception on row 0 with id 049c0000002JaopAAC; first error: UNKNOWN_EXCEPTION, EXTERNAL_OBJECT_UNSUPPORTED_EXCEPTION: Apex triggers can't reference the Big Object BigObjectCounter: []

It seems we cannot populate any bigobject through trigger . Can you please confirm whether my understanding is correct or not.
If it is correct then what should be our approach to populate this big object? Any help will be much appreciated. 
  • November 21, 2017
  • Like
  • 0
Well I created a Public Class/Controller, then I couldn't find it (wasn't coming up in any search), so I tried and recreating it, but it says it's already created.  What gives?  This is very bizarre behavior.