• Jeff Douglas (Personal)
  • NEWBIE
  • 22 Points
  • Member since 2008
  • Salesforce


  • Chatter
    Feed
  • 0
    Best Answers
  • 1
    Likes Received
  • 0
    Likes Given
  • 6
    Questions
  • 18
    Replies

I just refreshed our sandbox and now cannot create a new Connected App. With each (unique) app name I get the error:

 

The application name [app-name] / [app-name] has been used before. Use a new unique name for your application.

 

See this screenshot

 

Thanks

Jeff Douglas

Appirio

We are using the Databasedotcom Ruby gem (essentially a REST wrapper) to authenticate to salesforce. The OAuth dance is randomly failing (1 out of 25 attempts) with the following message: 

 

client identifier invalid

 

The code is almost boilerplace code for authentication:

 

def self.authenticate(username, password)
  config = YAML.load_file(File.join(::Rails.root, 'config', 'databasedotcom.yml'))
  client = Databasedotcom::Client.new(config)
  begin
    access_token = client.authenticate :username => username, :password => password
    {:success => 'true', :message => 'Successful sfdc login.', :access_token => access_token}
  rescue Exception => exc
    {:success => 'false', :message => exc.message}
  end
end

 

Any ideas what could be causing it to fail randomly?

 

Thanks

 

Jeff Douglas

Appirio & CloudSpokes

http://blog.jeffdouglas.com

 

 

Perhaps I'm missing something here but I can't find any docs or way to write unit tests for Apex REST classes for v24. Here's my class:

 

@RestResource(urlMapping='/v.9/member/*/results/*') 
global with sharing class MemberRestSvc {
 
  @HttpGet
  global static String doGet() {
  
    String[] uriKeys = RestContext.request.requestURI.split('/');
    // do awesome programming stuff here

  }
    
}

 

With a v23, I would typically write a test like:

 

RestRequest req = new RestRequest(); 
RestResponse res = new RestResponse();
 
req.requestURI = 'https://cs9.salesforce.com/services/apexrest/v.9/member/me/results/today';  
req.httpMethod = 'GET';

String results = MemberRestSvc.doGet(req, res);
System.assertEquals('awesomeness-happened',results);

 

However, I can't figure out how to specify the requestURI. It looks like the the System.RestContext class is not writeable? I keep getting NPEs. Any help would be greatly appreciated.

 

Thanks

Jeff Douglas

Appirio / CloudSpokes

http://blog.jeffdouglas.com

I'm having a problem with the stylesheets and am wondering if it is just something that I am not including correctly.

 

If I use the following tag, the Visualforce page renders with the correct colors for Account...

 

<apex:page controller="MyController" showHeader="true" tabStyle="Account">

 

However, if I remove the header and add the standard Salesforce stylesheets, I would assume that the colors would dispaly correctly but the blue coloring for Accounts is simply black. I checked the code and the stylesheets are being referenced correctly.

 

<apex:page controller="MyController" showHeader="false" standardStylesheets="true" tabStyle="Account">

 

Any idea?

 

Thanks

Jeff

There has been some concerns regarding the slow load times of  Sites pages. I was wondering what the specific plans are to address this? Caching? Pre-compiling?

 

Thanks

 

Jeff Douglas
Informa Plc
http://blog.jeffdouglas.com

 

Vote for my Idea: Ehanced Apex Testing Functionality (JUnit)

My Flex applications cannot connect this morning? Everything was working last night.

*** Security Sandbox Violation ***

We are using the Databasedotcom Ruby gem (essentially a REST wrapper) to authenticate to salesforce. The OAuth dance is randomly failing (1 out of 25 attempts) with the following message: 

 

client identifier invalid

 

The code is almost boilerplace code for authentication:

 

def self.authenticate(username, password)
  config = YAML.load_file(File.join(::Rails.root, 'config', 'databasedotcom.yml'))
  client = Databasedotcom::Client.new(config)
  begin
    access_token = client.authenticate :username => username, :password => password
    {:success => 'true', :message => 'Successful sfdc login.', :access_token => access_token}
  rescue Exception => exc
    {:success => 'false', :message => exc.message}
  end
end

 

Any ideas what could be causing it to fail randomly?

 

Thanks

 

Jeff Douglas

Appirio & CloudSpokes

http://blog.jeffdouglas.com

 

 

Quanity__c: Number(18, 0) - Required

Should Read

Quantity__c: Number(18, 0) - Required

Cannot complete challange without change
Hi, I am having trouble with the "Attributes and Expressions" module from trailhead.

Here is the challenge:
Create a Lightning Component to display a single item for your packing list.
  • Create a component called campingListItem that displays the name (ui:outputText) and the three custom fields using the appropriate output components.
  • Add an attribute named 'item' for type Camping_Item__c.
I created an component named campingListItem and this is the code:
<aura:component >
    <aura:attribute name="item" type="<my_domain>__Camping_Item__c"/>
    
    <ui:outputText value="{!v.item.Name}"/>
    <ui:outputCheckbox value="{!v.item.<my_domain>__Packed__c}"/>
    <ui:outputCurrency  value="{!v.item.<my_domain>__Price__c}"/>
    <ui:outputNumber value="{!v.item.<my_domain>__Quantity__c}"/>
</aura:component>

The error that I am getting is: "Challenge Not yet complete... here's what's wrong: 
The packingListItem Lightning Component's attribute tag doesn't exist or its attributes are not set correctly."

With this, I tried to create another component, with the name "packingListItem", but It didn't work.

Can anyone help me?

Thanks,
I have an error with reference KFVQKOVW. I have already Data.com Assessment App, but i can't validate trailhead. I need to be update in order to show my boss i am doing trailheads. Please, help me how to proceed!
Showing error as below :
Challenge Not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: VGRWNMRH
Hello - I am trying to complete the "Assessing the Quality of Data" module and can't seem to complete the Data.com download. This is the error message code I get - IDMFMZQJ. Does anyone know how I move past this? Thanks!
Hello Experts 

I tried to verify one of the trailhead " Battle station" 
and i got this error 
please can you help ? 

Thank you 
Step Not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: OZXVVKJM 
Remarque : Si vous avez ignoré les étapes précédentes, vous risquez de rencontrer des erreurs.
I have completed the Lightning Process builder step and i have verified that it is working correctly ( the battle Station record has been changed to complete and it has post a message to chatter, but when I click the Verify Step button I get this error message:

"Step Not yet complete... here's what's wrong:
An update to a Battle Station record with Weapon Status of 'Fully Operational' failed to post a Chatter message to the record. Make sure that the process is configured correctly and that it is activated.
Note: you may run into errors if you've skipped previous steps."
I'm getting the following error on the admin beginner trail; create and share a dashboard in the reports and dashboards module: There was an unhandled exception. Please reference ID: HCOAKAFC. Error: Faraday::Error::ResourceNotFound. Message: NOT_FOUND: The requested resource does not exist.

I went through other posts that reported the same error and most reference the presence of a namespace. I'm using a new org with no namespace registered so am not sure what the cause is. I'm wondering if it's related to the fact that I can't access the chatter tab in this org. I keep getting a data access error to the reocrds I'm trying to merge every time I click on the chatter tab. 

I just refreshed our sandbox and now cannot create a new Connected App. With each (unique) app name I get the error:

 

The application name [app-name] / [app-name] has been used before. Use a new unique name for your application.

 

See this screenshot

 

Thanks

Jeff Douglas

Appirio

We are using the Databasedotcom Ruby gem (essentially a REST wrapper) to authenticate to salesforce. The OAuth dance is randomly failing (1 out of 25 attempts) with the following message: 

 

client identifier invalid

 

The code is almost boilerplace code for authentication:

 

def self.authenticate(username, password)
  config = YAML.load_file(File.join(::Rails.root, 'config', 'databasedotcom.yml'))
  client = Databasedotcom::Client.new(config)
  begin
    access_token = client.authenticate :username => username, :password => password
    {:success => 'true', :message => 'Successful sfdc login.', :access_token => access_token}
  rescue Exception => exc
    {:success => 'false', :message => exc.message}
  end
end

 

Any ideas what could be causing it to fail randomly?

 

Thanks

 

Jeff Douglas

Appirio & CloudSpokes

http://blog.jeffdouglas.com

 

 

Any tips on using Coldfusion MX - when I try to add the web service to my server components in Dreamweaver using the WSDL file I receive an error indicating that SalesforceConnector.class does not exist.