• ddddavo
  • NEWBIE
  • 5 Points
  • Member since 2011

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 5
    Questions
  • 26
    Replies
I'm trying to force sequential operation within a VF page, waiting for one pop up to exit before closing the original page.

The use case is this:
  • quickaction button calls VF page
  • VF page runs javascript that calls sforce.one.editRecord
  • once the sforce.one popup is closed, then and only then
  • close the originating page
I know how to do everything except the asynch wait between the second and third bullet. If at all possible, please provide a code sample that is known to work, rather than an abstract discussion.

Hi.

 

I'm doing a fresh install of the IDE downloaded Nov 20.  Install sequence appears to work, the basic Eclipse Provisioning Workbench comes up.

 

But none of the SFDC features seem to have actually been installed--the menu items are generic and it seems that the features are waiting to be fully installed.  I select the HELP menu, select the Software and Workspace center.  In the Dashboard view, the summary of software shows Eclipse Platform and SDK, Force.com IDE, and Pulse Services and Extensions as being in a state of "To Install".  Looking in the About This Profile area (lower left of screen) the install state is shown as "Not Currently Installed."  The "Install This Profile" area (to the right of the About area) makes it LOOK like all you have to do is push the big green button to affect the install.

 

But the button isn't a button:  it's just a dead icon.

 

What am I missing????  I know I'm blind and stupid and everything, but I honestly can't see how to proceed.

 

System is running WinXP Pro on JDK 1.7 update 9.  Force.com IDE installer file is nominally 23.0.0.0, but the actual payload that's supposed to be inswtalling is v26 of the IDE.

Hi all,

 

We all know that you shouldn't ever ever ever make code changes directly to production orgs.  The logical path is always to do your work in sandbox and push to production.

 

But what if you can't push to production, due to errors in code that are totally outside of your control?  Here's a scenario I bump into:

  • I deploy code
  • Later, client adds some code from other sources (AppExch, etc.)
  • Even later, client makes changes to picklists or adds validation rules
  • Now, the third party code always fails its tests...which means I can't deploy any code fixes I need to into the production org.
  • Which means we have to wait around for the thirt parties to stop finger-pointing and actually get their tests to execute without errors

In the good old days, there were ways you could edit code directly in the production org (the modules had to exist in the org already, but at least you could modify them) without running all the tests there.  So you could squeak by when there were emergency patches to be done.  But this doesn't appear to be true any more.

 

Of course, this situation should never happen.  But I've had it happen twice in a month at two separate clients.

 

Any ideas for work-arounds (assuming I'm using only tools that work on Windows)?  Isn't there a way to just "save" a file to production, without re-running all the tests?

Hi Simon,

 

First off, thanks for creating the APEXmate plug-in.  It saved our bacon today.

 

Unforunately, it only seems to run on the real TextMate.  The guys who produce the E texteditor claim that it runs "most" if not all plugins...but I couldn't get yours to work.  When I ask it to log in, nothing shows up...and since I can't login, nothing else works.

 

Any clues?

 

You might ask "why do I care?"  There appears to be a new behavior in the Eclipse editor, where it will no longer do emergency patches into a production org.  You have to run-all-tests just like a deployment.  Problem is, my client has an org that's so messed up that (1) run-all-tests takes hours to complete and when it does (2) it throws errors generated by a managed package.  We can't even deploy a one-line system.debug statement to see what's really blowing up!

In the old days, eclipse let you save-to-production just by running YOUR tests, not everybody else's drek.  The SFDC ANT plugin now makes you do the run-all-tests dance as well.   

 

So the only way to do this now is for me to bother my Mac friends and get them to use Textmate to do the emergency fixes.  As annoying for them as it is for me...how they taunt me that I should just break down and get a mac.

 

Sorry for the diatribe, but I hope it adds some local color.

 

thanks in advance for any tips except "just buy a Mac"

I'm using a DE to set up a system, and I need to delete the first record type I created for Accounts.

 

The system won't let me because it says that this is the default record type for the Force.com Free Profile...which is bug #1 because that profile doesn't allow access to the Account object.

 

Which means that when you go to that profile to change the default record type, you can't.  I've set the default record type for all other profiles to be something else, but I still get the error message.

 

Which leads to bug #2:  if your org has the force.com free profile, you can't delete the first record type you created.

 

 

Hi.

 

I'm doing a fresh install of the IDE downloaded Nov 20.  Install sequence appears to work, the basic Eclipse Provisioning Workbench comes up.

 

But none of the SFDC features seem to have actually been installed--the menu items are generic and it seems that the features are waiting to be fully installed.  I select the HELP menu, select the Software and Workspace center.  In the Dashboard view, the summary of software shows Eclipse Platform and SDK, Force.com IDE, and Pulse Services and Extensions as being in a state of "To Install".  Looking in the About This Profile area (lower left of screen) the install state is shown as "Not Currently Installed."  The "Install This Profile" area (to the right of the About area) makes it LOOK like all you have to do is push the big green button to affect the install.

 

But the button isn't a button:  it's just a dead icon.

 

What am I missing????  I know I'm blind and stupid and everything, but I honestly can't see how to proceed.

 

System is running WinXP Pro on JDK 1.7 update 9.  Force.com IDE installer file is nominally 23.0.0.0, but the actual payload that's supposed to be inswtalling is v26 of the IDE.

i not understanding usage of junction object .

Please explain usage and how to create junction object with a example

Hi all,

 

We all know that you shouldn't ever ever ever make code changes directly to production orgs.  The logical path is always to do your work in sandbox and push to production.

 

But what if you can't push to production, due to errors in code that are totally outside of your control?  Here's a scenario I bump into:

  • I deploy code
  • Later, client adds some code from other sources (AppExch, etc.)
  • Even later, client makes changes to picklists or adds validation rules
  • Now, the third party code always fails its tests...which means I can't deploy any code fixes I need to into the production org.
  • Which means we have to wait around for the thirt parties to stop finger-pointing and actually get their tests to execute without errors

In the good old days, there were ways you could edit code directly in the production org (the modules had to exist in the org already, but at least you could modify them) without running all the tests there.  So you could squeak by when there were emergency patches to be done.  But this doesn't appear to be true any more.

 

Of course, this situation should never happen.  But I've had it happen twice in a month at two separate clients.

 

Any ideas for work-arounds (assuming I'm using only tools that work on Windows)?  Isn't there a way to just "save" a file to production, without re-running all the tests?

Hi,

 

Trying to get information from SObjects in order to know the last Update date information of each one, I found some issues with VBA SFDC library:

 

  1. SForceSession4.EntityNames array cannot be used as parameter to SForceSession4.DescribeSObjects because it is a Variant array. Ok, let's take the EntityNames array and construct an array of string with it. This will avoid the "Run-time error. Automation error. Unespecified error" message
  2. After fixing the previous issue, the DescribeSObjects works but, where is the description of each SObject described? 
  3. If we use the Object Browser in VBA IDE, we can see that Salesforce Toolkit 4.0, SForceSession4.DescribeSObjects  is a SUB and NOT a FUNCTION, even more, there is no DescribeSObjectResult type in the DLL that will allow us to check the description of each described object

 

Does anyone have an idea of how to use this DescribeSObjects sub?

 

Thanks!

  • April 16, 2012
  • Like
  • 0

HI.

 

I am following the Warehouse app Tutorial.

I am at Tutorial #7.

Just finished down-loading the Force.com IDE but don't know how to create a project.

The instruction are saying to select FILe->New but under File the only options I am getting are: Exit, Open File and Convert Line delimiters to...

 

Help will be much appreciated!

 

New to SF

Hi Simon,

 

First off, thanks for creating the APEXmate plug-in.  It saved our bacon today.

 

Unforunately, it only seems to run on the real TextMate.  The guys who produce the E texteditor claim that it runs "most" if not all plugins...but I couldn't get yours to work.  When I ask it to log in, nothing shows up...and since I can't login, nothing else works.

 

Any clues?

 

You might ask "why do I care?"  There appears to be a new behavior in the Eclipse editor, where it will no longer do emergency patches into a production org.  You have to run-all-tests just like a deployment.  Problem is, my client has an org that's so messed up that (1) run-all-tests takes hours to complete and when it does (2) it throws errors generated by a managed package.  We can't even deploy a one-line system.debug statement to see what's really blowing up!

In the old days, eclipse let you save-to-production just by running YOUR tests, not everybody else's drek.  The SFDC ANT plugin now makes you do the run-all-tests dance as well.   

 

So the only way to do this now is for me to bother my Mac friends and get them to use Textmate to do the emergency fixes.  As annoying for them as it is for me...how they taunt me that I should just break down and get a mac.

 

Sorry for the diatribe, but I hope it adds some local color.

 

thanks in advance for any tips except "just buy a Mac"

Hi,

 

Unable to fetch and save Force.com Components to Project: com.salesforce.ide.api.metadata.types.Metadata$JaxAccessorF_fullName cannot be cast to com.sun.xm.internal.bind.v2.runtime.reflect.Accessor

 

Abort or Continute Force.com project creation?

==============

while i am creating a new force.com project i got this error: can u please tell me why this error came. i downloaded eclipse and added force.com ide.... when i try to creating a new force.com project i got this error... and i am able to create a force.com project but not getting all existing classes and pages. And not added my new page or class content to the sever when i save. Is it required any other software installations?

 

I have the Salesforce Toolkit installed, and the SForceOfficeToolkitLib4 is showing up in the VBA object browser and is enabled and in the VBA Tools -> References the SForceOfficeToolkit4 v4.0 is showing and is checked.

 

When I run the following code to login I get a VBA error 429 ActiveX cannot create object on the CreateObject call.

 

I'm running Windows 7 64-bit and Office 2010 64-bit.  

 


Dim g_sfApi As SForceOfficeToolkitLib4.SForceSession4

 

Public Function SF_Login() As Long

        Set g_sfApi = CreateObject("SForceOfficeToolkitLib4.SForceSession4")
   
        If g_sfApi.Login("XXX", "YYY") = False Then
            MsgBox (g_sfApi.ErrorMessage)
        End If
end function

 

What am I missing in this setup?   Does SalesForce.com not work with the latest release of Office 2010 or Windows 7?

 

Ian

I can successfully connect to and query data via the Excel connector. Now I am trying to pull archived data from Task and Event. Is it possible to QueryAll and not just Query via the connector?

 

Any suggestions onhow todo this?

 

\TIA

I'm using the textmate plugin for salesforce. Any chance the associated apexloader.app will be updated, or perhaps the source released?

 

The eclipse ide is just too fragile, so I'm developing using TextMate as editor with ant migration tool for uploading, but Salesforce_com.tmbundle is great for recompiling just one class or trigger at a time.

Message Edited by Shikibu on 03-19-2009 08:25 AM